- Update to latest upstream release 2011.08.10

- Add LICENSE*

PR:		192402
Submitted by:	shoesoft@gmx.net (maintainer)
Approved by:	mentors (implicit)
This commit is contained in:
Thomas Zander 2014-08-08 19:02:40 +00:00
parent 3771849700
commit 3533d6ca03
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364375
6 changed files with 19 additions and 64 deletions

View file

@ -2,15 +2,17 @@
# $FreeBSD$
PORTNAME= musepack
PORTVERSION= 2009.03.01
PORTREVISION= 2
PORTVERSION= 2011.08.10
CATEGORIES= audio
MASTER_SITES= http://files.musepack.net/source/
DISTNAME= ${PORTNAME}_src_r435
DISTNAME= ${PORTNAME}_src_r475
MAINTAINER= shoesoft@gmx.net
COMMENT= Decoder, encoder, and replaygain for musepack (mpc)
LICENSE= BSD3CLAUSE GPLv2 LGPL21 #or later for the (L)GPL'ed part
LICENSE_COMB= multi
USES= libtool
USE_LDCONFIG= yes
USE_AUTOTOOLS= aclocal autoheader libtoolize automake autoconf

View file

@ -1,2 +1,2 @@
SHA256 (musepack_src_r435.tar.gz) = 9fc1f4d0a88560590f377a3194a4b9b597966c9df91283aa7136fd3b120e43b2
SIZE (musepack_src_r435.tar.gz) = 194149
SHA256 (musepack_src_r475.tar.gz) = a4b1742f997f83e1056142d556a8c20845ba764b70365ff9ccf2e3f81c427b2b
SIZE (musepack_src_r475.tar.gz) = 188737

View file

@ -1,7 +0,0 @@
--- Makefile.am.orig 2008-03-25 15:31:41.000000000 +0100
+++ Makefile.am 2010-05-16 18:04:14.000000000 +0200
@@ -1,3 +1,3 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = include libmpcdec libmpcenc libmpcpsy libwavformat mpcenc mpc2sv8 \
- mpcchap mpccut mpcdec mpcgain wavcmp
+ mpccut mpcdec wavcmp

View file

@ -0,0 +1,12 @@
--- configure.in.orig 2014-08-04 08:34:39.000000000 +0200
+++ configure.in 2014-08-04 08:35:20.000000000 +0200
@@ -30,7 +30,8 @@
AM_CONDITIONAL([MPC_CHAP], [test "x$enable_mpcchap" = xyes])
-CHECK_VISIBILITY
+gl_VISIBILITY
+AM_CONDITIONAL([HAVE_VISIBILITY], [test "x$HAVE_VISIBILITY" = x1])
AC_CONFIG_FILES([
Makefile

View file

@ -1,25 +0,0 @@
--- ./libmpcenc/encode_sv7.c.orig 2009-02-23 19:15:46.000000000 +0100
+++ ./libmpcenc/encode_sv7.c 2010-05-16 17:59:52.000000000 +0200
@@ -24,6 +24,8 @@
#include "libmpcenc.h"
#include <mpc/minimax.h>
+#define log2(x) ( log (x) * (1./M_LN2) )
+
void Klemm ( void );
void Init_Skalenfaktoren ( void );
@@ -437,11 +439,11 @@
total_cnt += sym[j][i].Count;
total_size += sym[j][i].Count * sym[j][i].Bits;
if (sym[j][i].Count != 0)
- optim_size += sym[j][i].Count * __builtin_log2(sym[j][i].Count);
+ optim_size += sym[j][i].Count * log2(sym[j][i].Count);
}
full_count += total_cnt;
full_size += total_size;
- optim_size = total_cnt * __builtin_log2(total_cnt) - optim_size;
+ optim_size = total_cnt * log2(total_cnt) - optim_size;
full_optim += optim_size;
size[j] = total_size;
cnt[j] = total_cnt;

View file

@ -1,27 +0,0 @@
--- ./common/huffman-bcl.c.orig 2007-03-17 00:25:28.000000000 +0100
+++ ./common/huffman-bcl.c 2010-05-16 18:01:56.000000000 +0200
@@ -30,9 +30,12 @@
* marcus.geelnard at home.se
*************************************************************************/
+#include <math.h>
#include <stdio.h>
#include <stdlib.h>
+#define log2(x) ( log (x) * (1./M_LN2) )
+
typedef struct {
int Symbol;
unsigned int Count;
@@ -265,9 +268,9 @@
total_cnt += sym[i].Count;
total_size += sym[i].Count * sym[i].Bits;
if (sym[i].Count != 0)
- optim_size += sym[i].Count * __builtin_log2(sym[i].Count);
+ optim_size += sym[i].Count * log2(sym[i].Count);
}
- optim_size = total_cnt * __builtin_log2(total_cnt) - optim_size;
+ optim_size = total_cnt * log2(total_cnt) - optim_size;
printf("\ncount : %u huff : %f bps ", total_cnt, (float)total_size / total_cnt);
printf("opt : %f bps ", (float)optim_size / total_cnt);
printf("loss : %f bps (%f %%)\n", (float)(total_size - optim_size) / total_cnt, (float)(total_size - optim_size) * 100 / optim_size);