- New port: devel/dfmt
dfmt is a formatter for D source code. dfmt is beta quality. Make backups of your files or use source control when using the --inplace option. WWW: https://github.com/dlang-community/dfmt
This commit is contained in:
parent
c044c1fca4
commit
35537a31e9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=446448
5 changed files with 53 additions and 0 deletions
|
@ -426,6 +426,7 @@
|
|||
SUBDIR += dev86
|
||||
SUBDIR += devhelp
|
||||
SUBDIR += devtodo
|
||||
SUBDIR += dfmt
|
||||
SUBDIR += dfuife-curses
|
||||
SUBDIR += dia2code
|
||||
SUBDIR += dia2code+
|
||||
|
|
33
devel/dfmt/Makefile
Normal file
33
devel/dfmt/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dfmt
|
||||
DISTVERSION= 0.5.0beta5
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://github.com/dlang-community/dfmt/archive/
|
||||
DISTNAME= ${DISTVERSION:S/^/v/:S/beta5/-beta.5/}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= acm@FreeBSD.org
|
||||
COMMENT= Formatter for D source code
|
||||
|
||||
LICENSE= BSL
|
||||
|
||||
BUILD_DEPENDS= ldmd2:lang/ldc \
|
||||
dub:devel/dub \
|
||||
${LOCALBASE}/lib/d/libdparse.a:devel/libdparse
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/beta5/-beta.5/}
|
||||
DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/dub.json
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC} && ${DUB_CMD}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/dfmt/distinfo
Normal file
3
devel/dfmt/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1500780668
|
||||
SHA256 (dfmt/v0.5.0-beta.5.tar.gz) = 3d12017b6356db493eba44e46b75d3b87f0fc659a68c47c96562a90f9a2b634d
|
||||
SIZE (dfmt/v0.5.0-beta.5.tar.gz) = 66900
|
12
devel/dfmt/files/patch-dub.json
Normal file
12
devel/dfmt/files/patch-dub.json
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- dub.json.orig 2017-02-13 19:03:07 UTC
|
||||
+++ dub.json
|
||||
@@ -3,7 +3,6 @@
|
||||
"description": "Dfmt is a formatter for D source code",
|
||||
"targetType": "executable",
|
||||
"license": "BSL-1.0",
|
||||
- "dependencies": {
|
||||
- "libdparse": "~>0.7.0-beta.6"
|
||||
- }
|
||||
+ "libs": ["dparse"],
|
||||
+ "lflags": ["-L%%LOCALBASE%%/lib/d"],
|
||||
}
|
4
devel/dfmt/pkg-descr
Normal file
4
devel/dfmt/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
dfmt is a formatter for D source code. dfmt is beta quality. Make backups of
|
||||
your files or use source control when using the --inplace option.
|
||||
|
||||
WWW: https://github.com/dlang-community/dfmt
|
Loading…
Reference in a new issue