- Update to 0.7.0

- Update home page and MASTER_SITE

Approved by:	crees (mentor)
This commit is contained in:
Guido Falsi 2012-05-08 20:10:59 +00:00
parent a9913f53c0
commit 35c99001ac
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296247
8 changed files with 53 additions and 56 deletions

View file

@ -6,9 +6,9 @@
#
PORTNAME= abraca
PORTVERSION= 0.6.0
PORTVERSION= 0.7.0
CATEGORIES= audio
MASTER_SITES= LOCAL/madpilot/abraca
MASTER_SITES= http://cloud.github.com/downloads/Abraca/Abraca/
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Abraca is a GTK2 client for the XMMS2 music player
@ -18,17 +18,30 @@ LIB_DEPENDS= xmmsclient.6:${PORTSDIR}/audio/xmms2 \
gee.2:${PORTSDIR}/devel/libgee
USE_SCONS= yes
USE_GNOME= gtk20
USE_GNOME= gtk30
PLIST_FILES= bin/${PORTNAME}
SCONS_ARGS= MANDIR=${MANPREFIX}/man
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/src/${PORTNAME} ${PREFIX}/bin
MAN1= abraca.1
MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
OPTIONS= NLS "Enable gettext support" on
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.include <bsd.port.options.mk>
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS='@comment '
.else
PLIST_SUB+= NLS=''
USE_GETTEXT= yes
.endif
.include <bsd.port.post.mk>
post-configure:
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} -e 's/%%NLS%%/0/' ${WRKSRC}/SConstruct
.else
@${REINPLACE_CMD} -e 's/%%NLS%%/1/' ${WRKSRC}/SConstruct
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (abraca-0.6.0.tar.gz) = ff40ab90904036e9493658b446c1251135a2f507f9c00e2c7cf115db21a6be75
SIZE (abraca-0.6.0.tar.gz) = 403184
SHA256 (abraca-0.7.0.tar.gz) = 4004e0aa2ec1e8422d3748e1bacb99d71823d0d5a4226c55771252cc6948ec27
SIZE (abraca-0.7.0.tar.gz) = 684007

View file

@ -0,0 +1,18 @@
--- SConstruct.orig 2012-03-19 01:54:28.000000000 +0100
+++ SConstruct 2012-05-07 22:47:08.390528582 +0200
@@ -59,7 +59,7 @@
conf.Finish()
env.Append(VALAPKGS = ['build-config'])
-env.Append(CCFLAGS = ['-Wall', '-Wno-unused-variable', '-Wno-unused-but-set-variable'])
+env.Append(CCFLAGS = ['-Wall', '-Wno-unused-variable'])
#env.Append(CCFLAGS = ['-Wall', '-Wno-unused-variable', '-Wno-unused-but-set-variable', '-DHAVE_AVAHI_0_6'])
env.Append(CPPPATH = Dir('build'))
env.Append(LIBS = ['m'])
@@ -74,4 +74,5 @@
env.SConscript('build/data/ui/SConscript', exports='env', duplicate=0)
env.SConscript('build/src/SConscript', exports='env', duplicate=0)
env.SConscript('build/gladeui/SConscript', exports='env', duplicate=0)
-env.SConscript('build/po/SConscript', exports='env', duplicate=0)
+if %%NLS%%:
+ env.SConscript('build/po/SConscript', exports='env', duplicate=0)

View file

@ -1,12 +0,0 @@
--- ./src/components/filter/filter_view.vala.orig 2011-06-24 14:40:14.000000000 +0200
+++ ./src/components/filter/filter_view.vala 2011-06-24 14:41:00.000000000 +0200
@@ -370,7 +370,8 @@ namespace Abraca {
} else {
order = Gtk.SortType.DESCENDING;
}
- sorting = {column.title, order};
+ Sorting tmp = {column.title, order};
+ sorting = tmp;
break;
}
}

View file

@ -1,20 +0,0 @@
--- src/coverart.vala.orig 2011-06-24 14:41:53.000000000 +0200
+++ src/coverart.vala 2011-06-24 14:42:25.000000000 +0200
@@ -412,7 +412,7 @@ namespace Abraca {
if (!get_track_ids (candidates, pixbuf, out ids))
return true;
- char[] buffer;
+ uint8[] buffer;
if (!pixbuf.save_to_buffer (out buffer, "png"))
return true;
@@ -420,7 +420,7 @@ namespace Abraca {
/* TODO: Need to store ids here due to a Vala reference bug. */
selected_ids = ids;
- client.xmms.bindata_add ((uint8[]) buffer).notifier_set (on_bindata_add);
+ client.xmms.bindata_add (buffer).notifier_set (on_bindata_add);
return true;

View file

@ -1,11 +0,0 @@
--- src/toolbar.vala.orig 2011-06-24 14:42:58.000000000 +0200
+++ src/toolbar.vala 2011-06-24 14:43:11.000000000 +0200
@@ -343,7 +343,7 @@ namespace Abraca {
try {
var loader = new Gdk.PixbufLoader();
- loader.write(data, data.length);
+ loader.write(data);
loader.close();
var pixbuf = loader.get_pixbuf();

View file

@ -1,4 +1,4 @@
Abraca is a GTK2 client for the XMMS2 music player. It is designed with
collections in mind, which makes managing your music a breeze.
WWW: http://abraca.xmms.se/wiki/abraca
WWW: http://abraca.github.com/Abraca

9
audio/abraca/pkg-plist Normal file
View file

@ -0,0 +1,9 @@
bin/abraca
share/applications/abraca.desktop
share/icons/abraca.svg
%%NLS%%share/locale/de/LC_MESSAGES/abraca.mo
%%NLS%%share/locale/en/LC_MESSAGES/abraca.mo
%%NLS%%share/locale/nl/LC_MESSAGES/abraca.mo
%%NLS%%share/locale/sv/LC_MESSAGES/abraca.mo
@dirrmtry share/icons
@dirrmtry share/applications