- Update to 1.1
PR: ports/153465 Submitted by: Andrei Lavreniyuk <andy.lavr@gmail.com> (maintainer)
This commit is contained in:
parent
56f938e7f1
commit
35c9a5f399
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267613
5 changed files with 5 additions and 121 deletions
|
@ -5,12 +5,11 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= torsocks
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= net security
|
||||
MASTER_SITES= GOOGLE_CODE \
|
||||
http://tor.reactor-xg.kiev.ua/files/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-epsilon
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= andy.lavr@gmail.com
|
||||
COMMENT= Most SOCKS-friendly applications way with Tor
|
||||
|
@ -27,18 +26,13 @@ MAN8= torsocks.8
|
|||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
OPTIONS= TORDNS "Use tordns" on \
|
||||
SOCKSDNS "Use socks server for DNS lookups" off \
|
||||
OPTIONS= SOCKSDNS "Use socks server for DNS lookups" off \
|
||||
OLDMETHOD "Do not use RTLD_NEXT parameter to dlsym" off \
|
||||
NODEBUG "Disable output of error messages" off \
|
||||
HOSTNAMES "Disable DNS lookups of socks server" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_TORDNS)
|
||||
CONFIGURE_ARGS+= --disable-tordns
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SOCKSDNS)
|
||||
CONFIGURE_ARGS+= --enable-socksdns
|
||||
.endif
|
||||
|
@ -60,15 +54,6 @@ BROKEN= HOSTNAMES option is necessary if SOCKSDNS option is enabled
|
|||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITHOUT_TORDNS)
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "You can deselect the TORDNS option."
|
||||
@${ECHO_MSG} "This option disables tordns, which causes"
|
||||
@${ECHO_MSG} "names to be looked up in a way designed to"
|
||||
@${ECHO_MSG} "work well with Tor."
|
||||
@${ECHO_MSG}
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_SOCKSDNS)
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "You can use the SOCKSDNS option."
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (torsocks-1.0-epsilon.tar.gz) = 5f00676da97f198f95614db6e2804f35
|
||||
SHA256 (torsocks-1.0-epsilon.tar.gz) = e5aad7362462e8f76b6de6d9e6321e2e16ad8895e1a300b6ca19d49730890814
|
||||
SIZE (torsocks-1.0-epsilon.tar.gz) = 669553
|
||||
SHA256 (torsocks-1.1.tar.gz) = 09dac54c2bb4e57cfdc449dc45b97be832910a4d81d5a2931543b469d97fdf01
|
||||
SIZE (torsocks-1.1.tar.gz) = 674386
|
||||
|
|
|
@ -15,58 +15,3 @@
|
|||
|
||||
AC_CHECK_LIB(resolv, res_query, [ tempres="no" ],tempres="yes")
|
||||
if test "$tempres" = "no"; then
|
||||
@@ -356,8 +354,8 @@
|
||||
dnl Find the correct res_querydomain prototype on this machine
|
||||
AC_MSG_CHECKING(for correct res_querydomain prototype)
|
||||
PROTO=
|
||||
-PROTO1='const char *name, const char *domain, int class, int type, unsigned char *answer, int anslen'
|
||||
-for testproto in "${PROTO1}"
|
||||
+PROTO1='const char *name, const char *domain, int class, int type, u_char *answer, int anslen'
|
||||
+for PROTO in "${PROTO1}"
|
||||
do
|
||||
if test "${PROTO}" = ""; then
|
||||
AC_TRY_COMPILE([
|
||||
@@ -378,9 +376,9 @@
|
||||
AC_MSG_CHECKING(for correct res_send prototype)
|
||||
PROTO=
|
||||
PROTO1='const char *msg, int msglen, char *answer, int anslen'
|
||||
-PROTO2='const unsigned char *msg, int msglen, unsigned char *answer, int anslen'
|
||||
-for testproto in "${PROTO1}" \
|
||||
- "${PROTO2}"
|
||||
+PROTO2='const u_char *msg, int msglen, u_char *answer, int anslen'
|
||||
+for PROTO in "${PROTO1}" \
|
||||
+ "${PROTO2}"
|
||||
do
|
||||
if test "${PROTO}" = ""; then
|
||||
AC_TRY_COMPILE([
|
||||
@@ -401,8 +399,8 @@
|
||||
dnl Find the correct res_search prototype on this machine
|
||||
AC_MSG_CHECKING(for correct res_search prototype)
|
||||
PROTO=
|
||||
-PROTO1='const char *dname, int class, int type,unsigned char *answer, int anslen'
|
||||
-for testproto in "${PROTO1}"
|
||||
+PROTO1='const char *dname, int class, int type, u_char *answer, int anslen'
|
||||
+for PROTO in "${PROTO1}"
|
||||
do
|
||||
if test "${PROTO}" = ""; then
|
||||
AC_TRY_COMPILE([
|
||||
@@ -423,8 +421,8 @@
|
||||
dnl Find the correct res_query prototype on this machine
|
||||
AC_MSG_CHECKING(for correct res_query prototype)
|
||||
PROTO=
|
||||
-PROTO1='const char *dname, int class, int type,unsigned char *answer, int anslen'
|
||||
-for testproto in "${PROTO1}"
|
||||
+PROTO1='const char *dname, int class, int type, u_char *answer, int anslen'
|
||||
+for PROTO in "${PROTO1}"
|
||||
do
|
||||
if test "${PROTO}" = ""; then
|
||||
AC_TRY_COMPILE([
|
||||
@@ -471,7 +469,7 @@
|
||||
dnl Find the correct poll prototype on this machine
|
||||
AC_MSG_CHECKING(for correct poll prototype)
|
||||
PROTO=
|
||||
-for testproto in 'struct pollfd *ufds, unsigned long nfds, int timeout' \
|
||||
+for testproto in 'struct pollfd *ufds, u_long nfds, int timeout' \
|
||||
'struct pollfd *ufds, nfds_t nfds, int timeout' \
|
||||
'struct pollfd *pfd, unsigned int nfds, int timeout'
|
||||
do
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
--- src/torsocks.in.orig 2008-12-08 23:43:55.000000000 +0200
|
||||
+++ src/torsocks.in 2009-03-01 22:31:16.263795616 +0200
|
||||
@@ -72,16 +72,16 @@
|
||||
on)
|
||||
if [ -z "$LD_PRELOAD" ]
|
||||
then
|
||||
- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so"
|
||||
+ export LD_PRELOAD="@prefix@/lib/libtorsocks.so"
|
||||
else
|
||||
- echo $LD_PRELOAD | grep -q "@prefix@/lib/torsocks/libtorsocks\.so" || \
|
||||
- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so $LD_PRELOAD"
|
||||
+ echo $LD_PRELOAD | grep -q "@prefix@/lib/libtorsocks\.so" || \
|
||||
+ export LD_PRELOAD="@prefix@/lib/libtorsocks.so $LD_PRELOAD"
|
||||
fi
|
||||
;;
|
||||
off)
|
||||
#replace '/' with '\/' in @prefix@
|
||||
escprefix=`echo '@prefix@' |sed 's/\\//\\\\\//g'`
|
||||
- export LD_PRELOAD=`echo -n $LD_PRELOAD | sed "s/$escprefix\/lib\/torsocks\/libtorsocks.so \?//"`
|
||||
+ export LD_PRELOAD=`echo -n $LD_PRELOAD | sed "s/$escprefix\/lib\/libtorsocks.so \?//"`
|
||||
if [ -z "$LD_PRELOAD" ]
|
||||
then
|
||||
unset LD_PRELOAD
|
||||
@@ -96,10 +96,10 @@
|
||||
*)
|
||||
if [ -z "$LD_PRELOAD" ]
|
||||
then
|
||||
- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so"
|
||||
+ export LD_PRELOAD="@prefix@/lib/libtorsocks.so"
|
||||
else
|
||||
- echo $LD_PRELOAD | grep -q "@prefix@/lib/torsocks/libtorsocks\.so" || \
|
||||
- export LD_PRELOAD="@prefix@/lib/torsocks/libtorsocks.so $LD_PRELOAD"
|
||||
+ echo $LD_PRELOAD | grep -q "@prefix@/lib/libtorsocks\.so" || \
|
||||
+ export LD_PRELOAD="@prefix@/lib/libtorsocks.so $LD_PRELOAD"
|
||||
fi
|
||||
|
||||
if [ $# = 0 ]
|
|
@ -14,14 +14,6 @@
|
|||
/* Global configuration variables */
|
||||
const char *progname = "libtorsocks"; /* Name used in err msgs */
|
||||
|
||||
@@ -62,7 +69,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <string.h>
|
||||
#include <strings.h>
|
||||
@@ -163,7 +169,7 @@
|
||||
void tsocks_init(void) {
|
||||
|
||||
|
|
Loading…
Reference in a new issue