Add tkXwin - Tcl/Tk library to detect idle periods of an X session.
PR: 84940 Submitted by: Denis Shaposhnikov <dsh@vlink.ru> Approved by: perky (mentor)
This commit is contained in:
parent
69ef7dcc8d
commit
35cf5bb596
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=141568
7 changed files with 78 additions and 0 deletions
|
@ -174,6 +174,7 @@
|
|||
SUBDIR += sxpc
|
||||
SUBDIR += temperature.app
|
||||
SUBDIR += thinglaunch
|
||||
SUBDIR += tkXwin
|
||||
SUBDIR += tkgoodstuff
|
||||
SUBDIR += tycoon
|
||||
SUBDIR += vdesk
|
||||
|
|
34
x11/tkXwin/Makefile
Normal file
34
x11/tkXwin/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# New ports collection makefile for: tkXwin
|
||||
# Date created: Tue Aug 9 14:32:29 MSD 2005
|
||||
# Whom: Denis Shaposhnikov <dsh@vlink.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tkXwin
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://beepcore-tcl.sourceforge.net/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= dsh@vlink.ru
|
||||
COMMENT= Tcl/Tk library to detect idle periods of an X session
|
||||
|
||||
LIB_DEPENDS= tcl${SHORT_TK_VER}:${PORTSDIR}/lang/tcl${SHORT_TK_VER} \
|
||||
tk${SHORT_TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X_PREFIX= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
|
||||
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
|
||||
--with-tclinclude=${LOCALBASE}/include/tcl${TK_VER} \
|
||||
--with-tk=${LOCALBASE}/lib/tk${TK_VER} \
|
||||
--with-tkinclude=${LOCALBASE}/include/tk${TK_VER}
|
||||
CONFIGURE_ENV= INSTALL="${INSTALL_DATA}"
|
||||
|
||||
TK_VER= 8.4
|
||||
SHORT_TK_VER= ${TK_VER:S/.//}
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11/tkXwin/distinfo
Normal file
2
x11/tkXwin/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (tkXwin-1.0.tgz) = 1750b22a9b8e68013083d058562d4b65
|
||||
SIZE (tkXwin-1.0.tgz) = 168650
|
22
x11/tkXwin/files/patch-Makefile.in
Normal file
22
x11/tkXwin/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- Makefile.in.orig Sun Aug 25 10:29:52 2002
|
||||
+++ Makefile.in Tue Aug 9 15:09:49 2005
|
||||
@@ -14,8 +14,8 @@
|
||||
#
|
||||
|
||||
# if you have libXss.so, then uncomment the next two lines
|
||||
-#CFLAGS_XSS = -DHAVE_SHARED_XSS
|
||||
-#LIB_XSS = -L/usr/X11R6/lib -lXss
|
||||
+CFLAGS_XSS = -DHAVE_SHARED_XSS
|
||||
+LIB_XSS = -L/usr/X11R6/lib -lXss
|
||||
|
||||
|
||||
SHELL = @SHELL@
|
||||
@@ -145,7 +145,7 @@
|
||||
|
||||
tkXwin_version = 1:0:0
|
||||
|
||||
-INCLUDES = $(TCL_INCLUDES) $(TK_XINCLUDES) $(CFLAGS_XSS)
|
||||
+INCLUDES = $(TCL_INCLUDES) $(TK_INCLUDES) $(TK_XINCLUDES) $(CFLAGS_XSS)
|
||||
|
||||
common_sources = tkXwin.c
|
||||
|
11
x11/tkXwin/files/patch-configure
Normal file
11
x11/tkXwin/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Tue Aug 30 14:52:03 2005
|
||||
+++ configure Tue Aug 30 14:52:18 2005
|
||||
@@ -1798,7 +1798,7 @@
|
||||
AS="$AS" DLLTOOL="$DLLTOOL" OBJDUMP="$OBJDUMP" \
|
||||
objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
|
||||
deplibs_check_method="$deplibs_check_method" file_magic_cmd="$file_magic_cmd" \
|
||||
-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
|
||||
+$ac_aux_dir/ltconfig --no-reexec \
|
||||
$libtool_flags --no-verify --build="$build" $ac_aux_dir/ltmain.sh $host \
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
|
1
x11/tkXwin/pkg-descr
Normal file
1
x11/tkXwin/pkg-descr
Normal file
|
@ -0,0 +1 @@
|
|||
Tcl/Tk library to detect idle periods of an X session.
|
7
x11/tkXwin/pkg-plist
Normal file
7
x11/tkXwin/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
lib/libtkXwin.a
|
||||
lib/libtkXwin.so
|
||||
lib/libtkXwin.so.1
|
||||
@cd %%LOCALBASE%%
|
||||
lib/tkXwin/pkgIndex.tcl
|
||||
lib/tkXwin/test.tcl
|
||||
@dirrm lib/tkXwin
|
Loading…
Reference in a new issue