- Fix GnuTLS detection
- Replace patch-* with REINPLACE_CMD PR: 139871 Submitted by: Marc Lagrange <markocpc@gmail.com> (maintainer)
This commit is contained in:
parent
f5935e17fe
commit
35d1c83e2d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=243539
4 changed files with 31 additions and 33 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= iksemel
|
||||
PORTVERSION= 1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
|
||||
|
@ -15,7 +16,8 @@ COMMENT= XML parser library mainly designed for Jabber applications
|
|||
|
||||
LIB_DEPENDS= gnutls.40:${PORTSDIR}/security/gnutls
|
||||
|
||||
USE_AUTOTOOLS= libtool:22
|
||||
USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262 libtool:22
|
||||
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
@ -23,4 +25,12 @@ USE_LDCONFIG= yes
|
|||
|
||||
INFO= iksemel
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|@setfilename iksemel|@setfilename iksemel.info|' \
|
||||
${WRKSRC}/doc/iksemel.texi
|
||||
@${REINPLACE_CMD} -e 's|pkgconfigdir=$$(libdir)/pkgconfig|pkgconfigdir=$${prefix}/libdata/pkgconfig|' \
|
||||
${WRKSRC}/Makefile.am
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig 2007-08-02 12:49:14.000000000 +0200
|
||||
+++ Makefile.in 2007-10-01 18:22:45.000000000 +0200
|
||||
@@ -187,7 +187,7 @@
|
||||
target_alias = @target_alias@
|
||||
SUBDIRS = include src tools test doc
|
||||
EXTRA_DIST = HACKING iksemel.pc.in
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = ${prefix}/libdata/pkgconfig
|
||||
pkgconfig_DATA = iksemel.pc
|
||||
all: all-recursive
|
||||
|
19
textproc/iksemel/files/patch-configure.ac
Normal file
19
textproc/iksemel/files/patch-configure.ac
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- ./configure.ac.orig 2009-07-23 11:16:36.000000000 +0000
|
||||
+++ ./configure.ac 2009-10-21 11:57:12.768114881 +0000
|
||||
@@ -45,7 +45,15 @@
|
||||
AC_CHECK_FUNCS(getopt_long)
|
||||
AC_CHECK_FUNCS(getaddrinfo)
|
||||
|
||||
-AM_PATH_LIBGNUTLS(,AC_DEFINE(HAVE_GNUTLS,,"Use libgnutls"))
|
||||
+dnl Check GNU TLS
|
||||
+PKG_CHECK_MODULES(GNUTLS, gnutls >= 2.0.0, have_gnutls=yes, have_gnutls=no)
|
||||
+if test "x$have_gnutls" = "xyes"; then
|
||||
+ LIBGNUTLS_CFLAGS="$GNUTLS_CFLAGS"
|
||||
+ LIBGNUTLS_LIBS="$GNUTLS_LIBS"
|
||||
+ AC_SUBST(LIBGNUTLS_CFLAGS)
|
||||
+ AC_SUBST(LIBGNUTLS_LIBS)
|
||||
+ AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
|
||||
+fi
|
||||
|
||||
dnl Check -Wall flag of GCC
|
||||
if test "x$GCC" = "xyes"; then
|
|
@ -1,20 +0,0 @@
|
|||
--- doc/Makefile.in.orig 2007-08-02 12:49:13.000000000 +0200
|
||||
+++ doc/Makefile.in 2007-10-01 21:14:31.000000000 +0200
|
||||
@@ -46,7 +46,7 @@
|
||||
CONFIG_CLEAN_FILES =
|
||||
SOURCES =
|
||||
DIST_SOURCES =
|
||||
-INFO_DEPS = $(srcdir)/iksemel
|
||||
+INFO_DEPS = $(srcdir)/iksemel.info
|
||||
am__TEXINFO_TEX_DIR = $(srcdir)
|
||||
DVIS = iksemel.dvi
|
||||
PDFS = iksemel.pdf
|
||||
@@ -207,7 +207,7 @@
|
||||
distclean-libtool:
|
||||
-rm -f libtool
|
||||
|
||||
-$(srcdir)/iksemel: iksemel.texi
|
||||
+$(srcdir)/iksemel.info: iksemel.texi
|
||||
restore=: && backupdir="$(am__leading_dot)am$$$$" && \
|
||||
am__cwd=`pwd` && cd $(srcdir) && \
|
||||
rm -rf $$backupdir && mkdir $$backupdir && \
|
Loading…
Reference in a new issue