Fix build when SRC_BASE is not /usr/src.

PR:		233626
This commit is contained in:
Jung-uk Kim 2018-11-29 21:12:58 +00:00
parent 085b666fec
commit 35d684efe9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=486207
2 changed files with 7 additions and 7 deletions

View file

@ -3,6 +3,7 @@
PORTNAME= virtualbox-ose PORTNAME= virtualbox-ose
PORTVERSION= 5.2.22 PORTVERSION= 5.2.22
PORTREVISION= 1
CATEGORIES= emulators CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/ MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX?= -additions PKGNAMESUFFIX?= -additions

View file

@ -1,6 +1,6 @@
--- src/VBox/Additions/freebsd/mount_vboxvfs/Makefile.kmk.orig 1970-01-01 01:00:00.000000000 +0100 --- src/VBox/Additions/freebsd/mount_vboxvfs/Makefile.kmk.orig 2018-11-29 19:03:21 UTC
+++ src/VBox/Additions/freebsd/mount_vboxvfs/Makefile.kmk 2017-07-13 00:17:45.342815229 +0200 +++ src/VBox/Additions/freebsd/mount_vboxvfs/Makefile.kmk
@@ -0,0 +1,24 @@ @@ -0,0 +1,23 @@
+# $Id: Makefile.kmk $ +# $Id: Makefile.kmk $
+## @file +## @file
+# Sub-Makefile for the FreeBSD Shared folder mount utility. +# Sub-Makefile for the FreeBSD Shared folder mount utility.
@ -13,14 +13,13 @@
+$(error "The FreeBSD guest additions can only be built on FreeBSD!") +$(error "The FreeBSD guest additions can only be built on FreeBSD!")
+endif +endif
+ +
+FREEBSD_SRC= /usr/src +MOUNT= $(VBOX_FREEBSD_SRC)/../sbin/mount
+MOUNT= ${FREEBSD_SRC}/sbin/mount
+ +
+CFLAGS+=-I${MOUNT} +CFLAGS+=-I$(MOUNT)
+ +
+PROGRAMS += mount_vboxvfs +PROGRAMS += mount_vboxvfs
+mount_vboxvfs_TEMPLATE = NewVBoxGuestR3Exe +mount_vboxvfs_TEMPLATE = NewVBoxGuestR3Exe
+mount_vboxvfs_SOURCES = ${MOUNT}/getmntopts.c \ +mount_vboxvfs_SOURCES = $(MOUNT)/getmntopts.c \
+ mount_vboxvfs.c + mount_vboxvfs.c
+ +
+include $(FILE_KBUILD_SUB_FOOTER) +include $(FILE_KBUILD_SUB_FOOTER)