dns/sheerdns: Remove expired port

dns/sheerdns
This commit is contained in:
Muhammad Moinur Rahman 2024-02-29 12:50:27 +01:00
parent a7a56556a5
commit 35e6adf99c
No known key found for this signature in database
GPG Key ID: BDB9B5A617C0BC91
6 changed files with 1 additions and 82 deletions

1
MOVED
View File

@ -3006,3 +3006,4 @@ comms/sms_client||2024-02-29|Has expired: Abandonware, dead upstream and relies
devel/codeville||2024-02-29|Has expired: Abandonware, dead upstream for at least 10 years. Consider using devel/git or devel/mercurial
dns/dns_balance||2024-02-29|Has expired: Abandonware, last release in 2005. Consider using dns/dnsdist
dns/dnscheckengine||2024-02-29|Has expired: Deprecated upstream in favour of Zonemaster Project
dns/sheerdns||2024-02-29|Has expired: Abandonware, upstream dead and last update over 10 years ago

View File

@ -225,7 +225,6 @@
SUBDIR += rubygem-zonefile
SUBDIR += samba-nsupdate
SUBDIR += scavenge
SUBDIR += sheerdns
SUBDIR += sleuth
SUBDIR += subfinder
SUBDIR += totd

View File

@ -1,34 +0,0 @@
PORTNAME= sheerdns
PORTVERSION= 1.04
PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= https://BSDforge.com/projects/source/dns/sheerdns/
MAINTAINER= ports@FreeBSD.org
COMMENT= Lightweight, simple, and fast master DNS server
WWW= https://BSDforge.com/projects/dns/sheerdns/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Abandonware, upstream dead and last update over 10 years ago
EXPIRATION_DATE=2024-02-29
USES= gmake tar:xz
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= share/man/man8/sheerdns.8.gz sbin/sheerdns sbin/sheerdnshash
PORTDOCS= sheerdns.html sheerdns.ps
OPTIONS_DEFINE= DOCS
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/sheerdns
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/sheerdnshash
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (sheerdns-1.04.tar.xz) = 890d0c4735179b20d2ac9b5a2fa9f7a94849ba880bd8afb919305c677aa44475
SIZE (sheerdns-1.04.tar.xz) = 22404

View File

@ -1,36 +0,0 @@
--- Makefile.orig 2016-07-27 04:50:31 UTC
+++ Makefile
@@ -1,5 +1,6 @@
-CFLAGS=-Wall -g -O0 -ansi -pedantic
+CC?= gcc
+CFLAGS+=-Wall -ansi -pedantic
SRCS=$(wildcard *.c)
@@ -8,13 +9,13 @@ all: sheerdns sheerdnshash sheerdns.ps
OBJECTS=$(SRCS:.c=.o)
sheerdns: $(OBJECTS)
- gcc -o sheerdns $(OBJECTS)
+ $(CC) -o sheerdns $(OBJECTS)
sheerdnshash: hash.c
- gcc $(CFLAGS) -o sheerdnshash hash.c -DSTANDALONE -Wall
+ $(CC) $(CFLAGS) -o sheerdnshash hash.c -DSTANDALONE -Wall
.c.o: $(SRCS)
- gcc $(CFLAGS) -c $<
+ $(CC) $(CFLAGS) -c $<
clean:
rm -f sheerdns sheerdnshash *.o
@@ -26,6 +27,5 @@ sheerdns.ps:
groff -t sheerdns.8 > sheerdns.ps
install: all
- install sheerdnshash sheerdns /usr/sbin/
- install sheerdns.8 /usr/share/man/man8/
- install sheerdns.8 /usr/man/man8/
+ install sheerdnshash sheerdns $(DESTDIR)$(PREFIX)/sbin
+ install sheerdns.8 $(DESTDIR)$(PREFIX)/share/man/man8

View File

@ -1,9 +0,0 @@
sheerdns is a master DNS server whose zone records are stored on a
one-record-per-file bases. Because of this, sheerdns is likely the
simplest DNS to configure, use, update, and operate. It's especially
efficient for networks with frequent updates -- serving DHCP, for example.
Updates to the zones are immediate, and do not require restarting sheerdns.
SheerDNS is a good candidate for creating and RBL for mail, or web sites,
as well as for providing DNS on embedded systems. Or anything else that
requires a fast DNS, with very low overhead.