glade-- is a C++ code generator for devel/glade

PR:		21823
Submitted by:	Shinya FUJIE <fujie@tk.elec.waseda.ac.jp>
This commit is contained in:
Ade Lovett 2000-10-10 18:08:14 +00:00
parent 8f10bebca9
commit 361bcb9a03
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33685
9 changed files with 108 additions and 0 deletions

View file

@ -84,6 +84,7 @@
SUBDIR += gide
SUBDIR += gindent
SUBDIR += glade
SUBDIR += glade--
SUBDIR += glib12
SUBDIR += glib13
SUBDIR += global

30
devel/glade--/Makefile Normal file
View file

@ -0,0 +1,30 @@
# New ports collection makefile for: glade--
# Date created: 7th October 2000
# Whom: Shinya FUJIE <fujie@tk.elec.waseda.ac.jp>
#
# $FreeBSD$
#
PORTNAME= glademm
PORTVERSION= 0.5.9
CATEGORIES= devel gnome
MASTER_SITES= http://home.wtal.de/petig/Gtk/
MAINTAINER= fujie@tk.elec.waseda.ac.jp
RUN_DEPENDS= glade:${PORTSDIR}/devel/glade
LIB_DEPENDS= gtkmm.1:${PORTSDIR}/x11-toolkits/gtk--
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
post-patch:
@${PERL} -pi -e 's|%%GTK_CONFIG%%|${GTK_CONFIG}|g' \
${WRKSRC}/src/glade--.cc
@${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Cxx.cc
.include <bsd.port.mk>

1
devel/glade--/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (glademm-0.5.9.tar.gz) = af9f95c6778a47969f6377dcae004498

View file

@ -0,0 +1,18 @@
--- configure.orig Wed Jun 7 02:49:17 2000
+++ configure Tue Oct 10 12:34:46 2000
@@ -2065,11 +2065,11 @@
echo $ac_n "checking your gtk version""... $ac_c" 1>&6
echo "configure:2068: checking your gtk version" >&5
-case `gtk-config --version` in
+case `$GTK_CONFIG --version` in
*.*.*)
- GTK_MAJOR=`gtk-config --version | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
- GTK_MINOR=`gtk-config --version | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
- GTK_MICRO=`gtk-config --version | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
+ GTK_MAJOR=`$GTK_CONFIG --version | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
+ GTK_MINOR=`$GTK_CONFIG --version | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
+ GTK_MICRO=`$GTK_CONFIG --version | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
;;
*)
echo "configure: warning: Can't determine your gtk version, assuming 1.2.2" 1>&2

View file

@ -0,0 +1,17 @@
--- src/glade--.cc.orig Thu May 4 06:02:30 2000
+++ src/glade--.cc Tue Oct 10 12:36:14 2000
@@ -89,3 +89,3 @@
{ char buf[80];
- FILE *f=popen("gtk-config --version","r");
+ FILE *f=popen("%%GTK_CONFIG%% --version","r");
if (f)
@@ -98,3 +98,3 @@
Configuration.gtk_version=v;
- else cerr << "gtk-config --version: strange result '" << buf << "'\n";
+ else cerr << "%%GTK_CONFIG%% --version: strange result '" << buf << "'\n";
}
@@ -102,3 +102,3 @@
}
- else perror("gtk-config");
+ else perror("%%GTK_CONFIG%%");
f=popen("gtkmm-config --version","r");

View file

@ -0,0 +1,34 @@
--- src/Cxx.cc.orig Wed May 3 10:13:56 2000
+++ src/Cxx.cc Tue Oct 10 12:50:19 2000
@@ -491,10 +491,3 @@
if (Configuration.gnome_support)
- f << "if test -r /usr/lib/gnomemmConf.sh ; then\n"
- " source /usr/lib/gnomemmConf.sh\n"
- "elif test -r /opt/gnome/lib/gnomemmConf.sh ; then\n"
- " source /opt/gnome/lib/gnomemmConf.sh\n"
- "elif test -r /usr/local/lib/gnomemmConf.sh ; then\n"
- " source /usr/local/lib/gnomemmConf.sh\n"
- "else echo \"Cant find gnomemmConf.sh.\"\n"
- "fi\n"
+ f << "source %%X11BASE%%/etc/gnomemmConf.sh\n"
"AC_SUBST(GNOMEMM_INCLUDEDIR)\n"
@@ -540,17 +533,5 @@
if (Configuration.gnome_support)
- f << "# Search for glade\\'s gnome.m4 directory (contains gnome macros).\n"
- "# If you include gnome-common/macros in your application (recommended)\n"
- "# also replace this autogen.sh.\n"
- "if [ -r /opt/gnome/share/glade/gnome/gnome.m4 ]\n"
- "then \n"
- " aclocal -I /opt/gnome/share/glade/gnome\n"
- "elif [ -r /usr/local/share/glade/gnome/gnome.m4 ]\n"
- "then\n"
- " aclocal -I /usr/local/share/glade/gnome\n"
- "else\n"
- " echo \"Can't find glade's gnome.m4 directory (gnome macros)\"\n"
- " exit 2\n"
- "fi\n";
+ f << "aclocal -I %%X11BASE%%/share/aclocal -I %%X11BASE%%/share/gnome/glade/gnome\n";
else
- f << "aclocal\n";
+ f << "aclocal -I %%X11BASE%%/share/aclocal\n";
f << "automake --add-missing --copy --gnu\n"

View file

@ -0,0 +1 @@
A C++(GTK--) code generator for glade

5
devel/glade--/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
glade-- is a C++ backend for glade, the GUI designer for Gtk.
This means this program reads glade files and outputs a C++ program source
skeleton for you.
WWW: http://home.wtal.de/petig/Gtk/index.html

1
devel/glade--/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/glade--