- update to 0.9.8.0 [0]

- use the provided install target instead of re-writing do-install

PR:		55988 [0]
Submitted by:	Stefan Walter <sw@gegenunendlich.de> [0]
This commit is contained in:
Pete Fritchman 2003-10-11 17:45:14 +00:00
parent 6ea4010118
commit 365307d67b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90856
5 changed files with 126 additions and 43 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= slrn
PORTVERSION= 0.9.7.4
PORTVERSION= 0.9.8.0
PORTREVISION= 1
CATEGORIES= news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
@ -43,27 +43,14 @@ ALL_TARGET= all
MAN1= slrn.1 slrnpull.1
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS=yes
.endif
post-patch:
@${REINPLACE_CMD} -e 's,/usr/lib/sendmail,/usr/sbin/sendmail,' \
${WRKSRC}/src/slrnfeat.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/slrn ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/slrnpull ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/examples/slrn
${INSTALL_DATA} ${WRKSRC}/doc/slrn.rc ${PREFIX}/share/examples/slrn
(cd ${WRKSRC}/po; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install)
@${MKDIR} ${PREFIX}/share/examples/slrn/slrnpull
.for file in FAQ README SETUP score slrn.rc slrnpull.conf slrnpull.sh
${INSTALL_DATA} ${WRKSRC}/doc/slrnpull/${file} ${PREFIX}/share/examples/slrn/slrnpull
.endfor
${INSTALL_MAN} ${WRKSRC}/doc/slrn.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/slrnpull.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in FAQ README.* SCORE_FAQ *.txt slrn-doc.html
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
.endif
@${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' \
${WRKSRC}/src/jdmacros.h
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (slrn-0.9.7.4.tar.bz2) = da944c58f301cf07a41f996d91de8431
MD5 (slrn-0.9.8.0.tar.bz2) = 47e9931771114ba192356a0473e9649e

View file

@ -0,0 +1,28 @@
--- Makefile.in.orig Mon Aug 25 09:39:58 2003
+++ Makefile.in Sat Oct 11 12:31:29 2003
@@ -176,6 +176,7 @@
uninstall-info-am:
docDATA_INSTALL = $(INSTALL_DATA)
install-docDATA: $(doc_DATA)
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
$(mkinstalldirs) $(DESTDIR)$(docdir)
@list='$(doc_DATA)'; for p in $$list; do \
@@ -184,6 +185,7 @@
echo " $(docDATA_INSTALL) $$d$$p $(DESTDIR)$(docdir)/$$f"; \
$(docDATA_INSTALL) $$d$$p $(DESTDIR)$(docdir)/$$f; \
done
+endif
uninstall-docDATA:
@$(NORMAL_UNINSTALL)
@@ -399,7 +401,9 @@
all-am: Makefile $(DATA) all-local
installdirs: installdirs-recursive
installdirs-am:
+ifndef NOPORTDOCS
$(mkinstalldirs) $(DESTDIR)$(docdir)
+endif
install: install-recursive
install-exec: install-exec-recursive

View file

@ -0,0 +1,44 @@
--- doc/Makefile.in.orig Sun Oct 5 12:34:38 2003
+++ doc/Makefile.in Sun Oct 5 12:35:38 2003
@@ -205,6 +205,7 @@
done
docDATA_INSTALL = $(INSTALL_DATA)
install-docDATA: $(doc_DATA)
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
$(mkinstalldirs) $(DESTDIR)$(docdir)
@list='$(doc_DATA)'; for p in $$list; do \
@@ -213,6 +214,7 @@
echo " $(docDATA_INSTALL) $$d$$p $(DESTDIR)$(docdir)/$$f"; \
$(docDATA_INSTALL) $$d$$p $(DESTDIR)$(docdir)/$$f; \
done
+endif
uninstall-docDATA:
@$(NORMAL_UNINSTALL)
@@ -362,7 +364,9 @@
all-am: Makefile $(MANS) $(DATA)
installdirs: installdirs-recursive
installdirs-am:
+ifndef NOPORTDOCS
$(mkinstalldirs) $(DESTDIR)$(man1dir) $(DESTDIR)$(docdir)
+endif
install: install-recursive
install-exec: install-exec-recursive
@@ -449,6 +453,7 @@
install-data-local:
+ifndef NOPORTDOCS
@if test "x$(SLRNPULL)" = "xslrnpull"; then \
$(mkinstalldirs) $(DESTDIR)$(docdir)/slrnpull; \
list='$(PULLDOCS)'; for p in $$list; do \
@@ -458,6 +463,7 @@
fi; \
done; \
fi;
+endif
uninstall-local:
list='$(PULLDOCS)'; for p in $$list; do \

View file

@ -1,34 +1,58 @@
bin/slrn
bin/slrnpull
share/examples/slrn/slrn.rc
share/examples/slrn/slrnpull/FAQ
share/examples/slrn/slrnpull/README
share/examples/slrn/slrnpull/SETUP
share/examples/slrn/slrnpull/score
share/examples/slrn/slrnpull/slrn.rc
share/examples/slrn/slrnpull/slrnpull.conf
share/examples/slrn/slrnpull/slrnpull.sh
%%PORTDOCS%%share/doc/slrn/COPYING
%%PORTDOCS%%share/doc/slrn/COPYRIGHT
%%PORTDOCS%%share/doc/slrn/FAQ
%%PORTDOCS%%share/doc/slrn/FIRST_STEPS
%%PORTDOCS%%share/doc/slrn/README
%%PORTDOCS%%share/doc/slrn/README.GroupLens
%%PORTDOCS%%share/doc/slrn/README.SSL
%%PORTDOCS%%share/doc/slrn/README.macros
%%PORTDOCS%%share/doc/slrn/README.multiuser
%%PORTDOCS%%share/doc/slrn/THANKS
%%PORTDOCS%%share/doc/slrn/changes.txt
%%PORTDOCS%%share/doc/slrn/help.txt
%%PORTDOCS%%share/doc/slrn/manual.txt
%%PORTDOCS%%share/doc/slrn/score.sl
%%PORTDOCS%%share/doc/slrn/score.txt
%%PORTDOCS%%share/doc/slrn/slrn-doc.html
%%PORTDOCS%%share/doc/slrn/slrn.rc
%%PORTDOCS%%share/doc/slrn/slrnfuns.txt
%%PORTDOCS%%share/doc/slrn/slrnpull/README
%%PORTDOCS%%share/doc/slrn/slrnpull/README.offline
%%PORTDOCS%%share/doc/slrn/slrnpull/SETUP
%%PORTDOCS%%share/doc/slrn/slrnpull/score
%%PORTDOCS%%share/doc/slrn/slrnpull/setgid.txt
%%PORTDOCS%%share/doc/slrn/slrnpull/slrn.rc
%%PORTDOCS%%share/doc/slrn/slrnpull/slrnpull.conf
%%PORTDOCS%%share/doc/slrn/slrnpull/slrnpull.sh
share/locale/be/LC_MESSAGES/slrn.mo
share/locale/da/LC_MESSAGES/slrn.mo
share/locale/de/LC_MESSAGES/slrn.mo
share/locale/es/LC_MESSAGES/slrn.mo
share/locale/fi/LC_MESSAGES/slrn.mo
share/locale/fr/LC_MESSAGES/slrn.mo
share/locale/it/LC_MESSAGES/slrn.mo
share/locale/ko/LC_MESSAGES/slrn.mo
share/locale/nl/LC_MESSAGES/slrn.mo
share/locale/pl/LC_MESSAGES/slrn.mo
share/locale/ru/LC_MESSAGES/slrn.mo
%%PORTDOCS%%share/doc/slrn/FAQ
%%PORTDOCS%%share/doc/slrn/README.GroupLens
%%PORTDOCS%%share/doc/slrn/README.SSL
%%PORTDOCS%%share/doc/slrn/README.macros
%%PORTDOCS%%share/doc/slrn/README.multiuser
%%PORTDOCS%%share/doc/slrn/SCORE_FAQ
%%PORTDOCS%%share/doc/slrn/help.txt
%%PORTDOCS%%share/doc/slrn/manual.txt
%%PORTDOCS%%share/doc/slrn/pc-keys.txt
%%PORTDOCS%%share/doc/slrn/score.txt
%%PORTDOCS%%share/doc/slrn/slrnfuns.txt
%%PORTDOCS%%share/doc/slrn/slrn-doc.html
share/locale/tr/LC_MESSAGES/slrn.mo
share/slrn/macros/color.sl
share/slrn/macros/gsort.sl
share/slrn/macros/ispell.sl
share/slrn/macros/latin2.sl
share/slrn/macros/multipart.sl
share/slrn/macros/nn.sl
share/slrn/macros/posthook.sl
share/slrn/macros/search.sl
share/slrn/macros/tin-art.sl
share/slrn/macros/tin-group.sl
share/slrn/macros/ttyprint.sl
share/slrn/macros/util.sl
share/slrn/macros/varset.sl
share/slrn/macros/xcomment.sl
@dirrm share/slrn/macros
@dirrm share/slrn
%%PORTDOCS%%@dirrm share/doc/slrn/slrnpull
%%PORTDOCS%%@dirrm share/doc/slrn
@dirrm share/examples/slrn/slrnpull
@dirrm share/examples/slrn