- Update to 0.7.2
- Convert to OptionsNG PR: ports/170260 Submitted by: Mark Felder <feld@feld.me> Approved by: David Brooks <dab@rj45.org> (maintainer)
This commit is contained in:
parent
304df214df
commit
36624543ed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301700
3 changed files with 17 additions and 16 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= sabnzbdplus
|
||||
PORTVERSION= 0.7.0
|
||||
PORTVERSION= 0.7.2
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
|
||||
DISTNAME= SABnzbd-${PORTVERSION}-src
|
||||
|
@ -90,31 +90,32 @@ PORTDOCS= ABOUT.txt \
|
|||
USERS= _sabnzbd
|
||||
GROUPS= _sabnzbd
|
||||
|
||||
OPTIONS= PAR2CMDLINE "Required for postprocessing of par files." on \
|
||||
UNRAR "Often required for unpacking many downloads." on \
|
||||
FEEDPARSER "rss-feed support." on \
|
||||
YENC "yenc support." on \
|
||||
OPENSSL "SSL support" on
|
||||
OPTIONS_DEFINE= PAR2CMDLINE UNRAR FEEDPARSER YENC OPENSSL
|
||||
OPTIONS_DEFAULT= PAR2CMDLINE UNRAR FEEDPARSER YENC OPENSSL
|
||||
PAR2CMDLINE_DESC= Required for postprocessing of par files
|
||||
UNRAR_DESC= Often required for unpacking many downloads
|
||||
FEEDPARSER_DESC= rss-feed support
|
||||
YENC_DESC= yenc support
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITHOUT_PAR2CMDLINE)
|
||||
.if ${PORT_OPTIONS:MPAR2CMDLINE}
|
||||
RUN_DEPENDS+= par2repair:${PORTSDIR}/archivers/par2cmdline-tbb
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_FEEDPARSER)
|
||||
.if ${PORT_OPTIONS:MFEEDPARSER}
|
||||
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/OpenSSL/SSL.so:${PORTSDIR}/security/py-openssl
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_YENC)
|
||||
.if ${PORT_OPTIONS:MYENC}
|
||||
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_yenc.so:${PORTSDIR}/news/py-yenc
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_OPENSSL)
|
||||
.if ${PORT_OPTIONS:MOPENSSL}
|
||||
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/feedparser.py:${PORTSDIR}/textproc/py-feedparser
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_UNRAR)
|
||||
.if ${PORT_OPTIONS:MUNRAR}
|
||||
RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (SABnzbd-0.7.0-src.tar.gz) = 36ddfe48a770381bf8cdd4bd807416a09c7d05c4939c17861977d9413b1e3fa2
|
||||
SIZE (SABnzbd-0.7.0-src.tar.gz) = 2238004
|
||||
SHA256 (SABnzbd-0.7.2-src.tar.gz) = 4018b79ac9e5219e86e06fc6edad4c7502ee0d153bc2a1666c0649613e02822e
|
||||
SIZE (SABnzbd-0.7.2-src.tar.gz) = 2246261
|
|
@ -1,5 +1,5 @@
|
|||
--- SABnzbd.py.orig 2012-06-16 00:42:53.434526408 -0400
|
||||
+++ SABnzbd.py 2012-06-16 00:45:08.799296373 -0400
|
||||
--- SABnzbd.py.orig 2012-07-23 23:26:14.000000000 -0400
|
||||
+++ SABnzbd.py 2012-07-23 23:28:04.000000000 -0400
|
||||
@@ -40,6 +40,9 @@
|
||||
print "The Python module Cheetah is required"
|
||||
sys.exit(1)
|
||||
|
@ -10,7 +10,7 @@
|
|||
import cherrypy
|
||||
if not cherrypy.__version__.startswith("3.2"):
|
||||
print "Sorry, requires Python module Cherrypy 3.2 (use the included version)"
|
||||
@@ -1003,7 +1006,7 @@
|
||||
@@ -1011,7 +1014,7 @@
|
||||
|
||||
sabnzbd.MY_FULLNAME = os.path.normpath(os.path.abspath(sabnzbd.MY_FULLNAME))
|
||||
sabnzbd.MY_NAME = os.path.basename(sabnzbd.MY_FULLNAME)
|
||||
|
|
Loading…
Reference in a new issue