Add gksu, a GTK+ frontend to su. It supports login shells and

preserving environment when acting as a su frontend.  It is useful to
menu items or other graphical programs that need to ask a user's password
to run programs as another user.

PR:		72258
Submitted by:	Jesse van den Kieboom <troplosti@orcaweb.cjb.net>
This commit is contained in:
Joe Marcus Clarke 2004-11-05 06:12:59 +00:00
parent 11355a305e
commit 368978152b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120837
6 changed files with 64 additions and 0 deletions

View file

@ -161,6 +161,7 @@
SUBDIR += gkrellmwho
SUBDIR += gkrellmwho2
SUBDIR += gkrelltop
SUBDIR += gksu
SUBDIR += glload
SUBDIR += gnome-pkgview
SUBDIR += gnomecontrolcenter

27
sysutils/gksu/Makefile Normal file
View file

@ -0,0 +1,27 @@
# New ports collection makefile for: gksu
# Date created: 2 October 2004
# Whom: Jesse van den Kieboom <troplosti@orcaweb.cjb.net>
#
# $FreeBSD$
#
PORTNAME= gksu
PORTVERSION= 1.2.2
CATEGORIES= sysutils
MASTER_SITES= http://people.debian.org/~kov/gksu/gksu1.2/
MAINTAINER= troplosti@orcaweb.cjb.net
COMMENT= Graphical frontend to su
LIB_DEPENDS= libgksu1.2:${PORTSDIR}/sysutils/libgksu \
libgksuui1.0:${PORTSDIR}/sysutils/libgksuui
USE_X_PREFIX= yes
USE_GNOME= gtk20 pkgconfig gnomeprefix gnomehack
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gksu.1 gksuexec.1
.include <bsd.port.mk>

2
sysutils/gksu/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (gksu-1.2.2.tar.gz) = 564504badbd41fbe554a8133d07b5e94
SIZE (gksu-1.2.2.tar.gz) = 553299

View file

@ -0,0 +1,11 @@
--- gksu/Makefile.in.orig Fri Nov 5 00:55:23 2004
+++ gksu/Makefile.in Fri Nov 5 00:55:33 2004
@@ -167,7 +167,7 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-AM_CFLAGS = -g -O2 -Wall
+AM_CFLAGS = $(CFLAGS)
INCLUDES = `pkg-config --cflags gtk+-2.0 libgksu1.2 libgksuui1.0`
AM_CPPFLAGS = -DLOCALEDIR=\"$(prefix)/share/locale\" -DDATA_DIR=\"$(datadir)\" -DPREFIX=\"$(prefix)\"

9
sysutils/gksu/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
gksu is a Gtk+ frontend to /bin/su. It supports login shells and preserving
environment when acting as a su frontend. It is useful to menu items or other
graphical programs that need to ask a user's password to run another program
as another user.
WWW: http://www.gnu.org/non-gnu/gksu/
- Jesse van den Kieboom
troplosti@orcaweb.cjb.net

14
sysutils/gksu/pkg-plist Normal file
View file

@ -0,0 +1,14 @@
bin/gksu
bin/gksudo
bin/gksuexec
share/gnome/applications/gksu.desktop
share/gnome/applications/gksuexec.desktop
share/gnome/pixmaps/gksu-icon.png
share/gnome/pixmaps/gksu-root-terminal.png
share/locale/ca/LC_MESSAGES/gksu.mo
share/locale/da/LC_MESSAGES/gksu.mo
share/locale/de/LC_MESSAGES/gksu.mo
share/locale/es/LC_MESSAGES/gksu.mo
share/locale/no_NB/LC_MESSAGES/gksu.mo
share/locale/pt_BR/LC_MESSAGES/gksu.mo
share/locale/ru/LC_MESSAGES/gksu.mo