- Update to 118

This commit is contained in:
Dmitry Marakasov 2021-01-27 22:28:23 +00:00
parent a04e75e95a
commit 369808dec3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=563105
6 changed files with 144 additions and 33 deletions

View file

@ -2,34 +2,31 @@
# $FreeBSD$
PORTNAME= powder
PORTVERSION= 115
PORTREVISION= 3
PORTVERSION= 118
CATEGORIES= games
MASTER_SITES= http://www.zincland.com/powder/release/ \
http://mirror.amdmi3.ru/distfiles/
https://mirror.amdmi3.ru/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION}_src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Graphical dungeon crawling game
LICENSE= POWDER
LICENSE_NAME= THE POWDER LICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
LICENSE_PERMS= dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
USES= gmake sdl
USE_SDL= sdl
USE_CXXSTD= c++98
MAKE_JOBS_UNSAFE=yes
BUILD_WRKSRC= ${WRKSRC}/port/linux
PLIST_FILES= bin/powder
PORTDOCS= README.TXT LICENSE.TXT CREDITS.TXT
PORTDOCS= README.TXT CREDITS.TXT
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|bin/bash|bin/sh|' \
${WRKSRC}/rooms/buildrooms.bash \
${WRKSRC}/gfx/rebuild.sh
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' \
${BUILD_WRKSRC}/Makefile
do-build:
cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${SH} buildall.sh
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/powder ${STAGEDIR}${PREFIX}/bin/

View file

@ -1,2 +1,3 @@
SHA256 (powder115_src.tar.gz) = 223e03b30c98d1e500fe920b04fbb8b8df4a8d8d349735ad1e36c62e8450b895
SIZE (powder115_src.tar.gz) = 1872955
TIMESTAMP = 1574272976
SHA256 (powder118_src.tar.gz) = 4e812f3972c7dd1ff2403557d1cd891a98470f59ccf09bc03ce79dafd118f3d7
SIZE (powder118_src.tar.gz) = 1941412

View file

@ -0,0 +1,96 @@
--- buildall.sh.orig 2010-04-01 23:32:05 UTC
+++ buildall.sh
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
if [ -z "$CXXFLAGS" ]; then
export CXXFLAGS=-O3
@@ -7,7 +7,7 @@ fi
PREFIX_DOC=$DESTDIR/usr/share/doc/powder
PREFIX_BIN=$DESTDIR/opt/bin
-function usage {
+usage() {
echo Usage: `basename $0` [options]
echo -e "--install\t - install POWDER"
echo -e "--uninstall\t - uninstall POWDER"
@@ -26,43 +26,43 @@ function usage {
echo -e "--install does *NOT* rebuild if powder exists"
}
-function compile {
+compile() {
echo Run this from the root of the source tree.
echo Rebuild all of POWDER
echo Build support binaries
cd support/bmp2c
- make clean
- make
+ gmake clean
+ gmake
cd ../encyclopedia2c
- make clean
- make
+ gmake clean
+ gmake
cd ../enummaker
- make clean
- make
+ gmake clean
+ gmake
cd ../map2c
- make clean
- make
+ gmake clean
+ gmake
cd ../txt2c
- make clean
- make
+ gmake clean
+ gmake
cd ../tile2c
- make clean
- make
+ gmake clean
+ gmake
echo Clean...
cd ../../port/linux
- make clean
+ gmake clean
echo Premake
- make premake
+ gmake premake
echo Final install
- make powder-static
+ gmake powder
cp powder ../..
cd ../..
echo Run powder to play
}
-function install {
+install() {
if [ ! -f powder ]; then
compile
fi
@@ -74,7 +74,7 @@ function install {
echo "Installation complete"
}
-function uninstall {
+uninstall() {
rm $PREFIX_BIN/powder
for file in README.TXT LICENSE.TXT CREDITS.TXT; do
rm $PREFIX_DOC/$file
@@ -101,7 +101,7 @@ do
fi
done
-if [ "$INSTALL" == "1" ]; then
+if [ "$INSTALL" = "1" ]; then
install
else
compile

View file

@ -1,18 +0,0 @@
--- gfx/rebuild.sh.orig 2010-01-20 04:59:47.000000000 +0300
+++ gfx/rebuild.sh 2010-04-25 08:06:33.000000000 +0400
@@ -1,12 +1,12 @@
-#!/bin/bash
+#!/bin/sh
echo Rebuilding Graphics Files
for tileset in classic distorted adambolt nethack ascii ibsongrey akoimeexx akoi12 akoi10 lomaka ; do
- pushd $tileset
+ cd $tileset
echo Building tiles...
../../support/tile2c/tile2c
- popd
+ cd -
done
pushd akoi3x

View file

@ -0,0 +1,27 @@
--- gfx/rebuild.sh.orig 2010-01-20 01:59:47 UTC
+++ gfx/rebuild.sh
@@ -1,19 +1,19 @@
-#!/bin/bash
+#!/bin/sh
echo Rebuilding Graphics Files
for tileset in classic distorted adambolt nethack ascii ibsongrey akoimeexx akoi12 akoi10 lomaka ; do
- pushd $tileset
+ cd $tileset
echo Building tiles...
../../support/tile2c/tile2c
- popd
+ cd -
done
-pushd akoi3x
+cd akoi3x
echo Building Akoi3x
gzip -d -c sprite16_3x.bmp.gz > sprite16_3x.bmp
../../support/bmp2c/bmp2c sprite16_3x.bmp
-popd
+cd -
echo Building Background images..
../support/bmp2c/bmp2c tridude_goodbye.bmp

View file

@ -0,0 +1,8 @@
--- rooms/buildrooms.bash.orig 2008-01-03 01:39:03 UTC
+++ rooms/buildrooms.bash
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
echo If this fails due to trying to write
echo to allrooms.cpp, make sure you do not