Upgrade from 1.9.12 to 1.9.13.

Remove needless vendor's patches.

<ChangeLog>

*) Change: non-idempotent requests (POST, LOCK, PATCH) are no longer
   passed to the next server by default if a request has been sent to a
   backend; the "non_idempotent" parameter of the "proxy_next_upstream"
   directive explicitly allows retrying such requests.

*) Feature: the ngx_http_perl_module can be built dynamically.

*) Feature: UDP support in the stream module.

*) Feature: the "aio_write" directive.

*) Feature: now cache manager monitors number of elements in caches and
   tries to avoid cache keys zone overflows.

*) Bugfix: "task already active" and "second aio post" alerts might
   appear in logs when using the "sendfile" and "aio" directives with
   subrequests.

*) Bugfix: "zero size buf in output" alerts might appear in logs if
   caching was used and a client closed a connection prematurely.

*) Bugfix: connections with clients might be closed needlessly if
   caching was used.
   Thanks to Justin Li.

*) Bugfix: nginx might hog CPU if the "sendfile" directive was used on
   Linux or Solaris and a file being sent was changed during sending.

*) Bugfix: connections might hang when using the "sendfile" and "aio
   threads" directives.

*) Bugfix: in the "proxy_pass", "fastcgi_pass", "scgi_pass", and
   "uwsgi_pass" directives when using variables.
   Thanks to Piotr Sikora.

*) Bugfix: in the ngx_http_sub_filter_module.

*) Bugfix: if an error occurred in a cached backend connection, the
   request was passed to the next server regardless of the
   proxy_next_upstream directive.

*) Bugfix: "CreateFile() failed" errors when creating temporary files on
   Windows.

</ChangeLog>
This commit is contained in:
Sergey A. Osokin 2016-04-03 05:33:13 +00:00
parent 05a09f12a3
commit 37404b97d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412449
4 changed files with 3 additions and 217 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nginx
PORTVERSION= 1.9.12
PORTREVISION= 1
PORTVERSION= 1.9.13
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa

View file

@ -1,5 +1,5 @@
SHA256 (nginx-1.9.12.tar.gz) = 1af2eb956910ed4b11aaf525a81bc37e135907e7127948f9179f5410337da042
SIZE (nginx-1.9.12.tar.gz) = 899183
SHA256 (nginx-1.9.13.tar.gz) = f7cd529a5879cd9cd5b62e6fc4a3a7e8d8363cb12c080ab480cc718c55736609
SIZE (nginx-1.9.13.tar.gz) = 907611
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
SHA256 (ngx_http_auth_pam_module-1.2.tar.gz) = 5a85970ba61a99f55a26d2536a11d512b39bbd622f5737d25a9a8c10db81efa9

View file

@ -1,15 +0,0 @@
--- auto/make Thu Feb 25 16:28:42 2016 +0300
+++ auto/make Thu Feb 25 15:22:05 2016 +0300
@@ -437,9 +437,9 @@
# the addons config.make
-if test -n "$NGX_ADDONS"; then
+if test -n "$NGX_ADDONS$DYNAMIC_ADDONS"; then
- for ngx_addon_dir in $NGX_ADDONS
+ for ngx_addon_dir in $NGX_ADDONS $DYNAMIC_ADDONS
do
if test -f $ngx_addon_dir/config.make; then
. $ngx_addon_dir/config.make

View file

@ -1,198 +0,0 @@
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/install
--- auto/install Mon Feb 29 18:52:33 2016 +0300
+++ auto/install Fri Feb 26 14:27:04 2016 +0300
@@ -3,7 +3,7 @@
# Copyright (C) Nginx, Inc.
-if [ $USE_PERL = YES ]; then
+if [ $USE_PERL != NO ]; then
cat << END >> $NGX_MAKEFILE
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/lib/conf
--- auto/lib/conf Mon Feb 29 18:52:33 2016 +0300
+++ auto/lib/conf Fri Feb 26 14:27:04 2016 +0300
@@ -66,7 +66,7 @@
. auto/lib/libgd/conf
fi
-if [ $USE_PERL = YES ]; then
+if [ $USE_PERL != NO ]; then
. auto/lib/perl/conf
fi
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/lib/make
--- auto/lib/make Mon Feb 29 18:52:33 2016 +0300
+++ auto/lib/make Fri Feb 26 14:27:04 2016 +0300
@@ -27,6 +27,6 @@
. auto/lib/libatomic/make
fi
-if [ $USE_PERL = YES ]; then
+if [ $USE_PERL != NO ]; then
. auto/lib/perl/make
fi
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/lib/perl/conf
--- auto/lib/perl/conf Mon Feb 29 18:52:33 2016 +0300
+++ auto/lib/perl/conf Fri Feb 26 14:27:04 2016 +0300
@@ -60,8 +60,11 @@
| sed -e 's/-arch i386//' -e 's/-arch x86_64//'`
fi
- CORE_LINK="$CORE_LINK $ngx_perl_ldopts"
- LINK_DEPS="$LINK_DEPS $NGX_OBJS/$ngx_perl_module"
+ if [ $USE_PERL = YES ]; then
+ CORE_LINK="$CORE_LINK $ngx_perl_ldopts"
+ fi
+
+ NGX_LIB_PERL="$ngx_perl_ldopts"
if test -n "$NGX_PERL_MODULES"; then
have=NGX_PERL_MODULES value="(u_char *) \"$NGX_PERL_MODULES\""
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/lib/perl/make
--- auto/lib/perl/make Mon Feb 29 18:52:33 2016 +0300
+++ auto/lib/perl/make Fri Feb 26 14:27:04 2016 +0300
@@ -8,7 +8,10 @@
cat << END >> $NGX_MAKEFILE
-$NGX_OBJS/src/http/modules/perl/blib/arch/auto/nginx/nginx.$ngx_perl_dlext: \\
+$NGX_OBJS/src/http/modules/perl/ngx_http_perl_module.o: \\
+ $NGX_OBJS/$ngx_perl_module
+
+$NGX_OBJS/$ngx_perl_module: \\
\$(CORE_DEPS) \$(HTTP_DEPS) \\
src/http/modules/perl/ngx_http_perl_module.h \\
$NGX_OBJS/src/http/modules/perl/Makefile
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/make
--- auto/make Mon Feb 29 18:52:33 2016 +0300
+++ auto/make Fri Feb 26 14:27:04 2016 +0300
@@ -281,7 +281,7 @@
ngx_cc="\$(CC) $ngx_compile_opt \$(CFLAGS) $ngx_use_pch \$(ALL_INCS)"
else
ngx_cc="\$(CC) $ngx_compile_opt \$(CFLAGS) \$(CORE_INCS) \$(HTTP_INCS)"
- ngx_perl_cc="\$(CC) $ngx_compile_opt \$(NGX_PERL_CFLAGS) "
+ ngx_perl_cc="\$(CC) $ngx_compile_opt \$(NGX_PERL_CFLAGS)"
ngx_perl_cc="$ngx_perl_cc \$(CORE_INCS) \$(HTTP_INCS)"
fi
@@ -494,6 +494,8 @@
ngx_cc="\$(CC) $ngx_compile_opt $ngx_pic_opt \$(CFLAGS) $ngx_use_pch \$(ALL_INCS)"
else
ngx_cc="\$(CC) $ngx_compile_opt $ngx_pic_opt \$(CFLAGS) \$(ALL_INCS)"
+ ngx_perl_cc="\$(CC) $ngx_compile_opt $ngx_pic_opt \$(NGX_PERL_CFLAGS)"
+ ngx_perl_cc="$ngx_perl_cc \$(ALL_INCS)"
fi
ngx_obj_deps="\$(CORE_DEPS)"
@@ -639,15 +641,15 @@
END
- for ngx_src in $ngx_module_srcs
+ for ngx_source in $ngx_module_srcs
do
- case "$ngx_src" in
+ case "$ngx_source" in
src/*)
- ngx_obj=`echo $ngx_src | sed -e "s/\//$ngx_regex_dirsep/g"`
+ ngx_obj=`echo $ngx_source | sed -e "s/\//$ngx_regex_dirsep/g"`
;;
*)
- ngx_obj="addon/`basename \`dirname $ngx_src\``"
- ngx_obj=`echo $ngx_obj/\`basename $ngx_src\` \
+ ngx_obj="addon/`basename \`dirname $ngx_source\``"
+ ngx_obj=`echo $ngx_obj/\`basename $ngx_source\` \
| sed -e "s/\//$ngx_regex_dirsep/g"`
;;
esac
@@ -658,14 +660,25 @@
-e "s#^\(.*\.\)c\\$#$ngx_objs_dir\1$ngx_objext#g" \
-e "s#^\(.*\.\)S\\$#$ngx_objs_dir\1$ngx_objext#g"`
- ngx_src=`echo $ngx_src | sed -e "s/\//$ngx_regex_dirsep/g"`
+ ngx_src=`echo $ngx_source | sed -e "s/\//$ngx_regex_dirsep/g"`
- cat << END >> $NGX_MAKEFILE
+ if [ $ngx_source = src/http/modules/perl/ngx_http_perl_module.c ]; then
+
+ cat << END >> $NGX_MAKEFILE
+
+$ngx_obj: $ngx_obj_deps$ngx_cont$ngx_src
+ $ngx_perl_cc$ngx_tab$ngx_objout$ngx_obj$ngx_tab$ngx_src$NGX_AUX
+
+END
+ else
+
+ cat << END >> $NGX_MAKEFILE
$ngx_obj: $ngx_obj_deps$ngx_cont$ngx_src
$ngx_cc$ngx_tab$ngx_objout$ngx_obj$ngx_tab$ngx_src$NGX_AUX
END
+ fi
done
done
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/module
--- auto/module Mon Feb 29 18:52:33 2016 +0300
+++ auto/module Fri Feb 26 14:27:04 2016 +0300
@@ -40,7 +40,7 @@
do
case $lib in
- LIBXSLT | LIBGD | GEOIP)
+ LIBXSLT | LIBGD | GEOIP | PERL)
libs="$libs \$NGX_LIB_$lib"
if eval [ "\$USE_${lib}" = NO ] ; then
@@ -48,7 +48,7 @@
fi
;;
- PCRE | OPENSSL | MD5 | SHA1 | ZLIB | PERL)
+ PCRE | OPENSSL | MD5 | SHA1 | ZLIB)
eval USE_${lib}=YES
;;
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/modules
--- auto/modules Mon Feb 29 18:52:33 2016 +0300
+++ auto/modules Fri Feb 26 14:27:04 2016 +0300
@@ -727,14 +727,12 @@
. auto/module
fi
-if [ $HTTP_PERL = YES ]; then
- USE_PERL=YES
-
+if [ $HTTP_PERL != NO ]; then
ngx_module_name=ngx_http_perl_module
ngx_module_incs=src/http/modules/perl
ngx_module_deps=src/http/modules/perl/ngx_http_perl_module.h
ngx_module_srcs=src/http/modules/perl/ngx_http_perl_module.c
- ngx_module_libs=
+ ngx_module_libs=PERL
ngx_module_link=$HTTP_PERL
. auto/module
diff -r 8e6f34342eb6 -r 39a806ccf21e auto/options
--- auto/options Mon Feb 29 18:52:33 2016 +0300
+++ auto/options Fri Feb 26 14:27:04 2016 +0300
@@ -271,6 +271,7 @@
--without-http_upstream_zone_module) HTTP_UPSTREAM_ZONE=NO ;;
--with-http_perl_module) HTTP_PERL=YES ;;
+ --with-http_perl_module=dynamic) HTTP_PERL=DYNAMIC ;;
--with-perl_modules_path=*) NGX_PERL_MODULES="$value" ;;
--with-perl=*) NGX_PERL="$value" ;;
@@ -452,6 +453,7 @@
disable ngx_http_upstream_zone_module
--with-http_perl_module enable ngx_http_perl_module
+ --with-http_perl_module=dynamic enable dynamic ngx_http_perl_module
--with-perl_modules_path=PATH set Perl modules path
--with-perl=PATH set perl binary pathname