graphics/openimageio: update to 1.7.10
While here, add patch for blender to fix it's build with this new version of openimageio. PR: 216601 Submitted by: Shane <FreeBSD@ShaneWare.Biz> (maintainer)
This commit is contained in:
parent
c5aeed85b7
commit
37774fddf5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=445627
4 changed files with 56 additions and 32 deletions
|
@ -0,0 +1,21 @@
|
|||
--- source/blender/imbuf/intern/oiio/openimageio_api.cpp.orig 2017-02-13 14:08:03 UTC
|
||||
+++ source/blender/imbuf/intern/oiio/openimageio_api.cpp
|
||||
@@ -35,6 +35,9 @@
|
||||
#include "utfconv.h"
|
||||
#endif
|
||||
|
||||
+#include <openimageio_api.h>
|
||||
+#include <OpenImageIO/imageio.h>
|
||||
+
|
||||
extern "C"
|
||||
{
|
||||
#include "MEM_guardedalloc.h"
|
||||
@@ -48,8 +51,6 @@ extern "C"
|
||||
#include "IMB_colormanagement_intern.h"
|
||||
}
|
||||
|
||||
-#include <openimageio_api.h>
|
||||
-#include <OpenImageIO/imageio.h>
|
||||
|
||||
OIIO_NAMESPACE_USING
|
||||
|
|
@ -2,9 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openimageio
|
||||
PORTVERSION= 1.6.12
|
||||
PORTVERSION= 1.7.10
|
||||
DISTVERSIONPREFIX= Release-
|
||||
PORTREVISION= 13
|
||||
CATEGORIES?= graphics multimedia
|
||||
|
||||
MAINTAINER?= FreeBSD@Shaneware.biz
|
||||
|
@ -12,20 +11,26 @@ COMMENT?= OpenImageIO graphics library
|
|||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= OpenImageIO
|
||||
GH_PROJECT= oiio
|
||||
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
|
||||
libImath.so:graphics/ilmbase \
|
||||
libIlmImf.so:graphics/OpenEXR \
|
||||
libpng16.so:graphics/png \
|
||||
libtiff.so:graphics/tiff \
|
||||
libwebp.so:graphics/webp \
|
||||
libhdf5.so:science/hdf5
|
||||
|
||||
# fbm also installs bin/idiff
|
||||
CONFLICTS= fbm-[0-9]*
|
||||
|
||||
USES= cmake:outsource compiler:c11
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= OpenImageIO
|
||||
GH_PROJECT= oiio
|
||||
|
||||
USES= cmake:outsource jpeg compiler:c++11-lib
|
||||
CMAKE_ARGS= -DBUILDSTATIC:BOOL=OFF \
|
||||
-DLINKSTATIC:BOOL=OFF \
|
||||
-DNOTHREADS:BOOL=OFF \
|
||||
-DSTOP_ON_WARNING:BOOL=OFF \
|
||||
-DOIIO_BUILD_CPP11:BOOL=OFF \
|
||||
-DOIIO_BUILD_CPP14:BOOL=OFF \
|
||||
-DUSE_OPENSSL:BOOL=OFF
|
||||
|
||||
OPTIONS_DEFINE= DOCS FFMPEG FREETYPE GIF IMAGEVIEWER OCIO OPENCV \
|
||||
|
@ -54,7 +59,8 @@ GIF_LIB_DEPENDS= libgif.so:graphics/giflib
|
|||
|
||||
IMAGEVIEWER_CMAKE_ON= -DUSE_QT:BOOL=ON -DUSE_OPENGL:BOOL=ON
|
||||
IMAGEVIEWER_CMAKE_OFF= -DUSE_OPENGL:BOOL=OFF -DUSE_QT:BOOL=OFF
|
||||
IMAGEVIEWER_USE= GL=glew QT4=corelib,gui,opengl,qmake_build,moc_build,rcc_build,uic_build
|
||||
IMAGEVIEWER_USE= GL=gl,glu,glew \
|
||||
QT4=corelib,gui,opengl,qmake_build,moc_build,rcc_build,uic_build
|
||||
|
||||
OCIO_CMAKE_ON= -DUSE_OCIO:BOOL=ON
|
||||
OCIO_CMAKE_OFF= -DUSE_OCIO:BOOL=OFF
|
||||
|
@ -62,11 +68,13 @@ OCIO_LIB_DEPENDS= libOpenColorIO.so:graphics/opencolorio
|
|||
|
||||
OPENCV_CMAKE_ON= -DUSE_OPENCV:BOOL=ON
|
||||
OPENCV_CMAKE_OFF= -DUSE_OPENCV:BOOL=OFF
|
||||
OPENCV_LIB_DEPENDS= libopencv_highgui.so:graphics/opencv
|
||||
OPENCV_LIB_DEPENDS= libopencv_highgui.so:graphics/opencv \
|
||||
libopencv_core.so:graphics/opencv2-core \
|
||||
libopenjpeg.so:graphics/openjpeg15
|
||||
|
||||
OPENJPEG_CMAKE_ON= -DUSE_OPENJPEG:BOOL=ON
|
||||
OPENJPEG_CMAKE_OFF= -DUSE_OPENJPEG:BOOL=OFF
|
||||
OPENJPEG_LIB_DEPENDS= libopenjpeg.so:graphics/openjpeg15
|
||||
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
|
||||
|
||||
RAW_CMAKE_ON= -DUSE_LIBRAW:BOOL=ON
|
||||
RAW_CMAKE_OFF= -DUSE_LIBRAW:BOOL=OFF
|
||||
|
@ -79,20 +87,12 @@ PLIST_SUB+= LIBVERS=${PORTVERSION}
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${ARCH} == powerpc
|
||||
USE_GCC= yes
|
||||
.endif
|
||||
|
||||
.if ${SLAVE_PORT} == no
|
||||
LIB_DEPENDS+= libIlmImf.so:graphics/OpenEXR \
|
||||
libboost_thread.so:devel/boost-libs \
|
||||
libhdf5.so:science/hdf5 \
|
||||
libwebp.so:graphics/webp
|
||||
USE_LDCONFIG= yes
|
||||
CMAKE_ARGS+= -DUSE_PYTHON:BOOL=OFF -DUSE_PYTHON3:BOOL=OFF \
|
||||
-DOIIO_BUILD_TOOLS:BOOL=ON
|
||||
.else
|
||||
LIB_DEPENDS= libOpenImageIO.so:graphics/openimageio \
|
||||
LIB_DEPENDS+= libOpenImageIO.so:graphics/openimageio \
|
||||
libboost_python.so:devel/boost-python-libs
|
||||
PLIST= ${PKGDIR}/pkg-plist-pybind
|
||||
#while oiio supports py3, ports doesn't have py3 support for boost-python yet
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (OpenImageIO-oiio-Release-1.6.12_GH0.tar.gz) = 14b2221e1f45723fecc1def7863bad8839ef459147242d87c16651246d41a945
|
||||
SIZE (OpenImageIO-oiio-Release-1.6.12_GH0.tar.gz) = 24919192
|
||||
TIMESTAMP = 1484843803
|
||||
SHA256 (OpenImageIO-oiio-Release-1.7.10_GH0.tar.gz) = ec5c567b6b4078d17df22262b764ebb7c09ce5b69f0bc2095b51e56c7070f5b7
|
||||
SIZE (OpenImageIO-oiio-Release-1.7.10_GH0.tar.gz) = 26188475
|
||||
|
|
|
@ -7,9 +7,11 @@ bin/maketx
|
|||
bin/oiiotool
|
||||
include/OpenImageIO/argparse.h
|
||||
include/OpenImageIO/array_view.h
|
||||
include/OpenImageIO/atomic.h
|
||||
include/OpenImageIO/color.h
|
||||
include/OpenImageIO/coordinate.h
|
||||
include/OpenImageIO/dassert.h
|
||||
include/OpenImageIO/deepdata.h
|
||||
include/OpenImageIO/errorhandler.h
|
||||
include/OpenImageIO/export.h
|
||||
include/OpenImageIO/filesystem.h
|
||||
|
@ -52,19 +54,19 @@ include/OpenImageIO/varyingref.h
|
|||
include/OpenImageIO/version.h
|
||||
lib/libOpenImageIO.so
|
||||
lib/libOpenImageIO.so.1
|
||||
lib/libOpenImageIO.so.1.6
|
||||
lib/libOpenImageIO.so.1.7
|
||||
lib/libOpenImageIO.so.%%LIBVERS%%
|
||||
lib/libOpenImageIO_Util.so
|
||||
lib/libOpenImageIO_Util.so.1
|
||||
lib/libOpenImageIO_Util.so.1.6
|
||||
lib/libOpenImageIO_Util.so.1.7
|
||||
lib/libOpenImageIO_Util.so.%%LIBVERS%%
|
||||
share/fonts/oiio/DroidSans-Bold.ttf
|
||||
share/fonts/oiio/DroidSans.ttf
|
||||
share/fonts/oiio/DroidSansMono.ttf
|
||||
share/fonts/oiio/DroidSerif-Bold.ttf
|
||||
share/fonts/oiio/DroidSerif-BoldItalic.ttf
|
||||
share/fonts/oiio/DroidSerif-Italic.ttf
|
||||
share/fonts/oiio/DroidSerif.ttf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSans-Bold.ttf
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSans.ttf
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSansMono.ttf
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSerif-Bold.ttf
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSerif-BoldItalic.ttf
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSerif-Italic.ttf
|
||||
%%FREETYPE%%share/fonts/oiio/DroidSerif.ttf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/openimageio.pdf
|
||||
|
|
Loading…
Reference in a new issue