add gdal
A translator library for raster geospatial data formats PR: 30828 Submitted by: Randall Hopper <aa8vb@nc.rr.com>
This commit is contained in:
parent
3c4ef68dfe
commit
37ed1ab7a9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48883
7 changed files with 146 additions and 0 deletions
|
@ -54,6 +54,7 @@
|
|||
SUBDIR += g2
|
||||
SUBDIR += gcolor
|
||||
SUBDIR += gd
|
||||
SUBDIR += gdal
|
||||
SUBDIR += gdchart
|
||||
SUBDIR += gdk-pixbuf
|
||||
SUBDIR += gdtclft
|
||||
|
|
33
graphics/gdal/Makefile
Normal file
33
graphics/gdal/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: Geospatial Data Abstraction Library
|
||||
# Date created: 27 Aug 2001
|
||||
# Whom: Randall Hopper
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gdal
|
||||
PORTVERSION= 1.1.5
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.remotesensing.org/pub/gdal/
|
||||
|
||||
MAINTAINER= aa8vb@nc.rr.com
|
||||
|
||||
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
|
||||
USE_PYTHON= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
--with-libz=internal \
|
||||
--with-png=internal \
|
||||
--with-libtiff=internal \
|
||||
--with-libgeotiff=internal \
|
||||
--with-libjpeg=internal \
|
||||
--with-libgif=internal \
|
||||
--with-python
|
||||
MAKEFILE= GNUmakefile
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/gdal/distinfo
Normal file
1
graphics/gdal/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gdal-1.1.5.tar.gz) = ec8014270a7202b5584970ccd6dbab98
|
33
graphics/gdal/files/patch-aa
Normal file
33
graphics/gdal/files/patch-aa
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- frmts/ORIG/GNUmakefile Tue Jul 17 09:51:13 2001
|
||||
+++ frmts/GNUmakefile Mon Aug 27 18:09:37 2001
|
||||
@@ -12,7 +12,7 @@
|
||||
sub-libs:
|
||||
@for dir in $(GDAL_FORMATS) ; do \
|
||||
if test -d $$dir ; then \
|
||||
- if (cd $$dir; $(MAKE) install-obj) ; then \
|
||||
+ if (cd $$dir; $(MAKE) install-obj) || exit 1 ; then \
|
||||
echo; \
|
||||
else \
|
||||
break; \
|
||||
@@ -26,7 +26,7 @@
|
||||
rm -f *.o o/*.o o/*.a
|
||||
@for dir in $(GDAL_FORMATS) ; do \
|
||||
if test -d $$dir ; then \
|
||||
- if (cd $$dir; $(MAKE) clean) ; then \
|
||||
+ if (cd $$dir; $(MAKE) clean) || exit 1 ; then \
|
||||
echo; \
|
||||
else \
|
||||
break; \
|
||||
--- ORIG/GDALmake.opt.in Fri Jul 20 00:13:54 2001
|
||||
+++ GDALmake.opt.in Tue Aug 28 16:34:12 2001
|
||||
@@ -67,8 +67,8 @@
|
||||
|
||||
GDAL_VER = 1.1
|
||||
GDAL_LIB = $(GDAL_ROOT)/gdal.a
|
||||
-GDAL_SLIB = $(GDAL_ROOT)/libgdal.$(GDAL_VER).$(SO_EXT)
|
||||
-GDAL_SLIB_LINK = -L$(GDAL_ROOT) -lgdal.$(GDAL_VER)
|
||||
+GDAL_SLIB = $(GDAL_ROOT)/libgdal.$(SO_EXT).$(GDAL_VER)
|
||||
+GDAL_SLIB_LINK = -L$(GDAL_ROOT) -lgdal
|
||||
|
||||
OGR_LIB = $(GDAL_ROOT)/ogr/ogr.a
|
||||
CPL_LIB = $(GDAL_ROOT)/port/cpl.a
|
1
graphics/gdal/pkg-comment
Normal file
1
graphics/gdal/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A translator library for raster geospatial data formats
|
14
graphics/gdal/pkg-descr
Normal file
14
graphics/gdal/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
GDAL - Geospatial Data Abstraction Library
|
||||
|
||||
GDAL is a translator library for raster geospatial data formats that is
|
||||
released under an Open Source license. As a library, it presents a single
|
||||
abstract data model to the calling application for all supported formats.
|
||||
|
||||
GDAL is in active use in a few projects, and includes a number of
|
||||
formats. Current translators include GeoTIFF (read/write), Erdas Imagine
|
||||
(read), ESRI .BIL (read/write), .aux labelled raw (read/write), DTED
|
||||
(read), SDTS DEM (read), CEOS (read), JPEG (read/write), PNG (read/write),
|
||||
Geosoft GXF (read) and Arc/Info Binary Grid (read). A full list is
|
||||
available in Supported Formats.
|
||||
|
||||
WWW: http://www.remotesensing.org/gdal/
|
63
graphics/gdal/pkg-plist
Normal file
63
graphics/gdal/pkg-plist
Normal file
|
@ -0,0 +1,63 @@
|
|||
bin/ogr2ogr
|
||||
bin/ogrinfo
|
||||
bin/gdalinfo
|
||||
bin/gdal_translate
|
||||
bin/gdaladdo
|
||||
bin/gdal-config
|
||||
include/cpl_config.h
|
||||
include/cpl_conv.h
|
||||
include/cpl_csv.h
|
||||
include/cpl_error.h
|
||||
include/cpl_port.h
|
||||
include/cpl_string.h
|
||||
include/cpl_vsi.h
|
||||
include/gdal.h
|
||||
include/gdal_frmts.h
|
||||
include/gdal_priv.h
|
||||
include/ogr_core.h
|
||||
include/ogr_feature.h
|
||||
include/ogr_geometry.h
|
||||
include/ogr_p.h
|
||||
include/ogr_spatialref.h
|
||||
include/ogr_srs_api.h
|
||||
include/ogrsf_frmts.h
|
||||
include/ogr_featurestyle.h
|
||||
lib/%%PYTHON_VERSION%%/site-packages/epsg_tr.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/esri2wkt.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/gdal.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/gdal_merge.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/gdalconst.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/gdalimport.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/gdalnumeric.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/osr.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/rgb2pct.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/_gdalmodule.so
|
||||
lib/cpl.a
|
||||
lib/ogrsf_frmts.a
|
||||
lib/ogr.a
|
||||
lib/gdal.a
|
||||
lib/libgdal.1.1.so
|
||||
share/gdal/compd_cs.csv
|
||||
share/gdal/ellips_alias.csv
|
||||
share/gdal/ellipsoid.csv
|
||||
share/gdal/gdatum_alias.csv
|
||||
share/gdal/geod_datum.csv
|
||||
share/gdal/geod_trf.csv
|
||||
share/gdal/horiz_cs.csv
|
||||
share/gdal/p_meridian.csv
|
||||
share/gdal/s57attributes.csv
|
||||
share/gdal/s57expectedinput.csv
|
||||
share/gdal/s57objectclasses.csv
|
||||
share/gdal/trf_method.csv
|
||||
share/gdal/trf_nonpolynomial.csv
|
||||
share/gdal/trf_path.csv
|
||||
share/gdal/uom_an_alias.csv
|
||||
share/gdal/uom_angle.csv
|
||||
share/gdal/uom_le_alias.csv
|
||||
share/gdal/uom_length.csv
|
||||
share/gdal/uom_sc_alias.csv
|
||||
share/gdal/uom_scale.csv
|
||||
share/gdal/vert_cs.csv
|
||||
share/gdal/vert_datum.csv
|
||||
share/gdal/vert_offset.csv
|
||||
@dirrm share/gdal
|
Loading…
Reference in a new issue