devel/pcsc-cyberjack: the port had been improved (+)

- Chase HTTP/1.1 redirections in MASTER_SITES and WWW line
- Tame dos2unix(1) to not touch every file, cleanup Makefile
- No longer needlessly depends on GNU libstdc++ and make(1)

PR:	273675 (inspired by)
This commit is contained in:
Alexey Dokuchaev 2024-01-23 12:46:56 +00:00
parent e546b16a40
commit 37fed8066f
2 changed files with 12 additions and 18 deletions

View file

@ -1,13 +1,13 @@
PORTNAME= pcsc-cyberjack
DISTVERSION= 3.99.5final.SP15
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= devel security
MASTER_SITES= https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP15/
MASTER_SITES= https://downloads.reiner-sct.de/LINUX/V3.99.5_SP15/
DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= tm@NetBSD.org
COMMENT= Reiner SCT cyberJack card reader pcsc driver
WWW= https://www.reiner-sct.de
COMMENT= Reiner SCT cyberJack card reader PCSC driver
WWW= https://www.reiner-sct.com/
LICENSE= GPLv2 LGPL20
LICENSE_COMB= dual
@ -17,22 +17,13 @@ LICENSE_FILE_LGPL20= ${WRKSRC}/COPYRIGHT.LGPL
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite \
libxml2.so:textproc/libxml2
USES= autoreconf compiler:c++11-lib dos2unix gmake libtool pkgconfig \
tar:bzip2
USE_GCC= 12
USES= autoreconf dos2unix libtool localbase pkgconfig tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-release --with-usbdropdir=${PREFIX}/lib/pcsc/drivers
DOS2UNIX_FILES= cjeca32/Debug.cpp cjeca32/RSCTCriticalSection.cpp
INSTALL_TARGET= install-strip
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
CONFIGURE_ARGS= --enable-release --with-usbdropdir=${PREFIX}/lib/pcsc/drivers
CONFIGURE_ENV= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
CXXFLAGS+= -Wno-c++11-narrowing
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
PLIST_SUB= VER=${PORTVERSION}
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- ifd/Makefile.am.orig 2021-11-03 13:00:16 UTC
+++ ifd/Makefile.am
@@ -23,6 +23,11 @@ bundleosxdir=$(usbdropdir)/libifd-cyberjack.bundle/Con
@@ -23,8 +23,13 @@ bundleosxdir=$(usbdropdir)/libifd-cyberjack.bundle/Con
bundleosx_LTLIBRARIES=libifd-cyberjack.la
endif
@ -12,3 +12,6 @@
libifd_cyberjack_la_SOURCES=ifd.cpp
libifd_cyberjack_la_LDFLAGS=-version-info @CYBERJACK_SO_CURRENT@:@CYBERJACK_SO_REVISION@:@CYBERJACK_SO_AGE@ -no-undefined
#libifd_cyberjack_la_LIBADD=$(top_builddir)/cjeca32/libeca.la $(top_builddir)/cjeca32/ausb/libausb.la
-libifd_cyberjack_la_LIBADD=$(top_builddir)/cjeca32/libeca.la -lstdc++
+libifd_cyberjack_la_LIBADD=$(top_builddir)/cjeca32/libeca.la