math/ipopt: Update 3.12.12 -> 3.12.13
The project now rebuilds and installs documentation with doxygen. Reported by: portscout
This commit is contained in:
parent
01a3c0f507
commit
3812f2a836
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=500392
4 changed files with 29 additions and 21 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= Ipopt
|
||||
DISTVERSION= 3.12.12
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 3.12.13
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://www.coin-or.org/download/source/Ipopt/ \
|
||||
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/OLD/:metis \
|
||||
|
@ -29,12 +28,17 @@ CONFIGURE_ARGS= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
|
|||
--with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib"
|
||||
|
||||
CXXFLAGS+= -ffast-math
|
||||
|
||||
OPTIONS_DEFINE= DEBUG DOCS
|
||||
PORTDOCS= *
|
||||
|
||||
DEBUG_CXXFLAGS= -fomit-frame-pointer
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/coin/doc/${PORTNAME}
|
||||
|
||||
OPTIONS_DEFINE= DEBUG DOCS
|
||||
|
||||
DOCS_ALL_TARGET= all doxydoc
|
||||
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
post-extract:
|
||||
@(${ECHO} "Extracting Metis and Mumps ThirdParty libraries ..." )
|
||||
@(cd ${WRKSRC}/ThirdParty/Metis && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/metis-4.0.3.tar.gz ${EXTRACT_AFTER_ARGS});
|
||||
|
@ -46,16 +50,7 @@ pre-patch:
|
|||
@(cd ${WRKSRC}/ThirdParty/Mumps && ${PATCH} -p0 < mumps.patch && ${PATCH} -p0 < mumps_mpi.patch )
|
||||
@(${MV} ${WRKSRC}/ThirdParty/Mumps/MUMPS/libseq/mpi.h ${WRKSRC}/ThirdParty/Mumps/MUMPS/libseq/mumps_mpi.h);
|
||||
|
||||
pre-build: # workaround: configure fails to find the 'rand' function on 12, need to investigate. This patch unbreaks the build.
|
||||
pre-build: # workaround: configure fails to find the 'rand' function, need to investigate. This patch unbreaks the build.
|
||||
@${REINPLACE_CMD} -e 's|.*HAVE_RAND.*|#define HAVE_RAND 1|' ${WRKSRC}/Ipopt/src/Common/config.h
|
||||
|
||||
post-install-DOCS-off:
|
||||
@${RM} -r ${STAGEDIR}${PREFIX}/share/coin
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/Ipopt/doc/documentation.pdf ${STAGEDIR}${DOCSDIR}
|
||||
${MV} ${STAGEDIR}${PREFIX}/share/coin/doc ${STAGEDIR}${DOCSDIR}
|
||||
@${RM} -r ${STAGEDIR}${PREFIX}/share/coin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
TIMESTAMP = 1542749999
|
||||
SHA256 (Ipopt-3.12.12.tgz) = 7baeb713ef8d1999bed397b938e9654b38ad536406634384455372dd7e4ed61f
|
||||
SIZE (Ipopt-3.12.12.tgz) = 4530034
|
||||
TIMESTAMP = 1556522441
|
||||
SHA256 (Ipopt-3.12.13.tgz) = aac9bb4d8a257fdfacc54ff3f1cbfdf6e2d61fb0cf395749e3b0c0664d3e7e96
|
||||
SIZE (Ipopt-3.12.13.tgz) = 4519682
|
||||
SHA256 (metis-4.0.3.tar.gz) = 5efa35de80703c1b2c4d0de080fafbcf4e0d363a21149a1ad2f96e0144841a55
|
||||
SIZE (metis-4.0.3.tar.gz) = 522624
|
||||
SHA256 (MUMPS_4.10.0.tar.gz) = d0f86f91a74c51a17a2ff1be9c9cee2338976f13a6d00896ba5b43a5ca05d933
|
||||
|
|
13
math/ipopt/files/patch-Makefile.in
Normal file
13
math/ipopt/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.in.orig 2019-04-29 04:09:03 UTC
|
||||
+++ Makefile.in
|
||||
@@ -711,8 +711,8 @@ clean-doxydoc :
|
||||
cd doxydoc && rm -rf html *.log *.tag
|
||||
|
||||
install-doxydoc : doxydoc
|
||||
- $(mkdir_p) $(DocInstallDir)/doxydoc
|
||||
- cp -R doxydoc/html doxydoc/ipopt_doxy.tag $(DocInstallDir)/doxydoc
|
||||
+ $(mkdir_p) $(DESTDIR)$(DocInstallDir)/doxydoc
|
||||
+ cp -R doxydoc/html doxydoc/ipopt_doxy.tag $(DESTDIR)$(DocInstallDir)/doxydoc
|
||||
|
||||
uninstall-doxydoc:
|
||||
if test -e $(DocInstallDir)/doxydoc ; then rm -rf $(DocInstallDir)/doxydoc ; fi
|
|
@ -78,13 +78,13 @@ include/coin/ThirdParty/rename.h
|
|||
include/coin/ThirdParty/struct.h
|
||||
lib/libcoinmetis.so
|
||||
lib/libcoinmetis.so.1
|
||||
lib/libcoinmetis.so.1.3.6
|
||||
lib/libcoinmetis.so.1.3.7
|
||||
lib/libcoinmumps.so
|
||||
lib/libcoinmumps.so.1
|
||||
lib/libcoinmumps.so.1.6.1
|
||||
lib/libipopt.so
|
||||
lib/libipopt.so.1
|
||||
lib/libipopt.so.1.10.12
|
||||
lib/libipopt.so.1.10.13
|
||||
libdata/pkgconfig/coinmetis.pc
|
||||
libdata/pkgconfig/coinmumps.pc
|
||||
libdata/pkgconfig/ipopt.pc
|
||||
|
|
Loading…
Reference in a new issue