[maintainer-update] ports/misc/less 374 -> 378

revive the port - it improperly suffered repo-death - and
	apply the patch below.

PR:		ports/47577
Submitted by:	Jason Harris <jharris@widomaker.com>
This commit is contained in:
Edwin Groothuis 2003-04-04 12:40:04 +00:00
parent 2d3446586a
commit 3819707a20
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=78174
12 changed files with 180 additions and 0 deletions

30
misc/less/Makefile Normal file
View file

@ -0,0 +1,30 @@
# New ports collection makefile for: less
# Date created: 8 Nov 1994
# Whom: ache
#
# $FreeBSD$
#
PORTNAME= less
PORTVERSION= 378
CATEGORIES= misc
MASTER_SITES= http://www.greenwoodsoftware.com/%SUBDIR%/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= less
MAINTAINER= jharris@widomaker.com
COMMENT= A better pager utility
.include <bsd.port.pre.mk>
GNU_CONFIGURE= yes
MAN1= less.1 lesskey.1
.if defined(COLOUR_LESS) || defined(COLOR_LESS)
MAKE_ENV= CPPFLAGS="-DCOLOUR_LESS"
pre-fetch:
@${ECHO_MSG} "Making a colour version of less."
.endif
.include <bsd.port.post.mk>

1
misc/less/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (less-378.tar.gz) = db73e39a2d1a68eafa949f80be5a28c8

11
misc/less/files/patch-aa Normal file
View file

@ -0,0 +1,11 @@
--- Makefile.in.orig Fri Apr 9 20:02:59 1999
+++ Makefile.in Thu Apr 15 23:09:36 1999
@@ -15,7 +15,7 @@
LDFLAGS = @LDFLAGS@
O=o
-LIBS = @LIBS@
+LIBS = -ltermcap
prefix = @prefix@
exec_prefix = @exec_prefix@

41
misc/less/files/patch-ab Normal file
View file

@ -0,0 +1,41 @@
--- charset.c.orig Thu Mar 23 05:36:33 2000
+++ charset.c Mon Jun 19 22:33:43 2000
@@ -267,6 +267,10 @@
control_char(c)
int c;
{
+#ifdef COLOR_LESS
+ if (c == ESC)
+ return 0;
+#endif
c &= 0377;
return (chardef[c] & IS_CONTROL_CHAR);
}
@@ -281,6 +285,20 @@
{
static char buf[8];
+#ifdef COLOR_LESS
+ if(c == ESC)
+ sprintf(buf, "%c", ESC);
+ else
+ {
+ c &= 0377;
+ if (!control_char(c))
+ sprintf(buf, "%c", c);
+ else if (!control_char(c ^ 0100))
+ sprintf(buf, "^%c", c ^ 0100);
+ else
+ sprintf(buf, binfmt, c);
+ }
+#else
c &= 0377;
if (!control_char(c))
sprintf(buf, "%c", c);
@@ -290,5 +308,6 @@
sprintf(buf, "^%c", c ^ 0100);
else
sprintf(buf, binfmt, c);
+#endif
return (buf);
}

4
misc/less/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
This is the distribution of "less", a paginator similar to "more" or "pg",
but much more powerful.
WWW: http://www.greenwoodsoftware.com/less/

3
misc/less/pkg-plist Normal file
View file

@ -0,0 +1,3 @@
bin/less
bin/lesskey
bin/lessecho

30
sysutils/less/Makefile Normal file
View file

@ -0,0 +1,30 @@
# New ports collection makefile for: less
# Date created: 8 Nov 1994
# Whom: ache
#
# $FreeBSD$
#
PORTNAME= less
PORTVERSION= 378
CATEGORIES= misc
MASTER_SITES= http://www.greenwoodsoftware.com/%SUBDIR%/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= less
MAINTAINER= jharris@widomaker.com
COMMENT= A better pager utility
.include <bsd.port.pre.mk>
GNU_CONFIGURE= yes
MAN1= less.1 lesskey.1
.if defined(COLOUR_LESS) || defined(COLOR_LESS)
MAKE_ENV= CPPFLAGS="-DCOLOUR_LESS"
pre-fetch:
@${ECHO_MSG} "Making a colour version of less."
.endif
.include <bsd.port.post.mk>

1
sysutils/less/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (less-378.tar.gz) = db73e39a2d1a68eafa949f80be5a28c8

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig Fri Apr 9 20:02:59 1999
+++ Makefile.in Thu Apr 15 23:09:36 1999
@@ -15,7 +15,7 @@
LDFLAGS = @LDFLAGS@
O=o
-LIBS = @LIBS@
+LIBS = -ltermcap
prefix = @prefix@
exec_prefix = @exec_prefix@

View file

@ -0,0 +1,41 @@
--- charset.c.orig Thu Mar 23 05:36:33 2000
+++ charset.c Mon Jun 19 22:33:43 2000
@@ -267,6 +267,10 @@
control_char(c)
int c;
{
+#ifdef COLOR_LESS
+ if (c == ESC)
+ return 0;
+#endif
c &= 0377;
return (chardef[c] & IS_CONTROL_CHAR);
}
@@ -281,6 +285,20 @@
{
static char buf[8];
+#ifdef COLOR_LESS
+ if(c == ESC)
+ sprintf(buf, "%c", ESC);
+ else
+ {
+ c &= 0377;
+ if (!control_char(c))
+ sprintf(buf, "%c", c);
+ else if (!control_char(c ^ 0100))
+ sprintf(buf, "^%c", c ^ 0100);
+ else
+ sprintf(buf, binfmt, c);
+ }
+#else
c &= 0377;
if (!control_char(c))
sprintf(buf, "%c", c);
@@ -290,5 +308,6 @@
sprintf(buf, "^%c", c ^ 0100);
else
sprintf(buf, binfmt, c);
+#endif
return (buf);
}

4
sysutils/less/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
This is the distribution of "less", a paginator similar to "more" or "pg",
but much more powerful.
WWW: http://www.greenwoodsoftware.com/less/

3
sysutils/less/pkg-plist Normal file
View file

@ -0,0 +1,3 @@
bin/less
bin/lesskey
bin/lessecho