- Update to 0.9
PR: ports/141384 Submitted by: Erik Greenwald <erik@smluc.org> (maintainer)
This commit is contained in:
parent
6e3f5014f0
commit
383e96cfb0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249657
12 changed files with 67 additions and 395 deletions
|
@ -6,10 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= gauche
|
||||
PORTVERSION= 0.8.13 # Keep databases/gauche-gdbm in sync with this
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.9 # Keep databases/gauche-gdbm in sync with this
|
||||
CATEGORIES= lang scheme
|
||||
MASTER_SITES= SF/${PORTNAME}/Gauche/${PORTVERSION}
|
||||
MASTER_SITES= SF/${PORTNAME}/Gauche/
|
||||
DISTNAME= Gauche-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
|
@ -54,9 +53,6 @@ INFO= gauche-refe gauche-refj
|
|||
BROKEN= Does not compile on ${ARCH}
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
${REINPLACE_CMD} 's/gauche-refj. info/gauche-refj.info/' ${WRKSRC}/doc/gauche-refj.info
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${PREFIX}/bin/gosh
|
||||
${RM} -f ${PREFIX}/share/gauche/${PORTVERSION}/lib/slibcat
|
||||
|
@ -71,7 +67,7 @@ post-install:
|
|||
${TOUCH} ${EXAMPLESDIR}/.keepme
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1/
|
||||
.if !defined(NOPORTDOCS)
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.info ${WRKSRC}/doc/*.info-[1-7] ${PREFIX}/info/
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.info.gz ${WRKSRC}/doc/*.info-[1-7].gz ${PREFIX}/info/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (Gauche-0.8.13.tgz) = 65669fd7a8916cc9496965ed2ae43c98
|
||||
SHA256 (Gauche-0.8.13.tgz) = bc0a9fff8b4b326eb1b827be36fcdfee851f16f5107de5b770dce720c9884fe7
|
||||
SIZE (Gauche-0.8.13.tgz) = 3377336
|
||||
MD5 (Gauche-0.9.tgz) = 1ab7e09da8436950989efd55b5dc270a
|
||||
SHA256 (Gauche-0.9.tgz) = 9faa8e79d83152599e945380e874718642d25657803432b5c826a7d3711c9250
|
||||
SIZE (Gauche-0.9.tgz) = 3938498
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
--- doc/Makefile.in.orig Sun Oct 22 03:55:35 2006
|
||||
+++ doc/Makefile.in Sun Nov 12 12:14:52 2006
|
||||
@@ -79,7 +79,7 @@
|
||||
|
||||
pdf : gauche-refe.pdf
|
||||
|
||||
-info : gauche-refe.info.gz gauche-refj.info.gz
|
||||
+info : gauche-refe.info gauche-refj.info
|
||||
|
||||
gauche-refe.html : gauche-refe.texi
|
||||
texi2html --number gauche-refe.texi
|
||||
@@ -96,11 +96,9 @@
|
||||
gauche-refe.texi : $(TEXIS) extract
|
||||
$(GOSH) ./extract -en -o gauche-refe.texi gauche-ref.texi
|
||||
|
||||
-gauche-refe.info.gz : gauche-refe.texi
|
||||
+gauche-refe.info : gauche-refe.texi
|
||||
if test X$(MAKEINFO) != X -a X$(GZIP_PROGRAM) != X; then \
|
||||
env LANG=C $(MAKEINFO) --no-warn gauche-refe.texi; \
|
||||
- rm -rf gauche-refe.info*.gz; \
|
||||
- $(GZIP_PROGRAM) gauche-refe.info gauche-refe.info-[0-9]*; \
|
||||
fi
|
||||
|
||||
gauche-refj.html : gauche-refj.texi
|
||||
@@ -121,11 +119,9 @@
|
||||
gauche-refj.texi : $(TEXIS) extract
|
||||
$(GOSH) ./extract -jp -o gauche-refj.texi gauche-ref.texi
|
||||
|
||||
-gauche-refj.info.gz : gauche-refj.texi
|
||||
+gauche-refj.info : gauche-refj.texi
|
||||
if test X$(MAKEINFO) != X -a X$(GZIP_PROGRAM) != X; then \
|
||||
env LANG=C $(MAKEINFO) --no-warn gauche-refj.texi; \
|
||||
- rm -rf gauche-refj.info*.gz; \
|
||||
- $(GZIP_PROGRAM) gauche-refj.info gauche-refj.info-[0-9]*; \
|
||||
fi
|
||||
|
||||
gauche-deve.texi : gauche-dev.texi extract
|
|
@ -1,82 +0,0 @@
|
|||
--- ./gc/dbg_mlc.c.orig Sat Mar 4 12:55:43 2006
|
||||
+++ ./gc/dbg_mlc.c Tue May 9 14:38:56 2006
|
||||
@@ -477,6 +477,23 @@
|
||||
GC_register_displacement((word)sizeof(oh) + offset);
|
||||
}
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <dlfcn.h>
|
||||
+static void GC_caller_func_offset(ad, symp, offp)
|
||||
+const GC_word ad;
|
||||
+const char **symp;
|
||||
+int *offp;
|
||||
+{
|
||||
+ Dl_info caller;
|
||||
+ if (dladdr((const void *)ad, &caller) && caller.dli_sname != NULL) {
|
||||
+ *symp = caller.dli_sname;
|
||||
+ *offp = (const char *)ad - (const char *)caller.dli_saddr;
|
||||
+ }
|
||||
+}
|
||||
+#else
|
||||
+#define GC_caller_func(ad, symp, offp)
|
||||
+#endif
|
||||
+
|
||||
# ifdef __STDC__
|
||||
GC_PTR GC_debug_malloc(size_t lb, GC_EXTRA_PARAMS)
|
||||
# else
|
||||
@@ -491,6 +508,13 @@
|
||||
{
|
||||
GC_PTR result = GC_malloc(lb + DEBUG_BYTES);
|
||||
|
||||
+#ifdef GC_ADD_CALLER
|
||||
+ if (s == NULL) {
|
||||
+ GC_caller_func_offset(ra, &s, &i);
|
||||
+ if (s == NULL)
|
||||
+ s = "unknown";
|
||||
+ }
|
||||
+#endif
|
||||
if (result == 0) {
|
||||
GC_err_printf1("GC_debug_malloc(%ld) returning NIL (",
|
||||
(unsigned long) lb);
|
||||
@@ -880,6 +904,13 @@
|
||||
register size_t old_sz;
|
||||
register hdr * hhdr;
|
||||
|
||||
+#ifdef GC_ADD_CALLER
|
||||
+ if (s == NULL) {
|
||||
+ GC_caller_func_offset(ra, &s, &i);
|
||||
+ if (s == NULL)
|
||||
+ s = "unknown";
|
||||
+ }
|
||||
+#endif
|
||||
if (p == 0) return(GC_debug_malloc(lb, OPT_RA s, i));
|
||||
if (base == 0) {
|
||||
GC_err_printf1(
|
||||
@@ -1188,7 +1219,11 @@
|
||||
}
|
||||
|
||||
#ifdef GC_ADD_CALLER
|
||||
-# define RA GC_RETURN_ADDR,
|
||||
+# ifdef GC_RETURN_ADDR_PARENT
|
||||
+# define RA GC_RETURN_ADDR_PARENT,
|
||||
+# else
|
||||
+# define RA GC_RETURN_ADDR,
|
||||
+# endif
|
||||
#else
|
||||
# define RA
|
||||
#endif
|
||||
@@ -1196,12 +1231,12 @@
|
||||
GC_PTR GC_debug_malloc_replacement(lb)
|
||||
size_t lb;
|
||||
{
|
||||
- return GC_debug_malloc(lb, RA "unknown", 0);
|
||||
+ return GC_debug_malloc(lb, RA NULL, 0);
|
||||
}
|
||||
|
||||
GC_PTR GC_debug_realloc_replacement(p, lb)
|
||||
GC_PTR p;
|
||||
size_t lb;
|
||||
{
|
||||
- return GC_debug_realloc(p, lb, RA "unknown", 0);
|
||||
+ return GC_debug_realloc(p, lb, RA NULL, 0);
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- ./gc/doc/Makefile.in.orig Sat Mar 4 12:55:44 2006
|
||||
+++ ./gc/doc/Makefile.in Tue May 9 14:38:56 2006
|
||||
@@ -30,7 +30,7 @@
|
||||
srcdir = @srcdir@
|
||||
top_srcdir = @top_srcdir@
|
||||
VPATH = @srcdir@
|
||||
-pkgdatadir = $(datadir)/@PACKAGE@
|
||||
+pkgdatadir = $(datadir)/doc/@PACKAGE@
|
||||
pkglibdir = $(libdir)/@PACKAGE@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
top_builddir = ..
|
|
@ -1,60 +0,0 @@
|
|||
--- ./gc/doc/gc.man.orig Tue Sep 14 17:40:06 2004
|
||||
+++ ./gc/doc/gc.man Tue May 9 14:38:56 2006
|
||||
@@ -11,7 +11,7 @@
|
||||
void * GC_realloc(void *ptr, size_t size);
|
||||
.br
|
||||
.sp
|
||||
-cc ... gc.a
|
||||
+cc ... -lgc
|
||||
.LP
|
||||
.SH DESCRIPTION
|
||||
.I GC_malloc
|
||||
@@ -81,6 +81,48 @@
|
||||
This may temporarily write protect pages in the heap. See the README file for more information on how this interacts with system calls that write to the heap.
|
||||
.LP
|
||||
Other facilities not discussed here include limited facilities to support incremental collection on machines without appropriate VM support, provisions for providing more explicit object layout information to the garbage collector, more direct support for ``weak'' pointers, support for ``abortable'' garbage collections during idle time, etc.
|
||||
+.LP
|
||||
+.SH "PORT INFORMATION"
|
||||
+.LP
|
||||
+In this (FreeBSD package) installation,
|
||||
+.I gc.h
|
||||
+and
|
||||
+.I gc_cpp.h
|
||||
+will probably be found in
|
||||
+.I %%PREFIX%%/include,
|
||||
+and the library in
|
||||
+.I %%PREFIX%%/lib.
|
||||
+.LP
|
||||
+This library has been compiled as drop-in replacements
|
||||
+for malloc and free (which is to say, all malloc
|
||||
+calls will allocate garbage-collectable data).
|
||||
+There is no need to include "gc.h" in your C files unless you want
|
||||
+access to the debugging (and other) functions defined there,
|
||||
+or unless you want to explicitly use
|
||||
+.I GC_malloc_uncollectable
|
||||
+for some allocations.
|
||||
+Just link against them whenever you want either garbage
|
||||
+collection or leak detection.
|
||||
+.LP
|
||||
+The C++ header file, "gc_cpp.h",
|
||||
+.I is
|
||||
+necessary for C++ programs, to obtain the appropriate
|
||||
+definitions of the
|
||||
+.I new
|
||||
+and
|
||||
+.I delete
|
||||
+operators.
|
||||
+The comments in both of these header files presently
|
||||
+provide far better documentation
|
||||
+for the package than this man page;
|
||||
+look there for more information.
|
||||
+.LP
|
||||
+This library is compiled without (explicit) support
|
||||
+for the experimental
|
||||
+.I gc
|
||||
+extension of
|
||||
+.I g++.
|
||||
+This may or may not make a difference.
|
||||
.LP
|
||||
.SH "SEE ALSO"
|
||||
The README and gc.h files in the distribution. More detailed definitions of the functions exported by the collector are given there. (The above list is not complete.)
|
|
@ -1,15 +0,0 @@
|
|||
--- ./gc/dyn_load.c.orig Sat Mar 4 12:55:43 2006
|
||||
+++ ./gc/dyn_load.c Tue May 9 14:38:56 2006
|
||||
@@ -102,6 +102,12 @@
|
||||
# else
|
||||
# define ElfW(type) Elf64_##type
|
||||
# endif
|
||||
+# elif defined(__FreeBSD__)
|
||||
+# if __ELF_WORD_SIZE == 32
|
||||
+# define ElfW(type) Elf32_##type
|
||||
+# else
|
||||
+# define ElfW(type) Elf64_##type
|
||||
+# endif
|
||||
# else
|
||||
# ifdef NETBSD
|
||||
# if ELFSIZE == 32
|
|
@ -1,10 +0,0 @@
|
|||
--- ./gc/include/gc.h.orig Sat Mar 4 12:55:44 2006
|
||||
+++ ./gc/include/gc.h Tue May 9 14:38:56 2006
|
||||
@@ -504,6 +504,7 @@
|
||||
/* gcc knows how to retrieve return address, but we don't know */
|
||||
/* how to generate call stacks. */
|
||||
# define GC_RETURN_ADDR (GC_word)__builtin_return_address(0)
|
||||
+# define GC_RETURN_ADDR_PARENT (GC_word)__builtin_return_address(1)
|
||||
# else
|
||||
/* Just pass 0 for gcc compatibility. */
|
||||
# define GC_RETURN_ADDR 0
|
|
@ -1,20 +0,0 @@
|
|||
--- ./gc/include/gc_cpp.h.orig Sat Mar 4 12:55:44 2006
|
||||
+++ ./gc/include/gc_cpp.h Tue May 9 14:38:56 2006
|
||||
@@ -281,7 +281,7 @@
|
||||
else
|
||||
return GC_MALLOC_UNCOLLECTABLE( size );}
|
||||
|
||||
-inline void* gc::operator new( size_t size, void *p ) {
|
||||
+inline void* gc::operator new( size_t, void *p ) {
|
||||
return p;}
|
||||
|
||||
inline void gc::operator delete( void* obj ) {
|
||||
@@ -299,7 +299,7 @@
|
||||
inline void* gc::operator new[]( size_t size, GCPlacement gcp ) {
|
||||
return gc::operator new( size, gcp );}
|
||||
|
||||
-inline void* gc::operator new[]( size_t size, void *p ) {
|
||||
+inline void* gc::operator new[]( size_t, void *p ) {
|
||||
return p;}
|
||||
|
||||
inline void gc::operator delete[]( void* obj ) {
|
|
@ -1,88 +0,0 @@
|
|||
--- ./gc/include/private/gcconfig.h.orig Sat Mar 4 12:55:44 2006
|
||||
+++ ./gc/include/private/gcconfig.h Tue May 9 14:38:56 2006
|
||||
@@ -62,7 +62,7 @@
|
||||
/* Determine the machine type: */
|
||||
# if defined(__arm__) || defined(__thumb__)
|
||||
# define ARM32
|
||||
-# if !defined(LINUX) && !defined(NETBSD)
|
||||
+# if !defined(LINUX) && !defined(NETBSD) && !defined(FREEBSD)
|
||||
# define NOSYS
|
||||
# define mach_type_known
|
||||
# endif
|
||||
@@ -335,10 +335,22 @@
|
||||
# define X86_64
|
||||
# define mach_type_known
|
||||
# endif
|
||||
+# if defined(__FreeBSD__) && defined(__amd64__)
|
||||
+# define X86_64
|
||||
+# define mach_type_known
|
||||
+# endif
|
||||
# if defined(FREEBSD) && defined(__sparc__)
|
||||
# define SPARC
|
||||
# define mach_type_known
|
||||
-#endif
|
||||
+# endif
|
||||
+# if defined(FREEBSD) && defined(__powerpc__)
|
||||
+# define POWERPC
|
||||
+# define mach_type_known
|
||||
+# endif
|
||||
+# if defined(FREEBSD) && defined(__arm__)
|
||||
+# define ARM32
|
||||
+# define mach_type_known
|
||||
+# endif
|
||||
# if defined(bsdi) && (defined(i386) || defined(__i386__))
|
||||
# define I386
|
||||
# define BSDI
|
||||
@@ -853,6 +865,16 @@
|
||||
# define DATASTART GC_data_start
|
||||
# define DYNAMIC_LOADING
|
||||
# endif
|
||||
+# ifdef FREEBSD
|
||||
+# define ALIGNMENT 4
|
||||
+# define OS_TYPE "FREEBSD"
|
||||
+# ifdef __ELF__
|
||||
+# define DYNAMIC_LOADING
|
||||
+# endif
|
||||
+# define HEURISTIC2
|
||||
+ extern char etext[];
|
||||
+# define SEARCH_FOR_DATA_START
|
||||
+# endif
|
||||
# ifdef NOSYS
|
||||
# define ALIGNMENT 4
|
||||
# define OS_TYPE "NOSYS"
|
||||
@@ -1848,6 +1870,17 @@
|
||||
# endif
|
||||
# define USE_GENERIC_PUSH_REGS
|
||||
# endif
|
||||
+# ifdef FREEBSD
|
||||
+# define ALIGNMENT 4
|
||||
+# define OS_TYPE "FREEBSD"
|
||||
+# ifdef __ELF__
|
||||
+# define DYNAMIC_LOADING
|
||||
+# endif
|
||||
+# define HEURISTIC2
|
||||
+ extern char etext[];
|
||||
+# define SEARCH_FOR_DATA_START
|
||||
+# endif
|
||||
+
|
||||
# ifdef LINUX
|
||||
# define OS_TYPE "LINUX"
|
||||
# define LINUX_STACKBOTTOM
|
||||
@@ -1998,6 +2031,17 @@
|
||||
# ifdef __ELF__
|
||||
# define DYNAMIC_LOADING
|
||||
# endif
|
||||
+# define HEURISTIC2
|
||||
+ extern char etext[];
|
||||
+# define SEARCH_FOR_DATA_START
|
||||
+# endif
|
||||
+# ifdef FREEBSD
|
||||
+# define OS_TYPE "FREEBSD"
|
||||
+# define SIG_SUSPEND SIGUSR1
|
||||
+# define SIG_THR_RESTART SIGUSR2
|
||||
+# ifdef __ELF__
|
||||
+# define DYNAMIC_LOADING
|
||||
+# endif
|
||||
# define HEURISTIC2
|
||||
extern char etext[];
|
||||
# define SEARCH_FOR_DATA_START
|
|
@ -1,29 +0,0 @@
|
|||
--- ./gc/os_dep.c.orig Sat Mar 4 12:55:44 2006
|
||||
+++ ./gc/os_dep.c Tue May 9 14:38:56 2006
|
||||
@@ -694,7 +694,7 @@
|
||||
|| defined(HURD) || defined(NETBSD)
|
||||
static struct sigaction old_segv_act;
|
||||
# if defined(IRIX5) || defined(HPUX) \
|
||||
- || defined(HURD) || defined(NETBSD)
|
||||
+ || defined(HURD) || defined(NETBSD) || defined(FREEBSD)
|
||||
static struct sigaction old_bus_act;
|
||||
# endif
|
||||
# else
|
||||
@@ -709,7 +709,7 @@
|
||||
# endif
|
||||
{
|
||||
# if defined(SUNOS5SIGS) || defined(IRIX5) \
|
||||
- || defined(OSF1) || defined(HURD) || defined(NETBSD)
|
||||
+ || defined(OSF1) || defined(HURD) || defined(NETBSD) || defined(FREEBSD)
|
||||
struct sigaction act;
|
||||
|
||||
act.sa_handler = h;
|
||||
@@ -731,7 +731,7 @@
|
||||
# else
|
||||
(void) sigaction(SIGSEGV, &act, &old_segv_act);
|
||||
# if defined(IRIX5) \
|
||||
- || defined(HPUX) || defined(HURD) || defined(NETBSD)
|
||||
+ || defined(HPUX) || defined(HURD) || defined(NETBSD) || defined(FREEBSD)
|
||||
/* Under Irix 5.x or HP/UX, we may get SIGBUS. */
|
||||
/* Pthreads doesn't exist under Irix 5.x, so we */
|
||||
/* don't have to worry in the threads case. */
|
|
@ -5,46 +5,49 @@ bin/gauche-config
|
|||
bin/gauche-install
|
||||
bin/gauche-package
|
||||
bin/gosh
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/auxsys.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/binary.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/fcntl.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/file-util-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/binary--io.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/dbm--ndbm.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/file--util.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--auxsys.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--charconv.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--collection.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--fcntl.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--hook.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--net.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--parameter.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--sequence.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--syslog.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--termios.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--threads.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche--vport.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-cesconv
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-collection-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-config
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-hook-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-install
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-package
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-parameter-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gauche-sequence-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/gosh
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/libcharconv.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/libgauche-uvector.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/libgauche.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/libnet.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/md5.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/mt-random.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/ndbm.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sha1.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-1-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-13-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-19-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-43-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml-serializer.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml-ssax.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml-sxpath.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml-tools.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/syslog.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/termios.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/text-gettext-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/text-tr-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/threads.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/util-match-lib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/vport.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/math--mt-random.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/rfc--md5.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/rfc--sha.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/rfc--zlib.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-1.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-13.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-19.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/srfi-43.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml--serializer.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml--ssax.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml--sxpath.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/sxml--tools.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/text--gettext.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/text--tr.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/util--match.so
|
||||
lib/gauche/%%VERSION%%/%%TARGET%%/util--sparse.so
|
||||
lib/gauche/%%VERSION%%/include/gauche.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/arch.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/bignum.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/bits.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/bits_inline.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/builtin-syms.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/char_euc_jp.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/char_none.h
|
||||
|
@ -64,12 +67,16 @@ lib/gauche/%%VERSION%%/include/gauche/hash.h
|
|||
lib/gauche/%%VERSION%%/include/gauche/int64.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/keyword.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/load.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/mingw-compat.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/net.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/macro.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/module.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/number.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/parameter.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/paths.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/port.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/prof.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/pthread.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/reader.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/regexp.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/scmconst.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/string.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/symbol.h
|
||||
|
@ -81,13 +88,21 @@ lib/gauche/%%VERSION%%/include/gauche/vector.h
|
|||
lib/gauche/%%VERSION%%/include/gauche/vm.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/vminsn.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/weak.h
|
||||
lib/gauche/%%VERSION%%/include/gauche/win-compat.h
|
||||
lib/gauche/%%VERSION%%/include/gc.h
|
||||
lib/gauche/%%VERSION%%/include/gc_allocator.h
|
||||
lib/gauche/%%VERSION%%/include/gc_config_macros.h
|
||||
lib/gauche/%%VERSION%%/include/gc_cpp.h
|
||||
lib/gauche/%%VERSION%%/include/gc_inline.h
|
||||
lib/gauche/%%VERSION%%/include/gc_mark.h
|
||||
lib/gauche/%%VERSION%%/include/gc_pthread_redirects.h
|
||||
lib/gauche/%%VERSION%%/include/gc_tiny_fl.h
|
||||
lib/gauche/%%VERSION%%/include/gc_typed.h
|
||||
lib/gauche/%%VERSION%%/include/gc_version.h
|
||||
lib/gauche/site/%%VERSION%%/%%TARGET%%/.keepme
|
||||
lib/libgauche.so
|
||||
lib/libgauche.so.%%VERSION%%
|
||||
lib/libgauche.so.0
|
||||
lib/libgauche.so.%%VERSION%%.0
|
||||
share/aclocal/gauche.m4
|
||||
%%DATADIR%%/%%VERSION%%/aclocal.m4
|
||||
%%DATADIR%%/%%VERSION%%/lib/.packages/.keepme
|
||||
|
@ -109,7 +124,11 @@ share/aclocal/gauche.m4
|
|||
%%DATADIR%%/%%VERSION%%/lib/gauche/auxsys.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/cise.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/literal-uv.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/literal.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/precomp.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/stub.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/type.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/cgen/unit.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/charconv.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/collection.scm
|
||||
|
@ -118,6 +137,9 @@ share/aclocal/gauche.m4
|
|||
%%DATADIR%%/%%VERSION%%/lib/gauche/config.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/defvalues.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/dictionary.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/experimental/app.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/experimental/lamb.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/experimental/ref.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/fcntl.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/fileutil.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/hashutil.scm
|
||||
|
@ -132,7 +154,6 @@ share/aclocal/gauche.m4
|
|||
%%DATADIR%%/%%VERSION%%/lib/gauche/logical.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/macroutil.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/matrix.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/miscutil.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/modutil.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/mop/instance-pool.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/mop/propagate.scm
|
||||
|
@ -171,12 +192,15 @@ share/aclocal/gauche.m4
|
|||
%%DATADIR%%/%%VERSION%%/lib/gauche/validator.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/version.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/vm/debugger.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/vm/insn-core.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/vm/insn.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/vm/profiler.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gauche/vport.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/gencomp
|
||||
%%DATADIR%%/%%VERSION%%/lib/genstub
|
||||
%%DATADIR%%/%%VERSION%%/lib/math/const.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/math/mt-random.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/precomp
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/822.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/base64.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/cookie.scm
|
||||
|
@ -188,8 +212,10 @@ share/aclocal/gauche.m4
|
|||
%%DATADIR%%/%%VERSION%%/lib/rfc/md5.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/mime.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/quoted-printable.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/sha.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/sha1.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/uri.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/rfc/zlib.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/slib.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/srfi-0.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/srfi-1.scm
|
||||
|
@ -240,6 +266,7 @@ share/aclocal/gauche.m4
|
|||
%%DATADIR%%/%%VERSION%%/lib/util/rbtree.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/util/record.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/util/relation.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/util/sparse.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/util/stream.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/util/toposort.scm
|
||||
%%DATADIR%%/%%VERSION%%/lib/util/tree.scm
|
||||
|
@ -273,6 +300,7 @@ share/aclocal/gauche.m4
|
|||
@dirrm %%DATADIR%%/%%VERSION%%/lib/gauche/package
|
||||
@dirrm %%DATADIR%%/%%VERSION%%/lib/gauche/mop
|
||||
@dirrm %%DATADIR%%/%%VERSION%%/lib/gauche/interactive
|
||||
@dirrm %%DATADIR%%/%%VERSION%%/lib/gauche/experimental
|
||||
@dirrm %%DATADIR%%/%%VERSION%%/lib/gauche/cgen
|
||||
@dirrm %%DATADIR%%/%%VERSION%%/lib/gauche
|
||||
@dirrm %%DATADIR%%/%%VERSION%%/lib/file
|
||||
|
|
Loading…
Reference in a new issue