Don't install teapop.passwd -- only install teapop.passwd.sample, and

let the user know they need to copy it to teapop.passwd before using
teapop.
This commit is contained in:
Jim Mock 2001-03-11 01:08:47 +00:00
parent a283186713
commit 389518e808
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39500
4 changed files with 42 additions and 26 deletions

View file

@ -51,4 +51,12 @@ CONFIGURE_ARGS+= --with-drac=${PREFIX}/lib \
MAN8= teapop.8
post-install:
@${ECHO} " "
@${ECHO} "------------------------------------------------------------------------"
@${ECHO} "===> Be sure to copy ${LOCALBASE}/etc/teapop.passwd.sample to"
@${ECHO} "===> ${LOCALBASE}/etc/teapop.passwd before using teapop"
@${ECHO} "------------------------------------------------------------------------"
@${ECHO} " "
.include <bsd.port.mk>

View file

@ -1,21 +1,21 @@
--- etc/Makefile.in.orig Sat Aug 12 16:28:44 2000
+++ etc/Makefile.in Sat Aug 12 17:15:14 2000
@@ -23,14 +23,15 @@
--- etc/Makefile.in.orig Sat Mar 10 19:51:58 2001
+++ etc/Makefile.in Sat Mar 10 19:55:01 2001
@@ -23,15 +23,9 @@
fi
install: build
+ @echo installing teapop.passwd.sample; \
+ ${INSTALL} -d ${sysconfdir}; \
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}/teapop.passwd.sample;
@echo Checking for existing teapop.passwd; \
if [ -f ${sysconfdir}/teapop.passwd ]; then \
echo "Exists...NOT installing teapop.passwd"; \
else \
echo "Not found, installing teapop.passwd"; \
- @echo Checking for existing teapop.passwd; \
- if [ -f ${sysconfdir}/teapop.passwd ]; then \
- echo "Exists...NOT installing teapop.passwd"; \
- else \
- echo "Not found, installing teapop.passwd"; \
- ${INSTALL} -d ${sysconfdir}; \
- ${INSTALL} teapop.passwd ${sysconfdir}; \
- ${CHMOD} 0755 ${sysconfdir}/teapop.passwd; \
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}; \
fi
- fi
+ @echo Installing teapop.passwd.sample; \
+ ${INSTALL} -d ${sysconfdir}
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}/teapop.passwd.sample;
makefile: ../config/timestamp
@echo Updating Makefile

View file

@ -51,4 +51,12 @@ CONFIGURE_ARGS+= --with-drac=${PREFIX}/lib \
MAN8= teapop.8
post-install:
@${ECHO} " "
@${ECHO} "------------------------------------------------------------------------"
@${ECHO} "===> Be sure to copy ${LOCALBASE}/etc/teapop.passwd.sample to"
@${ECHO} "===> ${LOCALBASE}/etc/teapop.passwd before using teapop"
@${ECHO} "------------------------------------------------------------------------"
@${ECHO} " "
.include <bsd.port.mk>

View file

@ -1,21 +1,21 @@
--- etc/Makefile.in.orig Sat Aug 12 16:28:44 2000
+++ etc/Makefile.in Sat Aug 12 17:15:14 2000
@@ -23,14 +23,15 @@
--- etc/Makefile.in.orig Sat Mar 10 19:51:58 2001
+++ etc/Makefile.in Sat Mar 10 19:55:01 2001
@@ -23,15 +23,9 @@
fi
install: build
+ @echo installing teapop.passwd.sample; \
+ ${INSTALL} -d ${sysconfdir}; \
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}/teapop.passwd.sample;
@echo Checking for existing teapop.passwd; \
if [ -f ${sysconfdir}/teapop.passwd ]; then \
echo "Exists...NOT installing teapop.passwd"; \
else \
echo "Not found, installing teapop.passwd"; \
- @echo Checking for existing teapop.passwd; \
- if [ -f ${sysconfdir}/teapop.passwd ]; then \
- echo "Exists...NOT installing teapop.passwd"; \
- else \
- echo "Not found, installing teapop.passwd"; \
- ${INSTALL} -d ${sysconfdir}; \
- ${INSTALL} teapop.passwd ${sysconfdir}; \
- ${CHMOD} 0755 ${sysconfdir}/teapop.passwd; \
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}; \
fi
- fi
+ @echo Installing teapop.passwd.sample; \
+ ${INSTALL} -d ${sysconfdir}
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}/teapop.passwd.sample;
makefile: ../config/timestamp
@echo Updating Makefile