Clean up the patch section of the Makefile. Added one level of
directories to patch-a[ab] to make the Makefile simpler
This commit is contained in:
parent
57ba1b4792
commit
38d1697d55
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33974
3 changed files with 7 additions and 14 deletions
|
@ -43,17 +43,10 @@ CONFIGURE_ARGS?= --with-gnu-as --with-gnu-ld --with-newlib --verbose \
|
|||
CONFIGURE_WRKSRC?= ${WRKDIR}/build-${LCLTARGET}
|
||||
CONFIGURE_SCRIPT?= ../${F77NAME}/configure
|
||||
|
||||
MAKE_FLAGS= LANGUAGES="f77"
|
||||
PATCH_WRKSRC= ${WRKDIR}
|
||||
PATCH_STRIP= -p
|
||||
|
||||
.if defined(PATCH_DEBUG)
|
||||
PATCH_DEBUG_TMP= yes
|
||||
PATCH_ARGS= -d ${WRKDIR}/${F77NAME} -E ${PATCH_STRIP}
|
||||
PATCH_DIST_ARGS= -d ${WRKDIR} -E ${PATCH_DIST_STRIP}
|
||||
.else
|
||||
PATCH_DEBUG_TMP= no
|
||||
PATCH_ARGS= -d ${WRKDIR}/${F77NAME} --forward --quiet -E ${PATCH_STRIP}
|
||||
PATCH_DIST_ARGS= -d ${WRKDIR} --forward --quiet -E ${PATCH_DIST_STRIP}
|
||||
.endif
|
||||
MAKE_FLAGS= LANGUAGES="f77"
|
||||
|
||||
pre-configure:
|
||||
@(cd ${WRKDIR} ; \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- Makefile.in.orig Fri Sep 1 21:07:00 2000
|
||||
+++ Makefile.in Fri Sep 1 21:16:11 2000
|
||||
--- gcc-2.95.2/Makefile.in.orig Fri Sep 1 21:07:00 2000
|
||||
+++ gcc-2.95.2/Makefile.in Fri Sep 1 21:16:11 2000
|
||||
@@ -656,9 +656,7 @@
|
||||
install-autoconf \
|
||||
install-automake \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- gcc/Makefile.in.orig Fri Aug 13 03:46:55 1999
|
||||
+++ gcc/Makefile.in Fri Sep 1 21:15:38 2000
|
||||
--- gcc-2.95.2/gcc/Makefile.in.orig Fri Aug 13 03:46:55 1999
|
||||
+++ gcc-2.95.2/gcc/Makefile.in Fri Sep 1 21:15:38 2000
|
||||
@@ -400,7 +400,7 @@
|
||||
MAYBE_USE_COLLECT2 = @maybe_use_collect2@
|
||||
# It is convenient for configure to add the assignment at the beginning,
|
||||
|
|
Loading…
Reference in a new issue