Remove the devel/cs port, as it is no longer maintained and

officially discontinued in favor of the free version of cscope.

PR:		47894
Submitted by:	"Sergey A.Osokin" <osa@FreeBSD.org.ru>
This commit is contained in:
Peter Pentchev 2003-02-11 14:44:58 +00:00
parent 001f601d6d
commit 38dbb75757
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=75298
7 changed files with 0 additions and 83 deletions

View file

@ -111,7 +111,6 @@
SUBDIR += crossgo32-djgpp2
SUBDIR += crossgo32-djgpp2-pdcurses
SUBDIR += crystal
SUBDIR += cs
SUBDIR += cscope
SUBDIR += cssc
SUBDIR += ctags

View file

@ -1,28 +0,0 @@
# New ports collection makefile for: cs
# Date created: 22 May 1997
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= cs
PORTVERSION= 0.5
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.moria.de/~michael/cs/
DIST_SUBDIR= cs/0.5-19990925
MAINTAINER= ports@FreeBSD.org
ALL_TARGET= cs
MAN1= cs.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cs ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cs.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/ANNOUNCE ${DOCSDIR}
.endif
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (cs/0.5-19990925/cs-0.5.tar.gz) = 3cd38e56f0b7b14f3cd60ec2fcb60e51

View file

@ -1,28 +0,0 @@
--- Makefile.orig Sat Sep 25 06:33:12 1999
+++ Makefile Fri Jan 5 11:09:24 2001
@@ -2,7 +2,7 @@
#DB= BINARY_DB
#{{{script}}}#{{{ Linux, moria machines
-CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
+#CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
CPPFLAGS= -D$(DB)
LDFLAGS= -g
LIBS= -lcurses
@@ -32,11 +32,11 @@
#}}}
#{{{ FreeBSD, gcc, ncurses
#CC= gcc
-#CFLAGS= -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common $(CPPFLAGS)
-#CPPFLAGS= -I.curses.h -DNO_POSIX_SOURCE -D$(DB)
-#LIBS= -lncurses -lmytinfo
-#LDFLAGS=
-#MAKEDEPEND= gcc -MM
+CFLAGS+= -pedantic -fno-common $(CPPFLAGS)
+CPPFLAGS= -I.curses.h -DNO_POSIX_SOURCE -D$(DB)
+LIBS= -lncurses -lmytinfo
+LDFLAGS=
+MAKEDEPEND= ${CC} -MM
#}}}
#{{{ BSDI
#CC= gcc

View file

@ -1 +0,0 @@
Interactively examine C source code

View file

@ -1,21 +0,0 @@
A tool to find your way in C sources
cs offers the following functions:
* find C symbol
* find functions called from a certain function
* find functions calling a certain function
* find string literals
* find files #including a certain header file
* find file
* find POSIX naming violations
* execute shell command
The found lines will be displayed. Besides browsing through them, cs
allows to edit them using your favourite editor. If you frequently
grep for identifiers and edit the found files, then cs is for you. cs
should work on any system which supports the following:
* POSIX
* ANSI C
* SYSV curses library
WWW: http://www.moria.de/~michael/cs/

View file

@ -1,3 +0,0 @@
bin/cs
%%PORTDOCS%%share/doc/cs/ANNOUNCE
%%PORTDOCS%%@dirrm share/doc/cs