Madman is an advanced digital music organizer. It can catalogue huge amounts
of digital music in different formats, including MP3 and Ogg Vorbis. It has flexible querying, tagging, intelligent scoring, and more. Author: Andreas Kloeckner <inducer@users.sf.net> WWW: http://madman.sourceforge.net/ PR: ports/87301 Submitted by: Daniel Roethlisberger <daniel@roe.ch>
This commit is contained in:
parent
ce25467c03
commit
38e17d36fc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145287
10 changed files with 142 additions and 0 deletions
|
@ -272,6 +272,7 @@
|
|||
SUBDIR += lplayer
|
||||
SUBDIR += mac
|
||||
SUBDIR += mad
|
||||
SUBDIR += madman
|
||||
SUBDIR += madplay
|
||||
SUBDIR += malint
|
||||
SUBDIR += maplay
|
||||
|
|
53
audio/madman/Makefile
Normal file
53
audio/madman/Makefile
Normal file
|
@ -0,0 +1,53 @@
|
|||
# New ports collection makefile for: madman
|
||||
# Date created: 2005-10-12
|
||||
# Whom: Daniel Roethlisberger <daniel@roe.ch>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= madman
|
||||
PORTVERSION= 0.93
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= madman
|
||||
|
||||
MAINTAINER= daniel@roe.ch
|
||||
COMMENT= An advanced digital music manager
|
||||
|
||||
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
|
||||
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
|
||||
id3tag.2:${PORTSDIR}/audio/libid3tag \
|
||||
vorbis.3:${PORTSDIR}/audio/libvorbis
|
||||
RUN_DEPENDS= python:${PORTSDIR}/lang/python
|
||||
|
||||
USE_QT_VER= 3
|
||||
USE_GNOME= glib12
|
||||
|
||||
USE_REINPLACE= yes
|
||||
|
||||
PLIST_FILES= bin/madman \
|
||||
lib/madman/plugins/burn_to_audio_cd \
|
||||
lib/madman/plugins/burn_to_data_cd \
|
||||
lib/madman/plugins/export_m3u \
|
||||
lib/madman/plugins/move_to_trash
|
||||
PLIST_DIRS= lib/madman/plugins lib/madman
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/scons -C ${WRKSRC} prefix=${PREFIX} \
|
||||
qt_directory=${QT_PREFIX} add_c_include_dirs=${LOCALBASE}/include add_lib_dirs=${LOCALBASE}/lib
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/main/madman ${PREFIX}/bin
|
||||
${MKDIR} ${PREFIX}/lib/madman
|
||||
${MKDIR} ${PREFIX}/lib/madman/plugins
|
||||
for plugin in burn_to_audio_cd burn_to_data_cd export_m3u move_to_trash; do \
|
||||
${INSTALL_DATA} -m0755 ${WRKSRC}/plugins/$$plugin ${PREFIX}/lib/madman/plugins; \
|
||||
done
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= "Doesn't build on FreeBSD < 5.x"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
audio/madman/distinfo
Normal file
2
audio/madman/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (madman-0.93.tar.gz) = a9aeef95248ecd55e0479a6b8dec43f2
|
||||
SIZE (madman-0.93.tar.gz) = 548497
|
20
audio/madman/files/patch-SConstruct
Normal file
20
audio/madman/files/patch-SConstruct
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- SConstruct.orig Thu May 20 16:03:14 2004
|
||||
+++ SConstruct Wed Oct 12 01:01:10 2005
|
||||
@@ -1,6 +1,8 @@
|
||||
import os
|
||||
import glob
|
||||
|
||||
+SConsignFile()
|
||||
+
|
||||
opts = Options( "my_options.py")
|
||||
|
||||
opts.Add("qt_directory", "Path to Qt directory", "not specified")
|
||||
@@ -112,7 +114,7 @@
|
||||
def CheckForQtAt(context, qtdir):
|
||||
context.Message('Checking for Qt at %s... ' % qtdir)
|
||||
result = AttemptLinkWithVariables(context,
|
||||
- { "LIBS": "qt-mt", "LIBPATH": qtdir + '/lib', "CPPPATH": qtdir + '/include' },
|
||||
+ { "LINKFLAGS": "-pthread", "LIBS": "qt-mt", "LIBPATH": qtdir + '/lib', "CPPPATH": qtdir + '/include' },
|
||||
"""
|
||||
#include <qapplication.h>
|
||||
int main(int argc, char **argv) {
|
23
audio/madman/files/patch-expatconfig.h
Normal file
23
audio/madman/files/patch-expatconfig.h
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- expatconfig.h.org 2004-07-29 17:16:48.000000000 +0200
|
||||
+++ expatconfig.h 2004-07-29 17:17:36.000000000 +0200
|
||||
@@ -69,16 +69,16 @@
|
||||
#define HAVE_STRING_H 1
|
||||
|
||||
/* Define if you have strlcat */
|
||||
-/* #undef HAVE_STRLCAT */
|
||||
+#define HAVE_STRLCAT
|
||||
|
||||
/* Define if you have the strlcat prototype */
|
||||
-/* #undef HAVE_STRLCAT_PROTO */
|
||||
+#define HAVE_STRLCAT_PROTO
|
||||
|
||||
/* Define if you have strlcpy */
|
||||
-/* #undef HAVE_STRLCPY */
|
||||
+#define HAVE_STRLCPY
|
||||
|
||||
/* Define if you have the strlcpy prototype */
|
||||
-/* #undef HAVE_STRLCPY_PROTO */
|
||||
+#define HAVE_STRLCPY_PROTO
|
||||
|
||||
/* Define to 1 if you have the <sys/stat.h> header file. */
|
||||
#define HAVE_SYS_STAT_H 1
|
10
audio/madman/files/patch-main_SConscript
Normal file
10
audio/madman/files/patch-main_SConscript
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- main/SConscript.orig Thu May 20 16:03:14 2004
|
||||
+++ main/SConscript Wed Oct 12 01:30:29 2005
|
||||
@@ -18,6 +18,7 @@
|
||||
myenv.Append(LIBS = "madman" + component)
|
||||
|
||||
myenv.Replace(QT_LIB = "qt-mt")
|
||||
+myenv.Append(LINKFLAGS = "-pthread")
|
||||
|
||||
madman_prog = myenv.Program(target = "madman",
|
||||
source = [ "main.cpp" ])
|
8
audio/madman/files/patch-ui_auto_tag.cpp
Normal file
8
audio/madman/files/patch-ui_auto_tag.cpp
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- ui/auto_tag.cpp.orig 2004-11-08 19:22:02.000000000 +0100
|
||||
+++ ui/auto_tag.cpp 2004-11-08 19:22:23.000000000 +0100
|
||||
@@ -654,4 +654,4 @@
|
||||
|
||||
|
||||
|
||||
-#include "moc_auto_tag.cc"
|
||||
+#include "auto_tag.moc"
|
8
audio/madman/files/patch-ui_prefs_dialog.cpp
Normal file
8
audio/madman/files/patch-ui_prefs_dialog.cpp
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- ui/prefs_dialog.cpp.orig 2004-11-08 19:22:13.000000000 +0100
|
||||
+++ ui/prefs_dialog.cpp 2004-11-08 19:22:36.000000000 +0100
|
||||
@@ -498,4 +498,4 @@
|
||||
return make_pair(false, false);
|
||||
}
|
||||
|
||||
-#include "moc_prefs_dialog.cc"
|
||||
+#include "prefs_dialog.moc"
|
11
audio/madman/files/patch-utility_refcnt_ptr.h
Normal file
11
audio/madman/files/patch-utility_refcnt_ptr.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- utility/refcnt_ptr.h.orig Wed Oct 12 01:20:34 2005
|
||||
+++ utility/refcnt_ptr.h Wed Oct 12 01:20:40 2005
|
||||
@@ -109,7 +109,7 @@
|
||||
refcnt_ptr(const refcnt_ptr<T2>& rhs) throw()
|
||||
{
|
||||
object = rhs.object;
|
||||
- refcnt = rhs.refCnt;
|
||||
+ refCnt = rhs.refCnt;
|
||||
increaseCount();
|
||||
}
|
||||
|
6
audio/madman/pkg-descr
Normal file
6
audio/madman/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Madman is an advanced digital music organizer. It can catalogue huge amounts
|
||||
of digital music in different formats, including MP3 and Ogg Vorbis. It has
|
||||
flexible querying, tagging, intelligent scoring, and more.
|
||||
|
||||
Author: Andreas Kloeckner <inducer@users.sf.net>
|
||||
WWW: http://madman.sourceforge.net/
|
Loading…
Reference in a new issue