Add imapfilter 0.8, IMAP mail filtering utility.
PR: 41087 Submitted by: Lefteris Chatzibarbas <lefcha@hellug.gr>
This commit is contained in:
parent
28363b86c3
commit
38f5442f78
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63710
8 changed files with 113 additions and 0 deletions
|
@ -72,6 +72,7 @@
|
|||
SUBDIR += ifile
|
||||
SUBDIR += im
|
||||
SUBDIR += imap-uw
|
||||
SUBDIR += imapfilter
|
||||
SUBDIR += imp
|
||||
SUBDIR += imp3
|
||||
SUBDIR += isoqlog
|
||||
|
|
32
mail/imapfilter/Makefile
Normal file
32
mail/imapfilter/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: imapfilter
|
||||
# Date created: 28 July 2002
|
||||
# Whom: Lefteris Chatzibarbas <lefcha@hellug.gr>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= imapfilter
|
||||
PORTVERSION= 0.8
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://imapfilter.hellug.gr/source/
|
||||
|
||||
MAINTAINER= lefcha@hellug.gr
|
||||
|
||||
USE_OPENSSL= yes
|
||||
|
||||
MAN1= imapfilter.1
|
||||
MAN5= imapfilterrc.5
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} $(PREFIX)/bin/imapfilter
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/NEWS ${DOCSDIR}
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/sample.imapfilterrc ${EXAMPLESDIR}
|
||||
.endif
|
||||
@$(CAT) $(PKGMESSAGE)
|
||||
|
||||
.include <bsd.port.mk>
|
1
mail/imapfilter/distinfo
Normal file
1
mail/imapfilter/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (imapfilter-0.8.tar.gz) = 177838e56232fa8c19ad8789744a77f1
|
50
mail/imapfilter/files/patch-aa
Normal file
50
mail/imapfilter/files/patch-aa
Normal file
|
@ -0,0 +1,50 @@
|
|||
--- Makefile~ Sun Jul 28 18:09:32 2002
|
||||
+++ Makefile Sun Jul 28 18:09:24 2002
|
||||
@@ -1,14 +1,11 @@
|
||||
-CC = cc
|
||||
CFLAGS = -Wall -O2
|
||||
|
||||
-DESTDIR = /usr/local
|
||||
-BINDIR = /usr/local/bin
|
||||
-MANDIR = /usr/local/man
|
||||
-
|
||||
-INSTALL = install -c
|
||||
-INST_DIR = install -d
|
||||
-INST_BIN = $(INSTALL) -m 755
|
||||
-INST_DOC = $(INSTALL) -m 644
|
||||
+DESTDIR = $(PREFIX)
|
||||
+BINDIR = $(PREFIX)/bin
|
||||
+MANDIR = $(PREFIX)/man
|
||||
+
|
||||
+INST_BIN = $(BSD_INSTALL_PROGRAM)
|
||||
+INST_DOC = $(BSD_INSTALL_MAN)
|
||||
|
||||
MAN_BIN = imapfilter.1
|
||||
MAN_RC = imapfilterrc.5
|
||||
@@ -19,6 +16,8 @@
|
||||
|
||||
LIBS = -lssl -lcrypto
|
||||
|
||||
+all: imapfilter
|
||||
+
|
||||
imapfilter: $(OBJ)
|
||||
$(CC) $(LIBS) $(CFLAGS) -o $(BIN) $(OBJ)
|
||||
|
||||
@@ -27,11 +26,8 @@
|
||||
data.o imapfilter.o imap.o file.o passwd.o request.o socket.o: data.h
|
||||
|
||||
install: imapfilter
|
||||
- if test ! -d $(BINDIR); then $(INST_DIR) $(BINDIR); fi
|
||||
$(INST_BIN) $(BIN) $(BINDIR)
|
||||
- if test ! -d $(MANDIR)/man1; then $(INST_DIR) $(MANDIR)/man1; fi
|
||||
$(INST_DOC) $(MAN_BIN) $(MANDIR)/man1
|
||||
- if test ! -d $(MANDIR)/man5; then $(INST_DIR) $(MANDIR)/man5; fi
|
||||
$(INST_DOC) $(MAN_RC) $(MANDIR)/man5
|
||||
|
||||
uninstall:
|
||||
@@ -44,4 +40,4 @@
|
||||
@if test -f .Makefile; then mv .Makefile Makefile; fi
|
||||
@if test -f .config.h; then mv .config.h config.h; fi
|
||||
|
||||
-.PHONY : install uninstall clean distclean
|
||||
+.PHONY : all install uninstall clean distclean
|
1
mail/imapfilter/pkg-comment
Normal file
1
mail/imapfilter/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
IMAP mail filtering utility
|
18
mail/imapfilter/pkg-descr
Normal file
18
mail/imapfilter/pkg-descr
Normal file
|
@ -0,0 +1,18 @@
|
|||
IMAPFilter is an IMAP mail filtering utility, which based on user defined
|
||||
rules, processes mail residing in IMAP mailboxes without downloading them.
|
||||
Available searching criteria, which can be combined using logical operators
|
||||
(and/or/not), include the matching of a string in the headers or body of
|
||||
messages, the size, date or status of them. Different actions can be applied
|
||||
such as deletion, copying or moving of messages to mailboxes in the same
|
||||
or different mail server, and changing of their flags. Other features also
|
||||
include daemon mode and encryption and secure storing in the filesystem of the
|
||||
user's passwords, using the integrated interactive password editor.
|
||||
|
||||
IMAPfilter is purposed as a preconnect utility before a user fetches his/her
|
||||
mail, accesses his/her mailboxes with one of the available mail user agents or
|
||||
browses them via the Web.
|
||||
|
||||
WWW: http://imapfilter.hellug.gr
|
||||
|
||||
- Lefteris Chatzibarbas
|
||||
lefcha@hellug.gr
|
3
mail/imapfilter/pkg-message
Normal file
3
mail/imapfilter/pkg-message
Normal file
|
@ -0,0 +1,3 @@
|
|||
You can install imapfilter suid root, in order to lock memory pages and
|
||||
avoid swapping sensitive data. By default it is not installed suid root,
|
||||
so this must be done manually.
|
7
mail/imapfilter/pkg-plist
Normal file
7
mail/imapfilter/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
bin/imapfilter
|
||||
share/doc/imapfilter/README
|
||||
share/doc/imapfilter/LICENSE
|
||||
share/doc/imapfilter/NEWS
|
||||
share/examples/imapfilter/sample.imapfilterrc
|
||||
@dirrm share/doc/imapfilter
|
||||
@dirrm share/examples/imapfilter
|
Loading…
Reference in a new issue