Remove expired port:

2007-02-09 irc/sircd: No upgrade since 02-02-2002. Developer unavailable. Website gone.

Approved by:	erwin (mentor, implicit)
This commit is contained in:
Gabor Kovesdan 2007-02-18 18:22:53 +00:00
parent c323551e0e
commit 3904a5b66a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=185459
8 changed files with 1 additions and 94 deletions

1
MOVED
View file

@ -2831,3 +2831,4 @@ devel/Subversive|devel/subversive|2007-02-16|Normalize port name
www/ruby-mnogosearch||2007-02-17|Has expired: distfile and homepage disappeared
textproc/p5-Pod-LaTeX||2007-02-18|Has expired: Incorrect pkg-plist
editors/emacs20-mule-devel||2007-02-18|Has expired: homepage and patchfiles disappeared
irc/sircd||2007-02-18|Has expired: No upgrade since 02-02-2002. Developer unavailable. Website gone.

View file

@ -104,7 +104,6 @@
SUBDIR += scrollz
SUBDIR += sic
SUBDIR += sirc
SUBDIR += sircd
SUBDIR += slirc
SUBDIR += solid-ircd
SUBDIR += srvx

View file

@ -1,41 +0,0 @@
# ex:ts=8
# New ports collection makefile for: sircd
# Date created: Jun 15, 2001
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= sircd
PORTVERSION= 0.4.0
PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.sircd.org/files/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Smart IRC Daemon
FORBIDDEN= Multiple vulnerabilities.
DEPRECATED= No upgrade since 02-02-2002. Developer unavailable. Website gone.
EXPIRATION_DATE= 2007-02-09
USE_OPENSSL= yes
USE_GMAKE= yes
MAKE_ENV= LD="${CC}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
ALL_TARGET= release
USE_LDCONFIG= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sircd/sircd ${PREFIX}/sbin/sircd
${INSTALL_DATA} ${WRKSRC}/sircd/sircd.conf ${PREFIX}/etc/sircd.conf.sample
${INSTALL_DATA} ${WRKSRC}/syscore/libsyscore.so ${PREFIX}/lib/libsyscore.so
@${MKDIR} ${PREFIX}/lib/sircd
${INSTALL_DATA} ${WRKSRC}/sircd/motd.txt ${PREFIX}/lib/sircd/motd.txt
@${MKDIR} ${PREFIX}/lib/sircd/plugins
${INSTALL_DATA} ${WRKSRC}/plugins/*.so ${PREFIX}/lib/sircd/plugins
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (sircd-0.4.0.tar.gz) = cf5d230741e221bd48797eda373d0468
SHA256 (sircd-0.4.0.tar.gz) = c176cdb7f7f2dcc177ea80d98526af569457d0331b7c30d91376420ce16c1875
SIZE (sircd-0.4.0.tar.gz) = 192381

View file

@ -1,26 +0,0 @@
--- Makefile.orig Sun Feb 3 02:44:49 2002
+++ Makefile Thu Aug 8 02:50:28 2002
@@ -31,10 +31,10 @@
##
# Default (Linux / BSD)
-CC = gcc -pthread
-LD = gcc
-XLIBS = -lpthread
-RFLAGS = -march=i686
+#CC = gcc -pthread
+#LD = gcc
+XLIBS = ${PTHREAD_LIBS}
+RFLAGS = ${PTHREAD_CFLAGS}
SHFLAGS = -fPIC
# Solaris (SPARC)
@@ -56,7 +56,7 @@
# Release Flags
##
-RFLAGS += -O3 -fomit-frame-pointer
+RFLAGS += ${CFLAGS}
RFLAGS += -DNDEBUG -D_REENTRANT
##

View file

@ -1,11 +0,0 @@
--- syscore/Makefile.orig Sat Feb 2 18:44:49 2002
+++ syscore/Makefile Mon Mar 22 15:15:57 2004
@@ -69,7 +70,7 @@
#############################################################################
.c.o:
- $(CC) $(CFLAGS) $(INCLUDE) -o $*.o -c $*.c
+ $(CC) $(CFLAGS) $(SHFLAGS) $(INCLUDE) -o $*.o -c $*.c
clean:
@rm -f $(OBJ)

View file

@ -1,3 +0,0 @@
The Smart IRC Daemon
WWW: http://www.sircd.org/

View file

@ -1,9 +0,0 @@
sbin/sircd
etc/sircd.conf.sample
lib/libsyscore.so
lib/sircd/motd.txt
lib/sircd/plugins/cl_base.so
lib/sircd/plugins/cl_oper.so
lib/sircd/plugins/sv_base.so
@dirrm lib/sircd/plugins
@dirrm lib/sircd