- Enable staging
- Update USES - Rework doc installation - Strip installed binary
This commit is contained in:
parent
496131984d
commit
3969a63afa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333193
3 changed files with 10 additions and 13 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= notecase
|
||||
PORTVERSION= 1.9.8
|
||||
PORTREVISION= 9
|
||||
PORTREVISION= 10
|
||||
CATEGORIES= deskutils textproc
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
|
||||
|
@ -13,22 +13,16 @@ COMMENT= Hierarchical text notes manager
|
|||
|
||||
LICENSE= BSD
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gtk20 gtksourceview2 gnomevfs2
|
||||
USES= desktop-file-utils gettext pkgconfig shared-mime-info
|
||||
USES= gmake desktop-file-utils gettext pkgconfig shared-mime-info
|
||||
|
||||
USE_DOS2UNIX= yes
|
||||
DOS2UNIX_REGEX= .*\.(c|h|cpp)
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
PORTDOCS= help.ncd
|
||||
INSTALL_TARGET= install docinstall
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|^prefix=.*|prefix=${PREFIX}|' \
|
||||
|
@ -36,4 +30,7 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|^docsdir=.*|docsdir=${DOCSDIR}|' \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notecase
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- Makefile.orig 2008-12-09 11:07:06.000000000 +0100
|
||||
+++ Makefile 2011-06-23 19:11:55.067358819 +0200
|
||||
+++ Makefile 2013-11-05 17:07:34.000000000 +0100
|
||||
@@ -10,9 +10,10 @@
|
||||
VERSION=1.9.8
|
||||
|
||||
|
@ -27,8 +27,8 @@
|
|||
-
|
||||
+
|
||||
+docinstall:
|
||||
+ install -d -m 755 "$(docsdir)"
|
||||
+ $(INSTALL) -m 644 -c docs/help.ncd "$(docsdir)/help.ncd"
|
||||
+ install -d -m 755 "$(DESTDIR)$(docsdir)"
|
||||
+ $(INSTALL) -m 644 -c docs/help.ncd "$(DESTDIR)$(docsdir)/help.ncd"
|
||||
+
|
||||
#
|
||||
# install application
|
||||
|
|
|
@ -34,9 +34,9 @@ share/locale/ta/LC_MESSAGES/notecase.mo
|
|||
share/locale/tr/LC_MESSAGES/notecase.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/notecase.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/notecase.mo
|
||||
share/mime/application/notecase-enc.xml
|
||||
share/mime/application/notecase-plain.xml
|
||||
share/mime/packages/notecase.xml
|
||||
@dirrmtry share/mime/packages
|
||||
@dirrmtry share/mime
|
||||
share/pixmaps/notecase.xpm
|
||||
@dirrmtry share/locale/fr_CA/LC_MESSAGES
|
||||
@dirrmtry share/locale/fr_CA
|
||||
|
|
Loading…
Reference in a new issue