- Copy .conf.sample to .conf also in install target.
- Use correct order of @exec/@unexec directives for .conf files handling. - Add @dirrmtry for additional locale. - Remove BROKEN for dependent ports (tuxpaint-fonts and tuxpaint-stamps).
This commit is contained in:
parent
ef5936ff1d
commit
39aa7a65ff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=182804
4 changed files with 10 additions and 10 deletions
|
@ -18,8 +18,6 @@ COMMENT= TuxPaint Localized Fonts
|
|||
|
||||
RUN_DEPENDS= tuxpaint:${PORTSDIR}/games/tuxpaint
|
||||
|
||||
BROKEN= Incomplete pkg-plist
|
||||
|
||||
NO_BUILD= yes
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
|
|
|
@ -18,8 +18,6 @@ COMMENT= TuxPaint Stamps
|
|||
|
||||
RUN_DEPENDS= tuxpaint:${PORTSDIR}/games/tuxpaint
|
||||
|
||||
BROKEN= Incomplete pkg-plist
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
do-install:
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ./Makefile.orig Thu Oct 19 04:41:49 2006
|
||||
+++ ./Makefile Mon Nov 6 15:59:13 2006
|
||||
+++ ./Makefile Thu Jan 18 16:53:58 2007
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
# Where to install things:
|
||||
|
@ -36,7 +36,7 @@
|
|||
@echo
|
||||
@echo "--------------------------------------------------------------"
|
||||
@echo
|
||||
@@ -471,8 +469,8 @@
|
||||
@@ -471,8 +469,10 @@
|
||||
@echo
|
||||
@echo "...Installing default config file..."
|
||||
@install -d $(CONFDIR)
|
||||
|
@ -44,10 +44,12 @@
|
|||
- @chmod 644 $(CONFDIR)/tuxpaint.conf
|
||||
+ @cp src/tuxpaint.conf $(CONFDIR)/tuxpaint.conf.sample
|
||||
+ @chmod 644 $(CONFDIR)/tuxpaint.conf.sample
|
||||
+ @test -f $(CONFDIR)/tuxpaint.conf || \
|
||||
+ cp $(CONFDIR)/tuxpaint.conf.sample $(CONFDIR)/tuxpaint.conf
|
||||
|
||||
|
||||
# Install example stamps
|
||||
@@ -590,9 +588,6 @@
|
||||
@@ -590,9 +590,6 @@
|
||||
@install -d $(ICON_PREFIX)
|
||||
@cp data/images/icon.png $(ICON_PREFIX)/tuxpaint.png
|
||||
@chmod 644 $(ICON_PREFIX)/tuxpaint.png
|
||||
|
@ -57,7 +59,7 @@
|
|||
|
||||
|
||||
# Install the program:
|
||||
@@ -1008,12 +1003,6 @@
|
||||
@@ -1008,12 +1005,6 @@
|
||||
@cp src/manpage/tuxpaint.1 $(MAN_PREFIX)/man1
|
||||
@gzip -f $(MAN_PREFIX)/man1/tuxpaint.1
|
||||
@chmod a+rx,g-w,o-w $(MAN_PREFIX)/man1/tuxpaint.1.gz
|
||||
|
@ -70,7 +72,7 @@
|
|||
@# tuxpaint-import.1
|
||||
@cp src/manpage/tuxpaint-import.1 $(MAN_PREFIX)/man1/
|
||||
@gzip -f $(MAN_PREFIX)/man1/tuxpaint-import.1
|
||||
@@ -1034,7 +1023,7 @@
|
||||
@@ -1034,7 +1025,7 @@
|
||||
$^ \
|
||||
$(HQXX_O) \
|
||||
$(SDL_LIBS) \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
bin/tuxpaint
|
||||
bin/tuxpaint-import
|
||||
@exec [ -f %D/etc/tuxpaint/tuxpaint.conf ] || cp %D/etc/tuxpaint/tuxpaint.conf.sample %D/etc/tuxpaint/tuxpaint.conf
|
||||
@unexec if cmp -s %D/etc/tuxpaint/tuxpaint.conf %D/etc/tuxpaint/tuxpaint.conf.sample; then rm -f %D/etc/tuxpaint/tuxpaint.conf; fi
|
||||
etc/tuxpaint/tuxpaint.conf.sample
|
||||
@exec [ -f %D/etc/tuxpaint/tuxpaint.conf ] || cp %D/etc/tuxpaint/tuxpaint.conf.sample %D/etc/tuxpaint/tuxpaint.conf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ADVANCED-STAMPS-HOWTO.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
|
||||
|
@ -808,6 +808,8 @@ share/pixmaps/tuxpaint.png
|
|||
@dirrmtry share/locale/ve
|
||||
@dirrmtry share/locale/tl/LC_MESSAGES
|
||||
@dirrmtry share/locale/tl
|
||||
@dirrmtry share/locale/rw/LC_MESSAGES
|
||||
@dirrmtry share/locale/rw
|
||||
@dirrmtry share/locale/nr/LC_MESSAGES
|
||||
@dirrmtry share/locale/nr
|
||||
@dirrmtry share/locale/ku/LC_MESSAGES
|
||||
|
|
Loading…
Reference in a new issue