Due to a flaw in binutils 2.15, function names can conflict with
ELF assembler directives on PPC64 systems. As a result, it is not possible to have functions named things like 'text' and 'data'. In glib-compile-schemas.c we have such a name. PR: ports/152555 Submitted by: andreast@
This commit is contained in:
parent
549dc0e19b
commit
39b51edef8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=265109
2 changed files with 27 additions and 0 deletions
|
@ -56,6 +56,10 @@ OPTIONS= COLLATION_FIX "fix string collation" off
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == powerpc64
|
||||
EXTRA_PATCHES= ${.CURDIR}/files/extra-arch-powerpc64
|
||||
.endif
|
||||
|
||||
# Let glib use asm code for implementing atomic ops on i386 and amd64.
|
||||
.if ${ARCH} == "i386"
|
||||
GLIB_ARCH= i486
|
||||
|
|
23
devel/glib20/files/extra-arch-powerpc64
Normal file
23
devel/glib20/files/extra-arch-powerpc64
Normal file
|
@ -0,0 +1,23 @@
|
|||
|
||||
--- gio/glib-compile-schemas.c.orig 2010-11-24 21:32:15.000000000 +0100
|
||||
+++ gio/glib-compile-schemas.c 2010-11-24 21:33:42.000000000 +0100
|
||||
@@ -1458,7 +1458,7 @@
|
||||
}
|
||||
/* Text {{{2 */
|
||||
static void
|
||||
-text (GMarkupParseContext *context,
|
||||
+XXXtext (GMarkupParseContext *context,
|
||||
const gchar *text,
|
||||
gsize text_len,
|
||||
gpointer user_data,
|
||||
@@ -1590,7 +1590,7 @@
|
||||
parse_gschema_files (gchar **files,
|
||||
gboolean strict)
|
||||
{
|
||||
- GMarkupParser parser = { start_element, end_element, text };
|
||||
+ GMarkupParser parser = { start_element, end_element, XXXtext };
|
||||
ParseState state = { 0, };
|
||||
const gchar *filename;
|
||||
GError *error = NULL;
|
||||
|
||||
|
Loading…
Reference in a new issue