- Update to version 1.4.6, which fixed a parallel build race condition
resulting from integration of upstream ocaml-curses - Get rid of indefinite article in COMMENT, convert USE_GMAKE - Convert pkg-plist into PLIST_FILES and PORTDOCS - Add missing DOCS to OPTIONS_DEFINE, utilize new options helper - Fix minor formatting glitch and adjust WWW line in port description Reported by: marino Approved by: miwi, bapt (portmgr, implicit) PR: ports/179485 Submitted by: cs Approved by: maintainer (version update)
This commit is contained in:
parent
924ba32a5b
commit
39c7163be5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325085
5 changed files with 18 additions and 44 deletions
|
@ -2,45 +2,39 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= wyrd
|
||||
PORTVERSION= 1.4.5
|
||||
PORTVERSION= 1.4.6
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= http://pessimization.com/software/wyrd/
|
||||
|
||||
MAINTAINER= h.skuhra@gmail.com
|
||||
COMMENT= A curses front end to remind
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/ocamlc:${PORTSDIR}/lang/ocaml
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/remind:${PORTSDIR}/deskutils/remind
|
||||
COMMENT= Text-based front-end to Remind
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
OPTIONS_DEFINE= UTF8
|
||||
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
|
||||
RUN_DEPENDS= remind:${PORTSDIR}/deskutils/remind
|
||||
|
||||
USES= gmake ncurses
|
||||
GNU_CONFIGURE= yes
|
||||
USES= ncurses
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= wyrd.1
|
||||
MAN5= wyrdrc.5
|
||||
MAN1= wyrd.1
|
||||
MAN5= wyrdrc.5
|
||||
PLIST_FILES= bin/wyrd etc/wyrdrc
|
||||
PORTDOCS= manual.html manual.pdf
|
||||
|
||||
OPTIONS_DEFINE= UTF8 DOCS
|
||||
UTF8_CONFIGURE_ENABLE= utf8
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MUTF8}
|
||||
CONFIGURE_ARGS+=--enable-utf8
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-utf8
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wyrd.opt ${PREFIX}/bin/wyrd
|
||||
${INSTALL_DATA} ${WRKSRC}/wyrdrc ${PREFIX}/etc/wyrdrc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/wyrd.1 ${MAN1PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/wyrdrc.5 ${MAN5PREFIX}/man/man5
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${DOCSDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/manual.pdf ${DOCSDIR}/
|
||||
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (wyrd-1.4.5.tar.gz) = c8844d85767b3b9cc9ce4f430e0ef83ba29d96c630f03c508eab5ab86204137b
|
||||
SIZE (wyrd-1.4.5.tar.gz) = 398294
|
||||
SHA256 (wyrd-1.4.6.tar.gz) = b2b51d6fb38f8b8b3ec30ee72093f791ba9b6fe35418191bc2011d2c8079997e
|
||||
SIZE (wyrd-1.4.6.tar.gz) = 425829
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- Makefile.in.bak 2010-12-04 11:30:55.000000000 +0100
|
||||
+++ Makefile.in 2010-12-04 11:31:19.000000000 +0100
|
||||
@@ -91,10 +91,10 @@
|
||||
|
||||
|
||||
$(CURSES_CMA):
|
||||
- make -C curses byte
|
||||
+ $(MAKE) -C curses byte
|
||||
|
||||
$(CURSES_CMXA):
|
||||
- make -C curses opt
|
||||
+ $(MAKE) -C curses opt
|
||||
|
||||
|
||||
# installation
|
|
@ -1,7 +1,7 @@
|
|||
Wyrd is a text-based front-end to Remind, a sophisticated calendar and alarm
|
||||
program. Remind's power lies in its programmability, and Wyrd does not hide
|
||||
this capability behind flashy GUI dialogs. Rather, Wyrd is designed to make you
|
||||
more efficient at editing your reminder files directly. It also offers a
|
||||
this capability behind flashy GUI dialogs. Rather, Wyrd is designed to make
|
||||
you more efficient at editing your reminder files directly. It also offers a
|
||||
scrollable timetable suitable for visualizing your schedule at a glance.
|
||||
|
||||
Unlike most of the calendar applications available today, Wyrd is designed to
|
||||
|
@ -9,4 +9,4 @@ be both lightweight and fast. Startup time is negligible, UI navigation is
|
|||
instantaneous, and the wyrd process typically consumes less than 2MB of
|
||||
resident memory.
|
||||
|
||||
WWW: http://pessimization.com/software/wyrd/
|
||||
WWW: http://pessimization.com/software/wyrd/
|
||||
|
|
|
@ -1,5 +0,0 @@
|
|||
bin/wyrd
|
||||
etc/wyrdrc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/manual.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue