www/py-nevow: 0.10.0 -> 0.14.0
PR: 210511 Changes: https://github.com/twisted/nevow/blob/master/NEWS.txt Submitted by: Yuri Victorovich <yuri@rawbw.com> Approved by: nivit (maintainer timeout)
This commit is contained in:
parent
263d0845ef
commit
39ff10364f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=419494
5 changed files with 46 additions and 27 deletions
|
@ -2,19 +2,19 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nevow
|
||||
PORTVERSION= 0.10.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.14.0
|
||||
CATEGORIES= www python devel
|
||||
MASTER_SITES= http://divmod.org/trac/attachment/wiki/SoftwareReleases/ \
|
||||
https://pypi.python.org/packages/source/N/Nevow/
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= Nevow-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tar.gz?format=raw
|
||||
|
||||
MAINTAINER= nivit@FreeBSD.org
|
||||
COMMENT= Web application templating system, based on the Twisted Woven
|
||||
|
||||
USE_PYTHON= distutils autoplist
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USE_PYTHON= autoplist distutils
|
||||
USES= gettext python twisted:web
|
||||
NO_ARCH= yes
|
||||
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (Nevow-0.10.0.tar.gz?format=raw) = 90631f68f626c8934984908d3df15e7c198939d36be7ead1305479dfc67ff6d0
|
||||
SIZE (Nevow-0.10.0.tar.gz?format=raw) = 518696
|
||||
TIMESTAMP = 1466754265
|
||||
SHA256 (Nevow-0.14.0.tar.gz) = c3c1fa1e978d2a55f9ad7bbe6a052759886e713a93d7baf8280d2837dfef2672
|
||||
SIZE (Nevow-0.14.0.tar.gz) = 528137
|
||||
|
|
16
www/py-nevow/files/patch-examples_examples.tac
Normal file
16
www/py-nevow/files/patch-examples_examples.tac
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- examples/examples.tac.orig 2015-08-11 22:04:11 UTC
|
||||
+++ examples/examples.tac
|
||||
@@ -7,13 +7,6 @@ to run Nevow """
|
||||
import sys
|
||||
sys.exit(1)
|
||||
|
||||
-
|
||||
-from twisted.python import components
|
||||
-import warnings
|
||||
-warnings.filterwarnings(
|
||||
- 'ignore',
|
||||
- category=components.ComponentsDeprecationWarning)
|
||||
-
|
||||
from twisted.application import service, strports
|
||||
from twisted.python import util
|
||||
|
|
@ -11,4 +11,5 @@ automatically, and form posts will be validated and input coerced, rendering
|
|||
error pages if appropriate. Once a form post has validated successfully, the
|
||||
method will be called with the coerced values.
|
||||
|
||||
WWW: http://divmod.org/trac/wiki/DivmodNevow
|
||||
WWW: https://github.com/twisted/nevow
|
||||
WWW: https://pypi.python.org/pypi/Nevow
|
||||
|
|
|
@ -1,18 +1,33 @@
|
|||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/.hidden
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_templates/.hidden
|
||||
%%PORTDOCS%%%%DOCSDIR%%/conf.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/concepts.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/env.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/index.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/intro.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part00/index.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part00/listings/echothing/__init__.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part00/listings/echothing/echobox.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part00/listings/echothing/js/EchoThing.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part00/listings/echothing/template.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part00/listings/nevow/plugins/echothing_package.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part01/index.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part01/listings/chatthing/__init__.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part01/listings/chatthing/chatterbox.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part01/listings/chatthing/js/ChatThing.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part01/listings/chatthing/template.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/chattutorial/part01/listings/nevow/plugins/chatthing_package.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/deployment.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/gettingstarted.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/glossary.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/intro.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/listings/gettingstarted/helloworld.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/listings/gettingstarted/helloworld.tac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/stylesheet.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/default.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/publishing.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/traversal.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howto/xmltemplates.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/man/nevow-xmlgettext.1
|
||||
%%PORTDOCS%%%%DOCSDIR%%/old/nevow.doc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/old/toc.html
|
||||
|
@ -64,6 +79,7 @@
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/disktemplates/disktemplates.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/disktemplates/disktemplates_stan.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.tac
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.tac.orig
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/files/words
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/formbuilder/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/formbuilder/formbuilder.py
|
||||
|
@ -108,11 +124,6 @@
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irenderer/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irenderer/irenderer.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irenderer/simple_irenderer.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liveanimal/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liveanimal/liveanimal.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liveanimal/liveanimal.tac
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/livepage/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/livepage/livepage.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logout_guard/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logout_guard/logout_guard.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logout_guard/logout_guard2.py
|
||||
|
@ -161,8 +172,6 @@
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postit/store.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postit/styles/postit.css
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postit/styles/typo.css
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/progress/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/progress/progress.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple/simple.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple/simplehtml.html
|
||||
|
@ -173,8 +182,6 @@
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/table/tablehtml.html
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/table/tablehtml.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/testexamples.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/testformless.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/todo/controller.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/todo/database.sql
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/todo/dispatcher.py
|
||||
|
@ -187,9 +194,3 @@
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/userdb/userdb.tac
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/with_axiom/main.tac
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/with_axiom/powerups.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wsgi/README
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wsgi/test-cgi.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wsgi/test-modpy.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xul/__init__.py
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xul/xul_example.xul
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xul/xul_nevow.py
|
||||
|
|
Loading…
Reference in a new issue