CDO is a collection of command line Operators to manipulate and analyse Climate
model Data. Supported file formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 250 operators available. The following table gives a short overview about the main categories. * File information (info, sinfo, diff, ...) * File operations (copy, cat, merge, split*, ...) * Selection (selcode, selvar, sellevel, seltimestep, ...) * Missing values (setctomiss, setmisstoc, setrtomiss) * Arithmetic (add, sub, mul, div, ...) * Mathematical functions (sqrt, exp, log, sin, cos, ...) * Comparision (eq, ne, le, lt, ge, gt, ...) * Conditions (ifthen, ifnotthen, ifthenc, ifnotthenc) * Field statistic (fldsum, fldavg, fldstd, fldmin, fldmax, ...) * Vertical statistic (vertsum, vertavg, vertstd, vertmin, ...) * Time range statistic (timavg, yearavg, monavg, dayavg, ...) * Ensemble statistic (enssum, ensavg, ensstd, ensmin, ...) * Regression (detrend) * Field interpolation (remapbil, remapcon, remapdis, ...) * Vertical interpolation (ml2pl, ml2hl) * Time interpolation (inttime, intyear) WWW: http://www.mpimet.mpg.de/fileadmin/software/cdo/ PR: ports/98099 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
This commit is contained in:
parent
2e0ba384eb
commit
3a2793f906
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=165075
5 changed files with 77 additions and 0 deletions
|
@ -11,6 +11,7 @@
|
|||
SUBDIR += buddy
|
||||
SUBDIR += cdcl
|
||||
SUBDIR += cdf
|
||||
SUBDIR += cdo
|
||||
SUBDIR += chemtool
|
||||
SUBDIR += chemtool-devel
|
||||
SUBDIR += clhep
|
||||
|
|
40
science/cdo/Makefile
Normal file
40
science/cdo/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: CDO
|
||||
# Date created: 29 May 2006
|
||||
# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cdo
|
||||
PORTVERSION= 0.9.13
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
|
||||
http://sunpoet.net/distfiles/
|
||||
|
||||
MAINTAINER= sunpoet@sunpoet.net
|
||||
COMMENT= Climate Data Operators
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS= --program-transform-name=""
|
||||
CONFIGURE_ENV= CC="${CC}" \
|
||||
CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
|
||||
PLIST_FILES= bin/cdo
|
||||
|
||||
OPTIONS= HDF5 "HDF5 support" off \
|
||||
NETCDF "NETCDF support" off
|
||||
|
||||
.if defined(WITH_HDF5)
|
||||
CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}/include
|
||||
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF)
|
||||
CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}/include
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
science/cdo/distinfo
Normal file
3
science/cdo/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (cdo-0.9.13.tar.gz) = dc93ea5130c02fa6c1d56c0296df623b
|
||||
SHA256 (cdo-0.9.13.tar.gz) = d78d24761c451f6aaae0e631b4dec8c341acb593806a0f95d0dd4ac634ece87a
|
||||
SIZE (cdo-0.9.13.tar.gz) = 594776
|
10
science/cdo/files/patch-src__cdilib.c
Normal file
10
science/cdo/files/patch-src__cdilib.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/cdilib.c.orig Mon Mar 6 17:08:36 2006
|
||||
+++ src/cdilib.c Mon May 29 22:28:01 2006
|
||||
@@ -3948,7 +3948,6 @@
|
||||
|
||||
#if ! defined (HAVE_MALLOC_H)
|
||||
# if defined (__sun) || defined (__i386) || defined (__ia64) || defined (SX)
|
||||
-# define HAVE_MALLOC_H
|
||||
# endif
|
||||
#endif
|
||||
|
23
science/cdo/pkg-descr
Normal file
23
science/cdo/pkg-descr
Normal file
|
@ -0,0 +1,23 @@
|
|||
CDO is a collection of command line Operators to manipulate and analyse Climate
|
||||
model Data. Supported file formats are GRIB, netCDF, SERVICE, EXTRA and IEG.
|
||||
There are more than 250 operators available. The following table gives a short
|
||||
overview about the main categories.
|
||||
|
||||
* File information (info, sinfo, diff, ...)
|
||||
* File operations (copy, cat, merge, split*, ...)
|
||||
* Selection (selcode, selvar, sellevel, seltimestep, ...)
|
||||
* Missing values (setctomiss, setmisstoc, setrtomiss)
|
||||
* Arithmetic (add, sub, mul, div, ...)
|
||||
* Mathematical functions (sqrt, exp, log, sin, cos, ...)
|
||||
* Comparision (eq, ne, le, lt, ge, gt, ...)
|
||||
* Conditions (ifthen, ifnotthen, ifthenc, ifnotthenc)
|
||||
* Field statistic (fldsum, fldavg, fldstd, fldmin, fldmax, ...)
|
||||
* Vertical statistic (vertsum, vertavg, vertstd, vertmin, ...)
|
||||
* Time range statistic (timavg, yearavg, monavg, dayavg, ...)
|
||||
* Ensemble statistic (enssum, ensavg, ensstd, ensmin, ...)
|
||||
* Regression (detrend)
|
||||
* Field interpolation (remapbil, remapcon, remapdis, ...)
|
||||
* Vertical interpolation (ml2pl, ml2hl)
|
||||
* Time interpolation (inttime, intyear)
|
||||
|
||||
WWW: http://www.mpimet.mpg.de/fileadmin/software/cdo/
|
Loading…
Reference in a new issue