- now only provides the hungarian dictionnaries
- install them in the share/hunspell directory - gives maintainership back to the previous maintainer - reconnect
This commit is contained in:
parent
6fe57c63c5
commit
3a44de2e0d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=277986
6 changed files with 17 additions and 148 deletions
|
@ -6,6 +6,7 @@
|
|||
SUBDIR += aspell
|
||||
SUBDIR += hu-phone
|
||||
SUBDIR += hu-zipcodes
|
||||
SUBDIR += hunspell
|
||||
SUBDIR += ispell
|
||||
SUBDIR += jdictionary-eng-hun
|
||||
SUBDIR += jdictionary-eng-hun-expr
|
||||
|
|
|
@ -6,71 +6,26 @@
|
|||
#
|
||||
|
||||
PORTNAME= hunspell
|
||||
PORTVERSION= 1.2.11
|
||||
PORTVERSION= 1.6.1
|
||||
CATEGORIES= hungarian textproc
|
||||
MASTER_SITES= SF/${PORTNAME}/Hunspell/${PORTVERSION}:code \
|
||||
SF/magyarispell/Magyar%20Ispell/${DICTVERSION}:data
|
||||
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code \
|
||||
hu_HU-${DICTVERSION}${EXTRACT_SUFX}:data
|
||||
MASTER_SITES= SF/magyarispell/Magyar%20Ispell/${DICTVERSION}
|
||||
DISTNAME= hu_HU-${PORTVERSION}
|
||||
|
||||
MAINTAINER= bapt@FreeBSD.org
|
||||
COMMENT= Improved spell-checker for Hungarian and other languages
|
||||
MAINTAINER= janos.mohacsi@bsd.hu
|
||||
COMMENT= Hunspell hungarian dictionnary
|
||||
|
||||
#EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
|
||||
NO_BUILD= yes
|
||||
WRKSRC= ${WRKDIR}/hu_HU-${PORTVERSION}
|
||||
|
||||
#USE_GETTEXT= yes
|
||||
#USE_ICONV= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ui --with-readline --disable-nls
|
||||
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib
|
||||
EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude intl
|
||||
ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
|
||||
PLIST_FILES= share/hunspell/hu_HU.dic \
|
||||
share/hunspell/hu_HU.aff
|
||||
|
||||
MAN1= hunspell.1
|
||||
MAN4= hunspell.4
|
||||
|
||||
DICTVERSION= 1.6.1
|
||||
PORTDOCS= README README.myspell
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
|
||||
${WRKSRC}/src/tools/hunspell.cxx
|
||||
PLIST_DIRS= share/hunspell
|
||||
|
||||
do-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/man/hunspell.1 ${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/hunspell.4 ${PREFIX}/man/man4
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/tools/.libs/hunspell ${PREFIX}/bin
|
||||
${MKDIR} ${PREFIX}/include/hunspell
|
||||
${INSTALL_DATA} ${WRKSRC}/src/hunspell/*.h* ${PREFIX}/include/hunspell/
|
||||
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.a ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.lai ${PREFIX}/lib/libhunspell-1.1.la
|
||||
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.so.0 ${PREFIX}/lib
|
||||
${LN} -s ${LOCALBASE}/lib/libhunspell-1.2.so.0 ${PREFIX}/lib/libhunspell-1.2.so
|
||||
${MKDIR} ${PREFIX}/share/myspell/
|
||||
${INSTALL_DATA} ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.dic \
|
||||
${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.aff \
|
||||
${PREFIX}/share/myspell/
|
||||
${INSTALL_DATA} ${WRKSRC}/hunspell.pc ${PREFIX}/libdata/pkgconfig/
|
||||
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/magyar.dic
|
||||
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/hungarian.dic
|
||||
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/default.dic
|
||||
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/magyar.aff
|
||||
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/hungarian.aff
|
||||
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/default.aff
|
||||
#${LOCALBASE}/bin/msgfmt -o ${WRKSRC}/hunspell.mo ${WRKSRC}/hunspell.po
|
||||
#${MKDIR} ${PREFIX}/share/locale/hu/LC_MESSAGES/ && \
|
||||
#${INSTALL_DATA} ${WRKSRC}/hunspell.mo ${PREFIX}/share/locale/hu/LC_MESSAGES/
|
||||
${MKDIR} ${PREFIX}/share/hunspell/
|
||||
${INSTALL_DATA} ${WRKSRC}/hu_HU.dic \
|
||||
${WRKSRC}/hu_HU.aff \
|
||||
${PREFIX}/share/hunspell/
|
||||
|
||||
.ifndef(NOPORTDOCS)
|
||||
post-install:
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for doc in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in.orig
|
||||
+++ Makefile.in
|
||||
@@ -320,7 +320,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
-SUBDIRS = intl po src man m4 tests
|
||||
+SUBDIRS = po src man m4 tests
|
||||
pkgconfdir = $(libdir)/pkgconfig
|
||||
pkgconf_DATA = hunspell.pc
|
||||
EXTRA_DIST = BUGS README.myspell AUTHORS.myspell license.myspell license.hunspell \
|
|
@ -1,43 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/tools/hunspell.cxx.orig
|
||||
+++ src/tools/hunspell.cxx
|
||||
@@ -61,26 +61,22 @@
|
||||
#include "firstparser.hxx"
|
||||
|
||||
#define LIBDIR \
|
||||
- "/usr/share/hunspell:" \
|
||||
- "/usr/share/myspell:" \
|
||||
- "/usr/share/myspell/dicts"
|
||||
+ "%%PREFIX%%/share/hunspell:" \
|
||||
+ "%%PREFIX%%/share/myspell:" \
|
||||
+ "%%PREFIX%%/share/myspell/dicts"
|
||||
#define USEROOODIR \
|
||||
".openoffice.org/3/user/wordbook:" \
|
||||
".openoffice.org2/user/wordbook:" \
|
||||
".openoffice.org2.0/user/wordbook"
|
||||
#define OOODIR \
|
||||
- "/opt/openoffice.org/basis3.0/share/dict/ooo:" \
|
||||
- "/usr/lib/openoffice.org/basis3.0/share/dict/ooo:" \
|
||||
- "/opt/openoffice.org2.4/share/dict/ooo:" \
|
||||
- "/usr/lib/openoffice.org2.4/share/dict/ooo:" \
|
||||
- "/opt/openoffice.org2.3/share/dict/ooo:" \
|
||||
- "/usr/lib/openoffice.org2.3/share/dict/ooo:" \
|
||||
- "/opt/openoffice.org2.2/share/dict/ooo:" \
|
||||
- "/usr/lib/openoffice.org2.2/share/dict/ooo:" \
|
||||
- "/opt/openoffice.org2.1/share/dict/ooo:" \
|
||||
- "/usr/lib/openoffice.org2.1/share/dict/ooo:" \
|
||||
- "/opt/openoffice.org2.0/share/dict/ooo:" \
|
||||
- "/usr/lib/openoffice.org2.0/share/dict/ooo"
|
||||
+ "%%PREFIX%%/openoffice.org3/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org-3.0.0/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org-2.4.2/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org-2.4.1/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org-2.4/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org-2.2/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org-2.1/share/dict/ooo:" \
|
||||
+ "%%PREFIX%%/openoffice.org2.0/share/dict/ooo:"
|
||||
#define HOME getenv("HOME")
|
||||
#define DICBASENAME ".hunspell_"
|
||||
#define LOGFILE "/tmp/hunspell.log"
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -20562,7 +20562,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile intl/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/hunspell/hunvisapi.h src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
|
||||
+ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/hunspell/hunvisapi.h src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
|
||||
|
||||
cat >confcache <<\_ACEOF
|
||||
# This file is a shell script that caches the results of configure
|
|
@ -1,19 +1,3 @@
|
|||
Hungarian Spell Checher utility with Hungarian dictionary
|
||||
and affix files. It has several advantages over ispell.
|
||||
It has better affix rules than hu-ispell.
|
||||
|
||||
It is installing hungarian dictionary by default, but other dictionaries can
|
||||
be found at: http://wiki.services.openoffice.org/wiki/Dictionaries
|
||||
|
||||
Magyar helyes.r.s ellen.rz. hunspell. El.ny.k az ispell-hez k.pest:
|
||||
- T.bb karakter v.ltoz.ssal j.r. tipikus hib.kra jav.t.si javaslat.
|
||||
- Helyes .sszetett sz.nak l.tsz. szavak tilt.sa.
|
||||
- 6-3-as szab.ly
|
||||
- mozg.szab.ly
|
||||
- .sszet.teli szab.lyok
|
||||
- t.bbsz.r.s k.pz.k helyes haszn.lata
|
||||
- .kezetes.t.si javaslatok
|
||||
Alepesetben csak a magyar sz.t.rat install.lja, de tov.bbi sz.t.rak
|
||||
el.rhet.ek: http://wiki.services.openoffice.org/wiki/Dictionaries
|
||||
Hunspell hungarian dictionnary
|
||||
|
||||
WWW: http://magyarispell.sourceforge.net/
|
||||
|
|
Loading…
Reference in a new issue