net-p2p/monero-cli: Upgrade from 0.17.2.3 to 0.17.3.0

This commit is contained in:
Vasil Dimov 2021-12-09 17:05:28 +01:00
parent 73557d30d1
commit 3a598d5420
3 changed files with 14 additions and 10 deletions

View file

@ -2,7 +2,7 @@
PORTNAME= monero-cli
# To build from an arbitrary git commit comment PORTVERSION and PORTREVISION (if present)
PORTVERSION= 0.17.2.3
PORTVERSION= 0.17.3.0
DISTVERSIONPREFIX= v
# and uncomment the following two lines (use for example -git-HEAD or -git-b6420e1)
#PORTVERSION= 0
@ -43,7 +43,7 @@ GIT_COMMIT= ${DISTVERSIONPREFIX}${PORTVERSION}
.endif
GH_TUPLE= monero-project:monero:${GIT_COMMIT} \
monero-project:supercop:633500ad8c875999:ext1/external/supercop \
tevador:RandomX:fe4324e8c0c035fec3affd6e:ext2/external/randomx \
tevador:RandomX:9efc398c196ef1c50d8e6f5e:ext2/external/randomx \
trezor:trezor-common:bff7fdfe436c727982c:ext3/external/trezor-common
CFLAGS+= -D_WANT_SEMUN

View file

@ -1,9 +1,9 @@
TIMESTAMP = 1630575700
SHA256 (monero-project-monero-v0.17.2.3_GH0.tar.gz) = e4462f8909bdc5e66d76f4023374ff759159c15fe7d407f0c21619769e87c35d
SIZE (monero-project-monero-v0.17.2.3_GH0.tar.gz) = 10640501
TIMESTAMP = 1639063756
SHA256 (monero-project-monero-v0.17.3.0_GH0.tar.gz) = 23d56d0c366576ff49bd785290a3e6377d4e51156e70ce4bb774b3d70f8cada4
SIZE (monero-project-monero-v0.17.3.0_GH0.tar.gz) = 10659302
SHA256 (monero-project-supercop-633500ad8c875999_GH0.tar.gz) = 19861f74bfc2cc0b61a49bf0ff2da5c793432d31e8677b23455a4229dcb6435b
SIZE (monero-project-supercop-633500ad8c875999_GH0.tar.gz) = 346190
SHA256 (tevador-RandomX-fe4324e8c0c035fec3affd6e_GH0.tar.gz) = e62470bae4ac94f180b423a039fd091c2a8f2b9c9b31afc5456841e36dd86d57
SIZE (tevador-RandomX-fe4324e8c0c035fec3affd6e_GH0.tar.gz) = 163749
SHA256 (tevador-RandomX-9efc398c196ef1c50d8e6f5e_GH0.tar.gz) = 21cb41e2e52ea76385746a52c0d3ce39ca15678243148aefabd9fbc0805600e4
SIZE (tevador-RandomX-9efc398c196ef1c50d8e6f5e_GH0.tar.gz) = 163979
SHA256 (trezor-trezor-common-bff7fdfe436c727982c_GH0.tar.gz) = 298338e9924437677be76546929c64cda2bd8b04dbd2c3b533cdcf1291f903a0
SIZE (trezor-trezor-common-bff7fdfe436c727982c_GH0.tar.gz) = 1327776

View file

@ -1,6 +1,6 @@
--- external/CMakeLists.txt.orig 2018-10-12 11:58:33.398503000 +0200
+++ external/CMakeLists.txt 2018-10-12 12:01:52.063061000 +0200
@@ -31,25 +31,28 @@
--- external/CMakeLists.txt.orig 2021-12-09 16:37:10.161405000 +0100
+++ external/CMakeLists.txt 2021-12-09 16:36:54.211336000 +0100
@@ -31,27 +31,30 @@
# This is broken up into two parts: first we check for miniupnp, compile it if we can't
# find it, and thereafter we check for libunbound, and compile it if we can't find it.
@ -11,8 +11,10 @@
find_package(Miniupnpc REQUIRED)
-message(STATUS "Using in-tree miniupnpc")
-set(UPNPC_NO_INSTALL TRUE CACHE BOOL "Disable miniupnp installation" FORCE)
-add_subdirectory(miniupnp/miniupnpc)
-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
-set_property(TARGET libminiupnpc-static PROPERTY POSITION_INDEPENDENT_CODE ON)
-if(MSVC)
- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
-elseif(NOT MSVC)
@ -23,8 +25,10 @@
-endif()
+if(NOT MINIUPNPC_FOUND OR STATIC)
+ message(STATUS "Using in-tree miniupnpc")
+ set(UPNPC_NO_INSTALL TRUE CACHE BOOL "Disable miniupnp installation" FORCE)
+ add_subdirectory(miniupnp/miniupnpc)
+ set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+ set_property(TARGET libminiupnpc-static PROPERTY POSITION_INDEPENDENT_CODE ON)
+ if(MSVC)
+ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+ elseif(NOT MSVC)