Moved games/kxl to devel/kxl
PR: ports/87240 Submitted by: Edwin Groothuis <edwin@mavetju.org>
This commit is contained in:
parent
f8f0d093cc
commit
3a616a067c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145072
12 changed files with 3 additions and 156 deletions
1
MOVED
1
MOVED
|
@ -1643,3 +1643,4 @@ games/py-balazar|games/balazar|2005-10-09|renamed to reflect right name
|
|||
multimedia/gpac-libm4systems|multimedia/gpac-libgpac|2005-10-09|Library renamed
|
||||
games/marbles|games/lmarbles|2005-10-10|renamed to reflect right name
|
||||
games/py-slune|games/slune|2005-10-10|renamed to reflect right name
|
||||
games/kxl|devel/kxl|2005-10-12|accurate category
|
||||
|
|
|
@ -417,6 +417,7 @@
|
|||
SUBDIR += korelib
|
||||
SUBDIR += kprof
|
||||
SUBDIR += kscope
|
||||
SUBDIR += kxl
|
||||
SUBDIR += kyra
|
||||
SUBDIR += lbpp
|
||||
SUBDIR += leaktracer
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
PORTNAME= kxl
|
||||
PORTVERSION= 1.1.7
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= http://kxl.hn.org/download/
|
||||
DISTNAME= KXL-${PORTVERSION}
|
||||
|
||||
|
|
|
@ -300,7 +300,6 @@
|
|||
SUBDIR += kslide
|
||||
SUBDIR += ktritoc
|
||||
SUBDIR += kwappen
|
||||
SUBDIR += kxl
|
||||
SUBDIR += ladder
|
||||
SUBDIR += lbreakout
|
||||
SUBDIR += lbreakout2
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
# New ports collection makefile for: kxl
|
||||
# Date created: 16 June 2001
|
||||
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= kxl
|
||||
PORTVERSION= 1.1.7
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://kxl.hn.org/download/
|
||||
DISTNAME= KXL-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A visual, sound library for games
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
|
||||
LIBS=="-L${X11BASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
MD5 (KXL-1.1.7.tar.gz) = 321bfad9dee29840656225b54bb6feb0
|
||||
SIZE (KXL-1.1.7.tar.gz) = 192070
|
|
@ -1,57 +0,0 @@
|
|||
--- src/KXLsound.c.orig Fri Jan 17 01:29:09 2003
|
||||
+++ src/KXLsound.c Wed Oct 5 12:13:08 2005
|
||||
@@ -3,7 +3,6 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/time.h>
|
||||
-#include <linux/soundcard.h>
|
||||
#include "KXL.h"
|
||||
|
||||
#define MIN(a, b) (((a) < (b)) ? (a) : (b))
|
||||
@@ -45,6 +44,7 @@
|
||||
//==============================================================
|
||||
void KXL_SoundServer(void)
|
||||
{
|
||||
+#ifndef __FreeBSD__
|
||||
Uint16 i;
|
||||
KXL_SoundControl Command;
|
||||
fd_set sound_fdset;
|
||||
@@ -163,6 +163,7 @@
|
||||
}
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
|
||||
//==============================================================
|
||||
@@ -239,6 +240,7 @@
|
||||
//==============================================================
|
||||
void KXL_InitSound(Uint8 *path, Uint8 **fname)
|
||||
{
|
||||
+#ifndef __FreeBSD__
|
||||
KXL_SoundOk = False;
|
||||
|
||||
KXL_LoadSoundData(path, fname);
|
||||
@@ -266,6 +268,7 @@
|
||||
close(KXL_SoundData.Pipe[0]);
|
||||
KXL_SoundOk = True;
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
|
||||
//==============================================================
|
||||
@@ -273,6 +276,7 @@
|
||||
//==============================================================
|
||||
void KXL_EndSound(void)
|
||||
{
|
||||
+#ifndef __FreeBSD__
|
||||
while (KXL_SoundData.ListCnt)
|
||||
KXL_Free(KXL_wavelist[-- KXL_SoundData.ListCnt].Data);
|
||||
KXL_Free(KXL_wavelist);
|
||||
@@ -282,5 +286,6 @@
|
||||
KXL_PlaySound(0, KXL_SOUND_STOP_ALL);
|
||||
kill(KXL_SoundData.ID, SIGTERM);
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
|
|
@ -1,9 +0,0 @@
|
|||
--- src/KXLmisc.c.orig Sun Jan 20 01:10:31 2002
|
||||
+++ src/KXLmisc.c Sat Mar 30 19:26:06 2002
|
||||
@@ -1,6 +1,5 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
-#include <malloc.h>
|
||||
#include <signal.h>
|
||||
#include <sys/time.h>
|
||||
#include "KXL.h"
|
|
@ -1,10 +0,0 @@
|
|||
--- src/KXL.h.orig Wed Oct 5 12:14:12 2005
|
||||
+++ src/KXL.h Wed Oct 5 12:14:18 2005
|
||||
@@ -4,7 +4,6 @@
|
||||
#include <stdio.h>
|
||||
#include <X11/Xlib.h>
|
||||
#include <X11/Xutil.h>
|
||||
-#include <linux/joystick.h>
|
||||
|
||||
|
||||
//================================================================
|
|
@ -1,40 +0,0 @@
|
|||
--- src/KXLjoystick.c.orig Wed Oct 5 12:14:36 2005
|
||||
+++ src/KXLjoystick.c Wed Oct 5 12:15:19 2005
|
||||
@@ -11,24 +11,7 @@
|
||||
// return value : True - ok, False - NG
|
||||
//==============================================================
|
||||
Bool KXL_OpenJoystick(Uint8 *devname) {
|
||||
- Uint8 name[128] = "Unknown";
|
||||
- Sint32 version = 0x000800;
|
||||
- Uint8 axis = 2;
|
||||
- Uint8 buttons = 2;
|
||||
-
|
||||
- KXL_joydev = open(devname, O_RDONLY);
|
||||
- if (KXL_joydev < 0) {
|
||||
- fprintf(stderr, "KXL error message\nCannot open \"%s\".\n", devname);
|
||||
- return False;
|
||||
- }
|
||||
- ioctl(KXL_joydev, JSIOCGVERSION, &version);
|
||||
- ioctl(KXL_joydev, JSIOCGAXES, &axis);
|
||||
- ioctl(KXL_joydev, JSIOCGBUTTONS, &buttons);
|
||||
- ioctl(KXL_joydev, JSIOCGNAME(128), name);
|
||||
- //fcntl(KXL_joydev, F_SETFL, O_NONBLOCK);
|
||||
- fprintf(stderr, "KXL message\nJoystick (%s) has %d axes and %d buttons.\nDriver version is %d.%d.%d.\n",
|
||||
- name, axis, buttons, version >> 16, (version >> 8) & 0xff, version & 0xff);
|
||||
- return True;
|
||||
+ return False;
|
||||
}
|
||||
|
||||
//==============================================================
|
||||
@@ -46,11 +29,4 @@
|
||||
// return value : True - ok, False - NG
|
||||
//==============================================================
|
||||
Bool KXL_ReadJoystick(KXL_Joystick *my) {
|
||||
- if (KXL_joydev >= 0) {
|
||||
- if (read(KXL_joydev, my, JS_RETURN) == JS_RETURN) {
|
||||
- return True;
|
||||
- }
|
||||
- }
|
||||
- fprintf(stderr, "KXL error message\njoystick reading error\n");
|
||||
- return False;
|
||||
}
|
|
@ -1,5 +0,0 @@
|
|||
a visual, sound library for games
|
||||
|
||||
Sound is not available on FreeBSD.
|
||||
|
||||
WWW: http://kxl.hn.org/
|
|
@ -1,6 +0,0 @@
|
|||
include/KXL.h
|
||||
lib/libKXL-1.1.7.so
|
||||
lib/libKXL.so
|
||||
lib/libKXL.a
|
||||
lib/libKXL.la
|
||||
share/aclocal/KXL.m4
|
Loading…
Reference in a new issue