- Upgrade to 1.4.0.
PR: ports/199159 Submitted by: Yasuhiro KIMURA <freebsd.org@pob01.utahime.jp>
This commit is contained in:
parent
748a2e5cae
commit
3a807c07d1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383974
5 changed files with 31 additions and 68 deletions
|
@ -2,9 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= magit
|
||||
PORTVERSION= 1.2.1
|
||||
PORTVERSION= 1.4.0
|
||||
CATEGORIES= devel elisp
|
||||
MASTER_SITES= https://github.com/magit/magit/releases/download/${PORTVERSION}/
|
||||
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
|
||||
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
|
@ -13,19 +12,27 @@ COMMENT= Interface to Git for Emacs
|
|||
LICENSE= GFDL GPLv3
|
||||
LICENSE_COMB= multi
|
||||
|
||||
USES= gmake
|
||||
BUILD_DEPENDS= git-modes-${EMACS_PORT_NAME}>0:${PORTSDIR}/devel/git-modes
|
||||
RUN_DEPENDS= git-modes-${EMACS_PORT_NAME}>0:${PORTSDIR}/devel/git-modes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ${PORTNAME}
|
||||
GH_TAGNAME= 1.4.0
|
||||
|
||||
USES= gmake makeinfo
|
||||
USE_EMACS= YES
|
||||
INFO= magit
|
||||
PORTDOCS= AUTHORS.md
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
ELISPDIR= ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
|
||||
|
||||
MAKE_ENV+= ELISPDIR=${STAGEDIR}${PREFIX}/${ELISPDIR} \
|
||||
INFODIR=${STAGEDIR}${PREFIX}/${INFO_PATH}
|
||||
MAKE_ENV+= EFLAGS="-L ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/git-modes" \
|
||||
lispdir=${PREFIX}/${ELISPDIR} \
|
||||
infodir=${PREFIX}/${INFO_PATH} \
|
||||
docdir=${DOCSDIR}
|
||||
PLIST_SUB+= ELISPDIR=${ELISPDIR}
|
||||
|
||||
OPTIONS_DEFINE= GIT_SUBVERSION
|
||||
GIT_SUBVERSION_DESC= Use devel/git-subversion as backend
|
||||
GIT_SUBVERSION_RUN_DEPENDS= git-subversion>0:${PORTSDIR}/devel/git-subversion
|
||||
GIT_SUBVERSION_RUN_DEPENDS_OFF= git>0:${PORTSDIR}/devel/git
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (magit-1.2.1.tar.gz) = f99937c7ee9850fc9a283cc49ba5159fe23a4e7fd75e251c4bacf542cb43c4c6
|
||||
SIZE (magit-1.2.1.tar.gz) = 111414
|
||||
SHA256 (magit-magit-1.4.0-1.4.0_GH0.tar.gz) = 03cdc29fe5d5d3c5b1d975bccfcf0bb12318c6e5c198575c395caa3eb14e3878
|
||||
SIZE (magit-magit-1.4.0-1.4.0_GH0.tar.gz) = 132600
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- ./Makefile.orig 2012-09-24 19:41:19.000000000 +0000
|
||||
+++ ./Makefile 2014-07-01 17:24:01.000000000 +0000
|
||||
@@ -1,5 +1,5 @@
|
||||
VERSION=1.2.0
|
||||
-EMACS=emacs
|
||||
+#EMACS=emacs
|
||||
PREFIX=/usr/local
|
||||
SYSCONFDIR=/etc
|
||||
ELS=magit.el magit-svn.el magit-topgit.el magit-stgit.el magit-key-mode.el magit-bisect.el magit-wip.el rebase-mode.el magit-blame.el
|
||||
@@ -40,7 +40,7 @@
|
||||
magit.elc: magit.el
|
||||
|
||||
dir: magit.info
|
||||
- install-info --dir=$@ $<
|
||||
+ touch $@
|
||||
|
||||
magit.info:
|
||||
|
||||
@@ -64,15 +64,12 @@
|
||||
install: install_core install_docs
|
||||
|
||||
install_core: core
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/share/emacs/site-lisp
|
||||
- install -m 644 $(ELS) $(ELCS) $(DESTDIR)$(PREFIX)/share/emacs/site-lisp
|
||||
- mkdir -p $(DESTDIR)$(SYSCONFDIR)/emacs/site-start.d
|
||||
- install -m 644 50magit.el $(DESTDIR)$(SYSCONFDIR)/emacs/site-start.d/50magit.el
|
||||
+ mkdir -p $(ELISPDIR)
|
||||
+ install -m 644 $(ELS) $(ELCS) $(ELISPDIR)
|
||||
|
||||
install_docs: docs
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/share/info
|
||||
- install -m 644 magit.info $(DESTDIR)$(PREFIX)/share/info
|
||||
- install-info --info-dir=$(DESTDIR)$(PREFIX)/share/info $(DESTDIR)$(PREFIX)/share/info/magit.info
|
||||
+ mkdir -p $(INFODIR)
|
||||
+ install -m 644 magit.info $(INFODIR)
|
||||
|
||||
install_contrib: contrib
|
||||
mkdir -p $(DESTDIR)$(PREFIX)/share/emacs/site-lisp
|
|
@ -1,7 +1,9 @@
|
|||
With Magit, you can inspect and modify your Git repositories with
|
||||
Emacs. You can review and commit the changes you have made to the
|
||||
tracked files, for example, and you can browse the history of past
|
||||
changes. There is support for cherry picking, reverting, merging,
|
||||
rebasing, and other common Git operations.
|
||||
Magit is an interface to the version control system Git, implemented
|
||||
as an Emacs extension.
|
||||
|
||||
WWW: http://magit.github.io/magit/
|
||||
Unlike Emacs' native Version Control package which strives to provide
|
||||
a unified interface to various version control systems, Magit only
|
||||
supports Git and can therefore better take advantage of its native
|
||||
features.
|
||||
|
||||
WWW: http://magit.vc/
|
||||
|
|
|
@ -1,18 +1,10 @@
|
|||
%%ELISPDIR%%/magit-bisect.el
|
||||
%%ELISPDIR%%/magit-bisect.elc
|
||||
%%ELISPDIR%%/magit-autoloads.el
|
||||
%%ELISPDIR%%/magit-blame.el
|
||||
%%ELISPDIR%%/magit-blame.elc
|
||||
%%ELISPDIR%%/magit-key-mode.el
|
||||
%%ELISPDIR%%/magit-key-mode.elc
|
||||
%%ELISPDIR%%/magit-stgit.el
|
||||
%%ELISPDIR%%/magit-stgit.elc
|
||||
%%ELISPDIR%%/magit-svn.el
|
||||
%%ELISPDIR%%/magit-svn.elc
|
||||
%%ELISPDIR%%/magit-topgit.el
|
||||
%%ELISPDIR%%/magit-topgit.elc
|
||||
%%ELISPDIR%%/magit-version.el
|
||||
%%ELISPDIR%%/magit-wip.el
|
||||
%%ELISPDIR%%/magit-wip.elc
|
||||
%%ELISPDIR%%/magit.el
|
||||
%%ELISPDIR%%/magit.elc
|
||||
%%ELISPDIR%%/rebase-mode.el
|
||||
%%ELISPDIR%%/rebase-mode.elc
|
||||
|
|
Loading…
Reference in a new issue