This extension adds support for the U2F specification with Yubico devices
to Firefox. It can be used by accessing window.u2f object from content pages. WWW: https://github.com/prefiks/u2f4moz
This commit is contained in:
parent
c7e454d60c
commit
3a9c0a694d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424967
6 changed files with 78 additions and 0 deletions
|
@ -2409,6 +2409,7 @@
|
|||
SUBDIR += xpi-togglewordwrap
|
||||
SUBDIR += xpi-torbutton
|
||||
SUBDIR += xpi-twitterfox
|
||||
SUBDIR += xpi-u2f4moz
|
||||
SUBDIR += xpi-uBlock_origin
|
||||
SUBDIR += xpi-unplug
|
||||
SUBDIR += xpi-urllink
|
||||
|
|
47
www/xpi-u2f4moz/Makefile
Normal file
47
www/xpi-u2f4moz/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= u2f4moz
|
||||
DISTVERSION= v1.0
|
||||
CATEGORIES= www
|
||||
PKGNAMEPREFIX= xpi-
|
||||
|
||||
MAINTAINER= nivit@FreeBSD.org
|
||||
COMMENT= U2F support extension for Firefox
|
||||
|
||||
LICENSE= LGPL21
|
||||
|
||||
CMAKE_SOURCE_PATH= c_src
|
||||
|
||||
FIREFOX_EXTENSIONS_DIR= lib/firefox/browser/extensions
|
||||
|
||||
GH_ACCOUNT= prefiks
|
||||
|
||||
PLIST_SUB= SYSTEM_PROCESSOR=${SYSTEM_PROCESSOR}
|
||||
|
||||
SYSTEM_PROCESSOR= x86
|
||||
|
||||
USE_GITHUB= yes
|
||||
USES= cmake
|
||||
|
||||
XPI_DIR= lib/xpi
|
||||
XPI_ID= u2f4moz@prefiks.org
|
||||
|
||||
post-patch:
|
||||
@${SED} -i.bak -e 's,%%XPI_DIR%%,${XPI_DIR},1' \
|
||||
-e 's,%%XPI_ID%%,${XPI_ID},1' ${WRKSRC}/c_src/CMakeLists.txt
|
||||
|
||||
post-install:
|
||||
(cd ${WRKSRC}/ext && \
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}/${PREFIX}/${XPI_DIR}/${XPI_ID} && \
|
||||
${MKDIR} ${STAGEDIR}/${PREFIX}/${FIREFOX_EXTENSIONS_DIR})
|
||||
(cd ${STAGEDIR}/${PREFIX}/${FIREFOX_EXTENSIONS_DIR} && \
|
||||
${LN} -s ../../../xpi/${XPI_ID} ${XPI_ID})
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
SYSTEM_PROCESSOR= x86_64
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
www/xpi-u2f4moz/distinfo
Normal file
3
www/xpi-u2f4moz/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1477842711
|
||||
SHA256 (prefiks-u2f4moz-v1.0_GH0.tar.gz) = 479996b410f127dfbe0f33fac670ac8c53fbefcd26ce05357d9206ae5cc5a2fd
|
||||
SIZE (prefiks-u2f4moz-v1.0_GH0.tar.gz) = 116787
|
8
www/xpi-u2f4moz/files/patch-c__src_CMakeLists.txt
Normal file
8
www/xpi-u2f4moz/files/patch-c__src_CMakeLists.txt
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- c_src/CMakeLists.txt.orig 2016-10-27 08:19:19 UTC
|
||||
+++ c_src/CMakeLists.txt
|
||||
@@ -144,4 +144,4 @@ ADD_EXECUTABLE(u2f
|
||||
|
||||
TARGET_LINK_LIBRARIES(u2f ${extra_LIBS})
|
||||
|
||||
-INSTALL(TARGETS u2f DESTINATION ${PROJECT_SOURCE_DIR}/../ext/bin/${TARGET_LOCATION})
|
||||
+INSTALL(TARGETS u2f DESTINATION %%XPI_DIR%%/%%XPI_ID%%/bin/${TARGET_LOCATION})
|
6
www/xpi-u2f4moz/pkg-descr
Normal file
6
www/xpi-u2f4moz/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This extension adds support for the U2F specification with Yubico devices
|
||||
to Firefox.
|
||||
|
||||
It can be used by accessing window.u2f object from content pages.
|
||||
|
||||
WWW: https://github.com/prefiks/u2f4moz
|
13
www/xpi-u2f4moz/pkg-plist
Normal file
13
www/xpi-u2f4moz/pkg-plist
Normal file
|
@ -0,0 +1,13 @@
|
|||
lib/firefox/browser/extensions/u2f4moz@prefiks.org
|
||||
lib/xpi/u2f4moz@prefiks.org/appIdValidator.js
|
||||
lib/xpi/u2f4moz@prefiks.org/bin/freebsd_%%SYSTEM_PROCESSOR%%-gcc3/u2f
|
||||
lib/xpi/u2f4moz@prefiks.org/bootstrap.js
|
||||
lib/xpi/u2f4moz@prefiks.org/data/content-script.js
|
||||
lib/xpi/u2f4moz@prefiks.org/data/logs.html
|
||||
lib/xpi/u2f4moz@prefiks.org/data/logs.js
|
||||
lib/xpi/u2f4moz@prefiks.org/icon.png
|
||||
lib/xpi/u2f4moz@prefiks.org/icon64.png
|
||||
lib/xpi/u2f4moz@prefiks.org/index.js
|
||||
lib/xpi/u2f4moz@prefiks.org/install.rdf
|
||||
lib/xpi/u2f4moz@prefiks.org/options.xul
|
||||
lib/xpi/u2f4moz@prefiks.org/package.json
|
Loading…
Reference in a new issue