Update to 2.1.7.
Submitted by: maintainer PR: 93944
This commit is contained in:
parent
dd377fd837
commit
3aab734d41
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159860
6 changed files with 31 additions and 56 deletions
|
@ -6,48 +6,45 @@
|
|||
#
|
||||
|
||||
PORTNAME= pari
|
||||
PORTVERSION= 2.1.6
|
||||
PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}.${REV_VERSION}
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://pari.math.u-bordeaux.fr/pub/pari/unix/
|
||||
MASTER_SITES= http://pari.math.u-bordeaux.fr/pub/pari/unix/
|
||||
DISTNAME= pari-${MAJOR_VERSION}.${MINOR_VERSION}.${REV_VERSION}
|
||||
|
||||
MAINTAINER= yoshiaki@kt.rim.or.jp
|
||||
COMMENT= Mathmatics library and advanced calculator package
|
||||
|
||||
EXTRACT_SUFX= .tgz
|
||||
CONFLICTS= pari-2.2.*
|
||||
|
||||
EXTRACT_SUFX= .tgz
|
||||
NO_LATEST_LINK= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= Configure
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} --share-prefix=${PREFIX}/share
|
||||
# build is broken on some locales
|
||||
CONFIGURE_ENV= LANG=C
|
||||
MAKE_ENV= LANG=C
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
#USE_GMAKE= yes
|
||||
MAKE_ARGS= gp
|
||||
PLIST_SUB= MAJOR_VERSION=${MAJOR_VERSION} MINOR_VERSION=${MINOR_VERSION} REV_VERSION=${REV_VERSION}
|
||||
|
||||
MAJOR_VERSION= 2
|
||||
MINOR_VERSION= 1
|
||||
REV_VERSION= 7
|
||||
|
||||
MAN1= gp.1 gphelp.1 tex2mail.1
|
||||
MLINKS= gp.1 pari.1
|
||||
|
||||
HAVE_EMACS!= which emacs || echo nope
|
||||
.if ${HAVE_EMACS} != "nope"
|
||||
PLIST= ${PKGDIR}/pkg-plist.emacs
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 502126
|
||||
USE_GCC= 3.2
|
||||
HAVE_EMACS!= ${WHICH} emacs || ${ECHO} nope
|
||||
.if ${HAVE_EMACS} != "nope"
|
||||
PLIST= ${PKGDIR}/pkg-plist.emacs
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
CFLAGS+= -fPIC
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
|
||||
BROKEN= "Does not compile on sparc64 or ia64"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-O3|"${CFLAGS}"|' ${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (pari-2.1.6.tgz) = 506a061c8dcdec33d18876f3c551e951
|
||||
SHA256 (pari-2.1.6.tgz) = 6150700432e2cbd08567aeaa62b2f7f92f350b83f2cac8e747b1d581883a4227
|
||||
SIZE (pari-2.1.6.tgz) = 1541464
|
||||
MD5 (pari-2.1.7.tgz) = 357b7a42e89e2761a5367bbcbfcca5f2
|
||||
SHA256 (pari-2.1.7.tgz) = 9142f2cdaf3083c8962f1a5c2bb0e9fe8915f7d9490c03312ac2361c7ea155fa
|
||||
SIZE (pari-2.1.7.tgz) = 1542137
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- config/Makefile.SH.orig Thu Sep 27 10:58:38 2001
|
||||
+++ config/Makefile.SH Wed May 22 01:43:10 2002
|
||||
@@ -176,7 +176,7 @@
|
||||
--- config/Makefile.SH.orig Sat Apr 26 04:08:14 2003
|
||||
+++ config/Makefile.SH Tue Feb 28 19:07:18 2006
|
||||
@@ -183,7 +183,7 @@
|
||||
LIBDIR = \$(DESTDIR)$libdir
|
||||
BINDIR = \$(DESTDIR)$bindir
|
||||
DATADIR= \$(DESTDIR)$datadir
|
||||
|
@ -9,7 +9,7 @@
|
|||
ALLDIR = \$(DESTDIR)$miscdir
|
||||
READMEDIR = \$(ALLDIR)
|
||||
DOCDIR = \$(ALLDIR)/doc
|
||||
@@ -348,7 +348,7 @@
|
||||
@@ -355,7 +355,7 @@
|
||||
|
||||
install-doc::
|
||||
-mkdir -p \$(BINDIR) \$(DOCDIR)
|
||||
|
@ -18,7 +18,7 @@
|
|||
-\$(INSTALL_PROGRAM) $doc/gphelp \$(BINDIR)
|
||||
-\$(INSTALL_DATA) $doc/Makefile \$(DOCDIR)
|
||||
-\$(INSTALL_DATA) $doc/translations \$(DOCDIR)
|
||||
@@ -367,10 +367,10 @@
|
||||
@@ -374,10 +374,10 @@
|
||||
-\$(INSTALL_DATA) $doc/usersch4.tex \$(DOCDIR)
|
||||
-\$(INSTALL_DATA) $doc/usersch5.tex \$(DOCDIR)
|
||||
-\$(INSTALL_DATA) $doc/paricfg.tex \$(DOCDIR)
|
||||
|
@ -33,7 +33,7 @@
|
|||
|
||||
install-examples:
|
||||
-mkdir -p \$(EXDIR)
|
||||
@@ -388,8 +388,8 @@
|
||||
@@ -395,8 +395,8 @@
|
||||
-\$(INSTALL_DATA) $ex/taylor.gp \$(EXDIR)
|
||||
|
||||
install-data:
|
||||
|
@ -44,7 +44,7 @@
|
|||
|
||||
install-lib-sta: \$(LIBPARI_STA)
|
||||
-mkdir -p \$(LIBDIR)
|
||||
@@ -401,6 +401,7 @@
|
||||
@@ -408,6 +408,7 @@
|
||||
-mkdir -p \$(LIBDIR)
|
||||
-\$(RM) \$(LIBDIR)/\$(LIBPARI_DYN)
|
||||
\$(INSTALL_PROGRAM) \$(LIBPARI_DYN) \$(LIBDIR)/\$(LIBPARI_DYN)
|
||||
|
@ -52,7 +52,7 @@
|
|||
EOT
|
||||
if test "$soname" != "$sodest"; then
|
||||
cat >> $file << EOT
|
||||
@@ -429,6 +430,7 @@
|
||||
@@ -436,6 +437,7 @@
|
||||
\$(LIBPARI_DYN): \$(OBJS)
|
||||
-\$(RM) \$(LIBPARI_DYN)
|
||||
\$(DLLD) -o \$@ \$(DLLDFLAGS) \$(OBJS) \$(EXTRADLLDFLAGS)
|
||||
|
@ -60,7 +60,7 @@
|
|||
EOT
|
||||
if test "$soname" != "$sodest"; then
|
||||
cat >> $file << EOT
|
||||
@@ -457,13 +459,13 @@
|
||||
@@ -464,13 +466,13 @@
|
||||
|
||||
if test -n "$emacs"; then
|
||||
cat >> $file << EOT
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- doc/appb.tex.orig Mon Jan 10 02:59:06 2000
|
||||
+++ doc/appb.tex Mon Jan 10 02:59:23 2000
|
||||
@@ -29,5 +29,5 @@
|
||||
--- doc/appb.tex.orig Sat Sep 17 01:50:48 2005
|
||||
+++ doc/appb.tex Tue Feb 28 19:07:18 2006
|
||||
@@ -35,5 +35,5 @@
|
||||
seen in detail in \secref{se:prog}, with the slight modifications explained
|
||||
at the end of that section.
|
||||
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
diff -urN files_orig/patch-has_exp2.c files/patch-has_exp2.c
|
||||
--- files_orig/patch-has_exp2.c Wed Dec 31 18:00:00 1969
|
||||
+++ files/patch-has_exp2.c Thu Sep 16 14:30:23 2004
|
||||
@@ -0,0 +1,6 @@
|
||||
+--- config/has_exp2.c_orig Thu Sep 16 08:46:59 1999
|
||||
++++ config/has_exp2.c Thu Sep 16 14:27:18 2004
|
||||
+@@ -1,2 +1,2 @@
|
||||
+ #include <math.h>
|
||||
+-main(){double x=exp2(1.0);}
|
||||
++main(){double x=exp2(0.666);}
|
||||
diff -urN files_orig/patch-has_log2.c files/patch-has_log2.c
|
||||
--- files_orig/patch-has_log2.c Wed Dec 31 18:00:00 1969
|
||||
+++ files/patch-has_log2.c Thu Sep 16 14:30:50 2004
|
||||
@@ -0,0 +1,6 @@
|
||||
+--- config/has_log2.c_orig Wed Jan 8 18:16:55 2003
|
||||
++++ config/has_log2.c Thu Sep 16 14:27:07 2004
|
||||
+@@ -1,2 +1,2 @@
|
||||
+ #include <math.h>
|
||||
+-main(){double x=log2(1.0);}
|
||||
++main(){double x=log2(0.666);}
|
|
@ -9,5 +9,3 @@ application (for instance written in C, C++, Pascal or Fortran);
|
|||
2) as a sophisticated programmable calculator, named GP, which contains
|
||||
most of the standard control instructions of a standard language
|
||||
like C.
|
||||
|
||||
WWW: http://pari.math.u-bordeaux.fr/
|
||||
|
|
Loading…
Reference in a new issue