databases/freetds: Update version 0.91.112.0.0=>0.95.0
- Remove PORTSCOUT variable as new version has superseeded
This commit is contained in:
parent
4f413291cd
commit
3abab89bf0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=388912
7 changed files with 33 additions and 35 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= freetds
|
||||
PORTVERSION= 0.91.112.0.0
|
||||
PORTVERSION= 0.95.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ftp://ftp.freetds.org/pub/freetds/stable/
|
||||
|
@ -14,14 +14,13 @@ LICENSE= GPLv2
|
|||
|
||||
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
|
||||
|
||||
PORTSCOUT= skipv:0.92.48,0.92.49,0.92.51,0.92.52,0.92.53,0.92.54,0.92.55,0.92.59,0.92.63,0.92.79,0.92.405
|
||||
TDS_VER?= 5.0
|
||||
|
||||
USES= autoreconf iconv gmake pkgconfig libtool:keepla tar:bzip2
|
||||
USES= autoreconf iconv gmake libtool:keepla pkgconfig readline tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
LIBS+= -lgcrypt
|
||||
LIBS+= -lgcrypt -lpthread
|
||||
CONFIGURE_ARGS= --with-tdsver=${TDS_VER} --sysconfdir=${ETCDIR} \
|
||||
--enable-sybase-compat --enable-msdblib
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -70,10 +69,5 @@ post-patch:
|
|||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/interfaces ${STAGEDIR}${ETCDIR}/interfaces.sample
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC}/doc/doc/${PORTNAME}-${PORTVERSION} && \
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (freetds-0.91.112.0.0.tar.bz2) = 31c3ae92676c325f88306b60c073a274d91b0ec391a5d24eb8cf0039b2b010fa
|
||||
SIZE (freetds-0.91.112.0.0.tar.bz2) = 1803980
|
||||
SHA256 (freetds-0.95.0.tar.bz2) = ffcf6179545dea253d6bc3b081c220d4d1ff4f1d434d159baec17c820ad5cba3
|
||||
SIZE (freetds-0.95.0.tar.bz2) = 3208585
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- doc/Makefile.am.orig 2015-01-29 00:40:17 UTC
|
||||
+++ doc/Makefile.am
|
||||
@@ -8,7 +8,7 @@ SHELL = /bin/sh
|
||||
TXT2MAN = $(srcdir)/txt2man
|
||||
DOCDIR = doc/freetds-$(VERSION)
|
||||
PRODUCT = FreeTDS
|
||||
-TARGET_DOCDIR = $(DESTDIR)$(datadir)/$(DOCDIR)
|
||||
+TARGET_DOCDIR = $(DESTDIR)$(datadir)/doc/freetds
|
||||
|
||||
IMAGES = images/important.gif \
|
||||
images/note.gif \
|
14
databases/freetds/files/patch-include_freetds_tds.h
Normal file
14
databases/freetds/files/patch-include_freetds_tds.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- include/freetds/tds.h.orig 2015-06-09 10:34:04 UTC
|
||||
+++ include/freetds/tds.h
|
||||
@@ -144,7 +144,10 @@ typedef struct
|
||||
TDS_INT date; /**< date, 0 = 1900-01-01 */
|
||||
TDS_SMALLINT offset; /**< time offset */
|
||||
TDS_USMALLINT time_prec:3;
|
||||
- TDS_USMALLINT _res:10;
|
||||
+#pragma push_macro("_res")
|
||||
+#undef _res
|
||||
+ TDS_USMALLINT _res:10;
|
||||
+#pragma pop_macro("_res")
|
||||
TDS_USMALLINT has_time:1;
|
||||
TDS_USMALLINT has_date:1;
|
||||
TDS_USMALLINT has_offset:1;
|
|
@ -1,13 +0,0 @@
|
|||
--- include/tdsodbc.h.orig 2015-01-29 00:40:17 UTC
|
||||
+++ include/tdsodbc.h
|
||||
@@ -30,8 +30,8 @@
|
||||
#include <odbcinst.h>
|
||||
#endif
|
||||
#else /* IODBC */
|
||||
-#include <isql.h>
|
||||
-#include <isqlext.h>
|
||||
+#include <libiodbc/isql.h>
|
||||
+#include <libiodbc/isqlext.h>
|
||||
#ifdef HAVE_IODBCINST_H
|
||||
#include <iodbcinst.h>
|
||||
#endif /* HAVE_IODBCINST_H */
|
13
databases/freetds/files/patch-src_tds_tls.c
Normal file
13
databases/freetds/files/patch-src_tds_tls.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/tds/tls.c.orig 2015-06-09 10:38:40 UTC
|
||||
+++ src/tds/tls.c
|
||||
@@ -46,6 +46,10 @@
|
||||
#include <sys/stat.h>
|
||||
#endif /* HAVE_SYS_STAT_H */
|
||||
|
||||
+#if defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
+#include <sys/socket.h>
|
||||
+#endif
|
||||
+
|
||||
#include <freetds/tds.h>
|
||||
#include <freetds/string.h>
|
||||
#include <freetds/tls.h>
|
|
@ -46,3 +46,4 @@ man/man5/freetds.conf.5.gz
|
|||
%%ODBC%%lib/libtdsodbc.so.0.0.0
|
||||
%%ODBC%%lib/libtdsodbc.la
|
||||
%%ODBC%%lib/libtdsodbc.a
|
||||
%%PORTDOCS%%@dir %%DOCSDIR%%/images/callouts
|
||||
|
|
Loading…
Reference in a new issue