add jakelib2 2.0.0s
A cross platform C++ class library with a Java-like API
This commit is contained in:
parent
84e27e4737
commit
3ac282eb01
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92007
6 changed files with 249 additions and 0 deletions
|
@ -299,6 +299,7 @@
|
|||
SUBDIR += inilib
|
||||
SUBDIR += invitation_to_ruby
|
||||
SUBDIR += ixlib
|
||||
SUBDIR += jakelib2
|
||||
SUBDIR += jam
|
||||
SUBDIR += jrtplib
|
||||
SUBDIR += kaptain
|
||||
|
|
32
devel/jakelib2/Makefile
Normal file
32
devel/jakelib2/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: jakelib2
|
||||
# Date created: Oct 23, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= jakelib2
|
||||
PORTVERSION= 2.0.0.s
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.jakelib.org/lib/jakelib2/download/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A cross platform C++ class library with a Java-like API
|
||||
|
||||
LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc
|
||||
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --disable-debug
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
INFO= jakelib2
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/jakelib2/distinfo
Normal file
1
devel/jakelib2/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (jakelib2-2.0.0s.tar.gz) = a58c044cac537cc45a1843b8a8eea227
|
15
devel/jakelib2/files/patch-ltmain.sh
Normal file
15
devel/jakelib2/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ltmain.sh.orig Fri Oct 24 09:34:59 2003
|
||||
+++ ltmain.sh Fri Oct 24 09:35:12 2003
|
||||
@@ -4175,10 +4175,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
8
devel/jakelib2/pkg-descr
Normal file
8
devel/jakelib2/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
Jakelib2 is a cross platform C++ class library with a Java-like API. An
|
||||
automatic garbage collector is used to take care of unused objects. External
|
||||
libraries like PCRE or GTK+ are beeing integrated to provide the programmer
|
||||
with a homogeneous, easy to use programming environment that covers every
|
||||
day's tasks like string handling, data storage, networking, or GUI
|
||||
programming.
|
||||
|
||||
WWW: http://www.jakelib.org/
|
192
devel/jakelib2/pkg-plist
Normal file
192
devel/jakelib2/pkg-plist
Normal file
|
@ -0,0 +1,192 @@
|
|||
bin/jakelib2-config
|
||||
bin/jakelib2-newclass
|
||||
bin/jakelib2-skeleton
|
||||
bin/jlpp
|
||||
include/jakelib2.h
|
||||
include/jakelib2/config.h
|
||||
include/jakelib2/gc/gc.h
|
||||
include/jakelib2/gc/gc_config_macros.h
|
||||
include/jakelib2/gc/gc_cpp.h
|
||||
include/jakelib2/gc/gc_pthread_redirects.h
|
||||
include/jakelib2/io/BufferedReader.h
|
||||
include/jakelib2/io/BufferedWriter.h
|
||||
include/jakelib2/io/ByteArrayInputStream.h
|
||||
include/jakelib2/io/File.h
|
||||
include/jakelib2/io/FileInputStream.h
|
||||
include/jakelib2/io/FileOutputStream.h
|
||||
include/jakelib2/io/FileReader.h
|
||||
include/jakelib2/io/FileWriter.h
|
||||
include/jakelib2/io/FilenameExtensionFilter.h
|
||||
include/jakelib2/io/FilenameFilter.h
|
||||
include/jakelib2/io/IOException.h
|
||||
include/jakelib2/io/InputStream.h
|
||||
include/jakelib2/io/InputStreamReader.h
|
||||
include/jakelib2/io/OutputStream.h
|
||||
include/jakelib2/io/OutputStreamWriter.h
|
||||
include/jakelib2/io/PipeInputStream.h
|
||||
include/jakelib2/io/PipeOutputStream.h
|
||||
include/jakelib2/io/PrintWriter.h
|
||||
include/jakelib2/io/RandomAccessFile.h
|
||||
include/jakelib2/io/Reader.h
|
||||
include/jakelib2/io/Serializable.h
|
||||
include/jakelib2/io/StandardOutputStream.h
|
||||
include/jakelib2/io/Syslog.h
|
||||
include/jakelib2/io/WildCardFilter.h
|
||||
include/jakelib2/io/Writer.h
|
||||
include/jakelib2/io/all.h
|
||||
include/jakelib2/lang/Array.h
|
||||
include/jakelib2/lang/Boolean.h
|
||||
include/jakelib2/lang/Byte.h
|
||||
include/jakelib2/lang/Character.h
|
||||
include/jakelib2/lang/Class.h
|
||||
include/jakelib2/lang/Cloneable.h
|
||||
include/jakelib2/lang/Comparable.h
|
||||
include/jakelib2/lang/Double.h
|
||||
include/jakelib2/lang/Exception.h
|
||||
include/jakelib2/lang/Float.h
|
||||
include/jakelib2/lang/Integer.h
|
||||
include/jakelib2/lang/Interface.h
|
||||
include/jakelib2/lang/Long.h
|
||||
include/jakelib2/lang/Math.h
|
||||
include/jakelib2/lang/Monitorable.h
|
||||
include/jakelib2/lang/Mutex.h
|
||||
include/jakelib2/lang/Number.h
|
||||
include/jakelib2/lang/Object.h
|
||||
include/jakelib2/lang/Process.h
|
||||
include/jakelib2/lang/Runnable.h
|
||||
include/jakelib2/lang/Runtime.h
|
||||
include/jakelib2/lang/RuntimeException.h
|
||||
include/jakelib2/lang/Semaphore.h
|
||||
include/jakelib2/lang/Sentry.h
|
||||
include/jakelib2/lang/Short.h
|
||||
include/jakelib2/lang/StackTrace.h
|
||||
include/jakelib2/lang/StackTraceElement.h
|
||||
include/jakelib2/lang/String.h
|
||||
include/jakelib2/lang/StringBuffer.h
|
||||
include/jakelib2/lang/Synchronizeable.h
|
||||
include/jakelib2/lang/Synchronizer.h
|
||||
include/jakelib2/lang/System.h
|
||||
include/jakelib2/lang/Thread.h
|
||||
include/jakelib2/lang/Throwable.h
|
||||
include/jakelib2/lang/all.h
|
||||
include/jakelib2/net/InetAddress.h
|
||||
include/jakelib2/net/ServerSocket.h
|
||||
include/jakelib2/net/Socket.h
|
||||
include/jakelib2/net/SocketInputStream.h
|
||||
include/jakelib2/net/SocketOutputStream.h
|
||||
include/jakelib2/net/URL.h
|
||||
include/jakelib2/net/all.h
|
||||
include/jakelib2/text/ChoiceFormat.h
|
||||
include/jakelib2/text/DateFormat.h
|
||||
include/jakelib2/text/DateFormatSymbols.h
|
||||
include/jakelib2/text/DecimalFormat.h
|
||||
include/jakelib2/text/DecimalFormatSyms.h
|
||||
include/jakelib2/text/FieldPosition.h
|
||||
include/jakelib2/text/Format.h
|
||||
include/jakelib2/text/NumberFormat.h
|
||||
include/jakelib2/text/ParseException.h
|
||||
include/jakelib2/text/ParsePosition.h
|
||||
include/jakelib2/text/SimpleDateFormat.h
|
||||
include/jakelib2/text/all.h
|
||||
include/jakelib2/text/enc/ByteToCharASCII.h
|
||||
include/jakelib2/text/enc/ByteToCharCP1252.h
|
||||
include/jakelib2/text/enc/ByteToCharCP437.h
|
||||
include/jakelib2/text/enc/ByteToCharCP850.h
|
||||
include/jakelib2/text/enc/ByteToCharConverter.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_1.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_10.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_11.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_13.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_14.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_15.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_2.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_3.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_4.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_5.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_6.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_7.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_8.h
|
||||
include/jakelib2/text/enc/ByteToCharISO8859_9.h
|
||||
include/jakelib2/text/enc/ByteToCharSingleByte.h
|
||||
include/jakelib2/text/enc/ByteToCharUTF8.h
|
||||
include/jakelib2/text/enc/CharToByteASCII.h
|
||||
include/jakelib2/text/enc/CharToByteCP1252.h
|
||||
include/jakelib2/text/enc/CharToByteCP437.h
|
||||
include/jakelib2/text/enc/CharToByteCP850.h
|
||||
include/jakelib2/text/enc/CharToByteConverter.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_1.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_10.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_11.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_13.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_14.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_15.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_2.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_3.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_4.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_5.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_6.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_7.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_8.h
|
||||
include/jakelib2/text/enc/CharToByteISO8859_9.h
|
||||
include/jakelib2/text/enc/CharToByteSingleByte.h
|
||||
include/jakelib2/text/enc/CharToByteUTF8.h
|
||||
include/jakelib2/text/enc/all.h
|
||||
include/jakelib2/util/AbstractCollection.h
|
||||
include/jakelib2/util/AbstractList.h
|
||||
include/jakelib2/util/AbstractMap.h
|
||||
include/jakelib2/util/AbstractSet.h
|
||||
include/jakelib2/util/ArrayList.h
|
||||
include/jakelib2/util/ArrayListIterator.h
|
||||
include/jakelib2/util/BitSet.h
|
||||
include/jakelib2/util/ByteArray.h
|
||||
include/jakelib2/util/Calendar.h
|
||||
include/jakelib2/util/CharArray.h
|
||||
include/jakelib2/util/Collection.h
|
||||
include/jakelib2/util/Commandline.h
|
||||
include/jakelib2/util/Comparator.h
|
||||
include/jakelib2/util/Date.h
|
||||
include/jakelib2/util/Dictionary.h
|
||||
include/jakelib2/util/EventListener.h
|
||||
include/jakelib2/util/EventObject.h
|
||||
include/jakelib2/util/GregorianCalendar.h
|
||||
include/jakelib2/util/HashEntry.h
|
||||
include/jakelib2/util/Hashtable.h
|
||||
include/jakelib2/util/HashtableIterator.h
|
||||
include/jakelib2/util/Iterator.h
|
||||
include/jakelib2/util/List.h
|
||||
include/jakelib2/util/Locale.h
|
||||
include/jakelib2/util/Map.h
|
||||
include/jakelib2/util/Properties.h
|
||||
include/jakelib2/util/Queue.h
|
||||
include/jakelib2/util/Set.h
|
||||
include/jakelib2/util/SimpleTimeZone.h
|
||||
include/jakelib2/util/Stack.h
|
||||
include/jakelib2/util/StringComparator.h
|
||||
include/jakelib2/util/StringTokenizer.h
|
||||
include/jakelib2/util/SynchronizedStack.h
|
||||
include/jakelib2/util/TimeZone.h
|
||||
include/jakelib2/util/Vector.h
|
||||
include/jakelib2/util/all.h
|
||||
include/jakelib2/util/regex/Matcher.h
|
||||
include/jakelib2/util/regex/Pattern.h
|
||||
include/jakelib2/util/regex/PatternSyntaxException.h
|
||||
include/jakelib2/util/regex/pcre.h
|
||||
include/jakelib2/win32config.h
|
||||
@dirrm include/jakelib2/gc
|
||||
@dirrm include/jakelib2/io
|
||||
@dirrm include/jakelib2/lang
|
||||
@dirrm include/jakelib2/net
|
||||
@dirrm include/jakelib2/text/enc
|
||||
@dirrm include/jakelib2/text
|
||||
@dirrm include/jakelib2/util/regex
|
||||
@dirrm include/jakelib2/util
|
||||
@dirrm include/jakelib2
|
||||
lib/libjake2.a
|
||||
lib/libjake2.so
|
||||
lib/libjake2.so.1
|
||||
share/aclocal/jakelib2.m4
|
||||
%%DATADIR%%/template/COPYING
|
||||
%%DATADIR%%/template/Main.jlc
|
||||
%%DATADIR%%/template/Sub.jlc
|
||||
@dirrm %%DATADIR%%/template
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue