devel/py-blinker: Update to 1.4

- Update PORTVERSION and distinfo checksum (1.4)
- Add LICENSE_FILE
- Enable concurrent Python support
- Add NO_ARCH (architecture independent package)
- Update test target to new test framework convention
- Patch setup.py to support standard test command [1]

Changes:

  https://github.com/jek/blinker/blob/rel-1.4/CHANGES

[1] https://github.com/jek/blinker/pull/26/
This commit is contained in:
Kubilay Kocak 2015-12-27 06:23:14 +00:00
parent da75f0b112
commit 3aeb750e0d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=404549
3 changed files with 21 additions and 6 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= blinker
PORTVERSION= 1.3
PORTVERSION= 1.4
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -11,13 +11,16 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Fast, simple object-to-object and broadcast signaling
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
USES= python
USE_PYTHON= distutils autoplist
USE_PYTHON= autoplist concurrent distutils
regression-test: build
@cd ${WRKSRC} && nosetests
NO_ARCH= yes
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (blinker-1.3.tar.gz) = 6811010809262261e41ab7b92f3f6d23f35cf816fbec2bc05077992eebec6e2f
SIZE (blinker-1.3.tar.gz) = 91551
SHA256 (blinker-1.4.tar.gz) = 471aee25f3992bd325afa3772f1063dbdbbca947a041b8b89466dc00d606f8b6
SIZE (blinker-1.4.tar.gz) = 111476

View file

@ -0,0 +1,12 @@
# Add support for standard test command
# https://github.com/jek/blinker/pull/26/
--- setup.py.orig 2015-12-27 05:36:22 UTC
+++ setup.py
@@ -37,4 +37,6 @@ setup(name="blinker",
'Topic :: Software Development :: Libraries',
'Topic :: Utilities',
],
+ tests_require=['nose'],
+ test_suite='nose.collector',
)