audio/sonic-visualiser: Update 2.5 -> 4.0.1

A lot of changes:
* Merge some options with the port because they aren't project options any more
* Enable JACK and PULSEAUDIO by default
* Install additonal executables required for the package to run
* Remove the bundled vamp-plugin-sdk directory because the port dependency is used
* Cleanly remove all internal links with vamp-plugin-sdk, not rebuilding it many times any more
* Change WWW to the https URL

PR:		236000
Submitted by:	kunda <chitty_cloud@me.com> (preliminary patch version 3.2.1)
Approved by:	uddka@student.kit.edu (maintainer timeout; 1 year and 50 days)
This commit is contained in:
Yuri Victorovich 2020-04-17 00:21:01 +00:00
parent 467517cb97
commit 3b1b7fa147
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531889
14 changed files with 186 additions and 71 deletions

View file

@ -1,10 +1,9 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= sonic-visualiser PORTNAME= sonic-visualiser
PORTVERSION= 2.5 DISTVERSION= 4.0.1
PORTREVISION= 5
CATEGORIES= audio CATEGORIES= audio
MASTER_SITES= https://code.soundsoftware.ac.uk/attachments/download/1675/ MASTER_SITES= https://code.soundsoftware.ac.uk/attachments/download/2607/
MAINTAINER= uddka@student.kit.edu MAINTAINER= uddka@student.kit.edu
COMMENT= Program for viewing and analysing the contents of music audio files COMMENT= Program for viewing and analysing the contents of music audio files
@ -12,33 +11,37 @@ COMMENT= Program for viewing and analysing the contents of music audio files
LICENSE= GPLv2 LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfftw3.so:math/fftw3 \ LIB_DEPENDS= libcapnp.so:devel/capnproto \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \ libfftw3f.so:math/fftw3-float \
liblrdf.so:textproc/liblrdf \
libogg.so:audio/libogg \
liboggz.so:audio/liboggz \
libopusfile.so:audio/opusfile \
librubberband.so:audio/rubberband \
libsamplerate.so:audio/libsamplerate \ libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile \ libsndfile.so:audio/libsndfile \
librubberband.so:audio/rubberband \
libserd-0.so:devel/serd \ libserd-0.so:devel/serd \
libsord-0.so:devel/sord \ libsord-0.so:devel/sord \
libvamp-hostsdk.so:audio/vamp-plugin-sdk libvamp-hostsdk.so:audio/vamp-plugin-sdk
USES= autoreconf compiler:c++11-lang desktop-file-utils gmake gl \ USES= autoreconf compiler:c++11-lang desktop-file-utils dos2unix gmake gl pkgconfig qt:5 xorg
pkgconfig qt:5 xorg DOS2UNIX_FILES= convert.pro
USE_QT= buildtools_build core gui network qmake_build svg testlib widgets xml
GNU_CONFIGURE= yes
USE_QT= buildtools_build core gui network qmake_build testlib widgets xml
USE_XORG= x11 USE_XORG= x11
USE_GL= gl USE_GL= gl
OPTIONS_DEFINE= DEBUG FISHSOUND ID3TAG JACK LRDF MAD OGGZ OSC PORTAUDIO PULSEAUDIO GNU_CONFIGURE= yes
OPTIONS_DEFAULT= FISHSOUND ID3TAG MAD OGGZ PORTAUDIO
OPTIONS_SUB= yes OPTIONS_DEFINE= DEBUG FISHSOUND ID3TAG JACK MAD OSC PORTAUDIO PULSEAUDIO
OPTIONS_DEFAULT= FISHSOUND ID3TAG JACK MAD PORTAUDIO PULSEAUDIO
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ENABLE= debug DEBUG_CONFIGURE_ENABLE= debug
FISHSOUND_DESC= FLAC, Speex and Vorbis codecs support
FISHSOUND_CONFIGURE_WITH= fishsound FISHSOUND_CONFIGURE_WITH= fishsound
FISHSOUND_DESC= FLAC, Speex and Vorbis codecs support
FISHSOUND_LIB_DEPENDS= libfishsound.so:audio/libfishsound \ FISHSOUND_LIB_DEPENDS= libfishsound.so:audio/libfishsound \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \ libvorbis.so:audio/libvorbis \
libspeex.so:audio/speex \ libspeex.so:audio/speex \
libFLAC.so:audio/flac libFLAC.so:audio/flac
@ -49,20 +52,11 @@ ID3TAG_LIB_DEPENDS= libid3tag.so:audio/libid3tag
JACK_CONFIGURE_WITH= jack JACK_CONFIGURE_WITH= jack
JACK_LIB_DEPENDS= libjack.so:audio/jack JACK_LIB_DEPENDS= libjack.so:audio/jack
LRDF_CONFIGURE_WITH= lrdf
LRDF_DESC= Resource Description Framework support
LRDF_LIB_DEPENDS= liblrdf.so:textproc/liblrdf
MAD_CONFIGURE_WITH= mad MAD_CONFIGURE_WITH= mad
MAD_LIB_DEPENDS= libmad.so:audio/libmad MAD_LIB_DEPENDS= libmad.so:audio/libmad
OGGZ_CONFIGURE_WITH= oggz OSC_DESC= OpenSound Control support
OGGZ_DESC= Ogg container format support
OGGZ_LIB_DEPENDS= liboggz.so:audio/liboggz \
libogg.so:audio/libogg
OSC_CONFIGURE_WITH= lo OSC_CONFIGURE_WITH= lo
OSC_DESC= OpenSound Control support
OSC_LIB_DEPENDS= liblo.so:audio/liblo OSC_LIB_DEPENDS= liblo.so:audio/liblo
PORTAUDIO_CONFIGURE_WITH= portaudio PORTAUDIO_CONFIGURE_WITH= portaudio
@ -71,11 +65,16 @@ PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PULSEAUDIO_CONFIGURE_WITH= pulse PULSEAUDIO_CONFIGURE_WITH= pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
post-patch: # remove the bundled vamp-plugin-sdk to avoid possible confusion
@${RM} -r ${WRKSRC}/vamp-plugin-sdk
do-install: do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sonic-visualiser ${STAGEDIR}${PREFIX}/bin .for f in sonic-visualiser piper-vamp-simple-server piper-convert checker/vamp-plugin-load-checker
${INSTALL_DATA} ${WRKSRC}/sonic-visualiser.desktop ${STAGEDIR}${PREFIX}/share/applications ${INSTALL_PROGRAM} ${WRKSRC}/$f ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/x-sonicvisualiser.desktop ${STAGEDIR}${PREFIX}/share/applications .endfor
${INSTALL_DATA} ${WRKSRC}/x-sonicvisualiser-layer.desktop ${STAGEDIR}${PREFIX}/share/applications .for f in sonic-visualiser.desktop x-sonicvisualiser.desktop x-sonicvisualiser-layer.desktop
${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${PREFIX}/share/applications
.endfor
${INSTALL_DATA} ${WRKSRC}/icons/sv-icon.svg ${STAGEDIR}${PREFIX}/share/pixmaps ${INSTALL_DATA} ${WRKSRC}/icons/sv-icon.svg ${STAGEDIR}${PREFIX}/share/pixmaps
${MKDIR} ${STAGEDIR}${DOCSDIR} ${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${STAGEDIR}${DOCSDIR} ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${STAGEDIR}${DOCSDIR}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1487954437 TIMESTAMP = 1587060340
SHA256 (sonic-visualiser-2.5.tar.gz) = 5a66f20bae002876c64bc26d79dcba4f4c96c3c71ae160b5aafb40cfeacecdbe SHA256 (sonic-visualiser-4.0.1.tar.gz) = e6e9dbec686c9dc94d32dff311eb0f6b44b63d3643285b3d8d908dfb9b22c790
SIZE (sonic-visualiser-2.5.tar.gz) = 4112133 SIZE (sonic-visualiser-4.0.1.tar.gz) = 6649178

View file

@ -0,0 +1,22 @@
--- base.pro.orig 2020-04-16 18:47:44 UTC
+++ base.pro
@@ -25,7 +25,7 @@ exists(repoint.pri) {
}
include(bq-files.pri)
-include(vamp-plugin-sdk-files.pri)
+#include(vamp-plugin-sdk-files.pri)
include(svcore/files.pri)
include(capnp-regen.pri)
@@ -40,8 +40,8 @@ CLIENT_HEADERS=$$fromfile(piper-vamp-cpp/vamp-client/q
for (file, BQ_SOURCES) { SOURCES += $$file }
for (file, BQ_HEADERS) { HEADERS += $$file }
-for (file, VAMP_SOURCES) { SOURCES += $$file }
-for (file, VAMP_HEADERS) { HEADERS += $$file }
+#for (file, VAMP_SOURCES) { SOURCES += $$file }
+#for (file, VAMP_HEADERS) { HEADERS += $$file }
for (file, DATAQUAY_SOURCES) { SOURCES += $$sprintf("dataquay/%1", $$file) }
for (file, DATAQUAY_HEADERS) { HEADERS += $$sprintf("dataquay/%1", $$file) }

View file

@ -0,0 +1,11 @@
--- bqvec/src/VectorOpsComplex.cpp.orig 2020-04-16 18:11:58 UTC
+++ bqvec/src/VectorOpsComplex.cpp
@@ -50,6 +50,8 @@
#ifndef alloca
#define alloca _alloca
#endif
+#elif defined(__FreeBSD__)
+#include <stdlib.h>
#else
#include <alloca.h>
#endif

View file

@ -0,0 +1,11 @@
--- config.pri.in.orig 2020-04-16 19:38:03 UTC
+++ config.pri.in
@@ -17,6 +17,8 @@ CONFIG += @CXXSTANDARD@
linux*:LIBS += -L$$PWD -lbase -lasound -ldl
+LIBS += -L$$PWD -lbase -lvamp-hostsdk
+
macx*:DEFINES += HAVE_COREAUDIO
macx*:LIBS += -framework CoreAudio -framework CoreMidi -framework AudioUnit -framework AudioToolbox -framework CoreFoundation -framework CoreServices

View file

@ -1,8 +1,8 @@
--- configure.ac.orig 2015-10-22 11:26:02 UTC --- configure.ac.orig 2019-12-10 09:29:11 UTC
+++ configure.ac +++ configure.ac
@@ -99,8 +99,8 @@ SV_MODULE_OPTIONAL([fishsound],[fishsoun @@ -127,8 +127,8 @@ SV_MODULE_REQUIRED([mad],[mad >= 0.15.0],[mad.h],[mad]
SV_MODULE_OPTIONAL([mad],[mad >= 0.15.0],[mad.h],[mad],[mad_decoder_init]) SV_MODULE_REQUIRED([id3tag],[id3tag >= 0.15.0],[id3tag.h],[id3tag],[id3_tag_new])
SV_MODULE_OPTIONAL([id3tag],[id3tag >= 0.15.0],[id3tag.h],[id3tag],[id3_tag_new]) SV_MODULE_REQUIRED([opus],[opusfile],[opus/opusfile.h],[opusfile],[op_read_float])
-# Link in -lX11 if it exists -- this is for the X error handler -# Link in -lX11 if it exists -- this is for the X error handler
-SV_MODULE_OPTIONAL([X11],[x11 >= 1.0.0],[X11/X.h],[x11],[XGetErrorText]) -SV_MODULE_OPTIONAL([X11],[x11 >= 1.0.0],[X11/X.h],[x11],[XGetErrorText])
@ -11,3 +11,19 @@
AC_SUBST(PERL) AC_SUBST(PERL)
AC_SUBST(XARGS) AC_SUBST(XARGS)
@@ -154,6 +154,7 @@ AC_CONFIG_FILES([config.pri])
AC_OUTPUT
+if false; then
if test -x repoint ; then
if test -d .hg -o -d .git ; then
if ! ./repoint install; then
@@ -170,6 +171,7 @@ else
if ! test -d vamp-plugin-sdk ; then
AC_MSG_WARN([No vamp-plugin-sdk directory present, so external components might not have been updated])
fi
+fi
fi
if ! $QMAKE -r sonic-visualiser.pro; then

View file

@ -0,0 +1,26 @@
--- convert.pro.orig 2019-12-10 09:29:11 UTC
+++ convert.pro
@@ -26,17 +26,19 @@ macx*: CONFIG -= app_bundle
linux*: LIBS += -ldl
+LIBS += -lvamp-hostsdk
+
TARGET = piper-convert
OBJECTS_DIR = o
MOC_DIR = o
-INCLUDEPATH += piper-vamp-cpp piper-vamp-cpp/ext vamp-plugin-sdk
+INCLUDEPATH += piper-vamp-cpp piper-vamp-cpp/ext
-include(vamp-plugin-sdk-files.pri)
+#include(vamp-plugin-sdk-files.pri)
-for (file, VAMP_SOURCES) { SOURCES += $$file }
-for (file, VAMP_HEADERS) { HEADERS += $$file }
+#for (file, VAMP_SOURCES) { SOURCES += $$file }
+#for (file, VAMP_HEADERS) { HEADERS += $$file }
HEADERS += \
piper-vamp-cpp/vamp-capnp/piper.capnp.h \

View file

@ -0,0 +1,26 @@
--- server.pro.orig 2019-12-10 09:29:11 UTC
+++ server.pro
@@ -25,17 +25,19 @@ macx*: CONFIG -= app_bundle
linux*: LIBS += -ldl
+LIBS += -lvamp-hostsdk
+
TARGET = piper-vamp-simple-server
OBJECTS_DIR = o
MOC_DIR = o
-INCLUDEPATH += piper-vamp-cpp piper-vamp-cpp/ext vamp-plugin-sdk
+INCLUDEPATH += piper-vamp-cpp piper-vamp-cpp/ext
-include(vamp-plugin-sdk-files.pri)
+#include(vamp-plugin-sdk-files.pri)
-for (file, VAMP_SOURCES) { SOURCES += $$file }
-for (file, VAMP_HEADERS) { HEADERS += $$file }
+#for (file, VAMP_SOURCES) { SOURCES += $$file }
+#for (file, VAMP_HEADERS) { HEADERS += $$file }
HEADERS += \
piper-vamp-cpp/vamp-capnp/piper.capnp.h \

View file

@ -1,11 +1,34 @@
Disable building the tests. They prevent building sonic-visualiser in parallel. --- sonic-visualiser.pro.orig 2020-04-16 19:10:53 UTC
--- sonic-visualiser.pro.orig 2017-02-24 17:52:22 UTC
+++ sonic-visualiser.pro +++ sonic-visualiser.pro
@@ -5,7 +5,6 @@ SUBDIRS = sub_dataquay svcore svgui svap @@ -8,11 +8,11 @@ SUBDIRS += \
# We should build and run the tests on any platform, # writing they are only automatically run on non-Windows platforms
# but doing it automatically doesn't work so well from # (because of the difficulty of getting them running nicely in the
# within an IDE on Windows, so remove that from here # IDE without causing great confusion if a test fails).
- SUBDIRS += svcore/base/test svcore/data/fileio/test svcore/data/model/test -SUBDIRS += \
} - sub_test_svcore_base \
- sub_test_svcore_system \
- sub_test_svcore_data_fileio \
- sub_test_svcore_data_model
+#SUBDIRS += \
+# sub_test_svcore_base \
+# sub_test_svcore_system \
+# sub_test_svcore_data_fileio \
+# sub_test_svcore_data_model
sub_sv.file = sv.pro SUBDIRS += \
checker \
@@ -22,10 +22,10 @@ SUBDIRS += \
sub_base.file = base.pro
-sub_test_svcore_base.file = test-svcore-base.pro
-sub_test_svcore_system.file = test-svcore-system.pro
-sub_test_svcore_data_fileio.file = test-svcore-data-fileio.pro
-sub_test_svcore_data_model.file = test-svcore-data-model.pro
+#sub_test_svcore_base.file = test-svcore-base.pro
+#sub_test_svcore_system.file = test-svcore-system.pro
+#sub_test_svcore_data_fileio.file = test-svcore-data-fileio.pro
+#sub_test_svcore_data_model.file = test-svcore-data-model.pro
sub_server.file = server.pro
sub_convert.file = convert.pro

View file

@ -1,10 +1,10 @@
--- sv.pro.orig 2015-10-22 11:26:02 UTC --- sv.pro.orig 2019-12-10 09:29:11 UTC
+++ sv.pro +++ sv.pro
@@ -41,6 +41,7 @@ QT += network xml gui widgets @@ -15,6 +15,7 @@ QT += network xml gui widgets svg
TARGET = "Sonic Visualiser" TARGET = "Sonic Visualiser"
linux*:TARGET = sonic-visualiser linux*:TARGET = sonic-visualiser
+freebsd*:TARGET = sonic-visualiser +freebsd*:TARGET = sonic-visualiser
solaris*:TARGET = sonic-visualiser solaris*:TARGET = sonic-visualiser
DEPENDPATH += . svcore svgui svapp !win32 {

View file

@ -1,11 +0,0 @@
--- svapp/audioio/AudioJACKTarget.cpp.orig 2015-10-22 11:26:02 UTC
+++ svapp/audioio/AudioJACKTarget.cpp
@@ -21,8 +21,6 @@
#include <iostream>
#include <cmath>
-#include <alloca.h>
-
//#define DEBUG_AUDIO_JACK_TARGET 1
#ifdef BUILD_STATIC

View file

@ -1,11 +0,0 @@
--- svcore/base/RealTime.cpp.orig 2015-10-22 11:26:02 UTC
+++ svcore/base/RealTime.cpp
@@ -105,7 +105,7 @@ RealTime::fromXsdDuration(std::string xs
char *eptr = 0;
if (isdigit(s[i]) || s[i] == '.') {
- value = strtod(&s[i], &eptr);
+ value = strtod_l(&s[i], &eptr, NULL);
i = int(eptr - s);
}

View file

@ -6,4 +6,4 @@ and spectograms in a straightforward way. The audio data can be
annotated and played back featuring time streching. Furthermore it annotated and played back featuring time streching. Furthermore it
can be extended by third-party vamp plugins for feature extraction. can be extended by third-party vamp plugins for feature extraction.
WWW: http://www.sonicvisualiser.org/ WWW: https://www.sonicvisualiser.org/

View file

@ -1,4 +1,7 @@
bin/piper-convert
bin/piper-vamp-simple-server
bin/sonic-visualiser bin/sonic-visualiser
bin/vamp-plugin-load-checker
share/applications/sonic-visualiser.desktop share/applications/sonic-visualiser.desktop
share/applications/x-sonicvisualiser.desktop share/applications/x-sonicvisualiser.desktop
share/applications/x-sonicvisualiser-layer.desktop share/applications/x-sonicvisualiser-layer.desktop