- add new port: security/qtkeychain
QtKeychain is a Qt API to store passwords and other secret data securely.How the data is stored depends on the platform. For Linux/Unix, KWallet (via D-Bus) is used. Support for the GNOME Keyring via freedesktop.org's Secret Storage D-Bus specification is planned but not yet implemented. WWW: https://github.com/frankosterfeld/qtkeychain PR: 177634 Submitted by: 6yearold@gmail.com Feature safe: yes
This commit is contained in:
parent
3d560094c7
commit
3b2488db11
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315930
6 changed files with 57 additions and 0 deletions
|
@ -801,6 +801,7 @@
|
|||
SUBDIR += qca-ossl
|
||||
SUBDIR += qca-tls
|
||||
SUBDIR += qtfw
|
||||
SUBDIR += qtkeychain
|
||||
SUBDIR += quantis
|
||||
SUBDIR += quantis-kmod
|
||||
SUBDIR += racoon2
|
||||
|
|
24
security/qtkeychain/Makefile
Normal file
24
security/qtkeychain/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= qtkeychain
|
||||
PORTVERSION= 0.1.0
|
||||
CATEGORIES= security
|
||||
|
||||
MAINTAINER= 6yearold@gmail.com
|
||||
COMMENT= Platform independent Qt API for storing passwords
|
||||
|
||||
LICENSE= BSD
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= frankosterfeld
|
||||
GH_TAGNAME= v${PORTVERSION}
|
||||
GH_COMMIT= bb32e45
|
||||
|
||||
USES= cmake
|
||||
USE_QT4= corelib dbus moc_build qmake_build rcc_build
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
security/qtkeychain/distinfo
Normal file
2
security/qtkeychain/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (qtkeychain-0.1.0.tar.gz) = cf4fa0e9063d6df54c191e361566f5b6e5d3a5867fc0d9ab96954af393c939ef
|
||||
SIZE (qtkeychain-0.1.0.tar.gz) = 12834
|
11
security/qtkeychain/files/patch-auto_ptr.h
Normal file
11
security/qtkeychain/files/patch-auto_ptr.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- _keychain_dbus.cpp 2013-03-25 20:32:44.801564594 +0400
|
||||
+++ keychain_dbus.cpp 2013-03-25 20:32:49.811561714 +0400
|
||||
@@ -10,7 +10,7 @@
|
||||
|
||||
#include <QSettings>
|
||||
|
||||
-#include <auto_ptr.h>
|
||||
+#include <memory>
|
||||
|
||||
using namespace QKeychain;
|
||||
|
7
security/qtkeychain/pkg-descr
Normal file
7
security/qtkeychain/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
QtKeychain is a Qt API to store passwords and other secret data securely.How
|
||||
the data is stored depends on the platform.
|
||||
For Linux/Unix, KWallet (via D-Bus) is used. Support for the GNOME Keyring
|
||||
via freedesktop.org's Secret Storage D-Bus specification is planned
|
||||
but not yet implemented.
|
||||
|
||||
WWW: https://github.com/frankosterfeld/qtkeychain
|
12
security/qtkeychain/pkg-plist
Normal file
12
security/qtkeychain/pkg-plist
Normal file
|
@ -0,0 +1,12 @@
|
|||
include/qtkeychain/keychain.h
|
||||
include/qtkeychain/qkeychain_export.h
|
||||
lib/cmake/QtKeychain/QtKeychainConfig.cmake
|
||||
lib/cmake/QtKeychain/QtKeychainConfigVersion.cmake
|
||||
lib/cmake/QtKeychain/QtKeychainLibraryDepends-release.cmake
|
||||
lib/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
|
||||
lib/libqtkeychain.so
|
||||
lib/libqtkeychain.so.0
|
||||
lib/libqtkeychain.so.0.1.0
|
||||
@dirrm lib/cmake/QtKeychain
|
||||
@dirrmtry lib/cmake
|
||||
@dirrm include/qtkeychain
|
Loading…
Reference in a new issue