Unbreak editor/zed

Noticed by: bento
This commit is contained in:
Edwin Groothuis 2002-11-17 11:40:31 +00:00
parent f43ffbc9f4
commit 3b2b3411ff
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70302
3 changed files with 30 additions and 10 deletions

View file

@ -12,13 +12,7 @@ MASTER_SITES= http://zed.c3po.it/
MAINTAINER= exile@chamber.ee
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500035
BROKEN= "Does not compile on 5.0"
.endif
post-install:
@${STRIP_CMD} ${PREFIX}/bin/zed
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,5 +1,5 @@
--- Makefile Tue Jun 4 15:01:04 2002
+++ Makefile Tue Jun 4 16:26:14 2002
--- Makefile.orig Wed Apr 5 19:49:16 2000
+++ Makefile Sun Nov 17 22:41:13 2002
@@ -5,7 +5,7 @@
PREFIX=/usr/local
@ -9,7 +9,7 @@
# i486 Linux
#CFLAGS=-pipe -Wall -fomit-frame-pointer -m486 -O2
@@ -16,7 +16,7 @@
@@ -16,18 +16,18 @@
#CFLAGS=-pipe -Wall -mpa-risc-1-1 -O2
# RS6000 AIX
@ -18,6 +18,19 @@
# Sun
#ILIBS=-lm
#IXLIBS=-lm
#CFLAGS=-pipe -Wall -O2 -msupersparc
-COMPILER=gcc
+COMPILER=${CXX}
# someone needs this:
#COMPILER=g++
-LINKER=gcc
+LINKER=${CXX}
###############################################
@@ -45,7 +45,7 @@
###############################################

View file

@ -0,0 +1,13 @@
--- zed.h.orig Sun Nov 17 22:35:46 2002
+++ zed.h Sun Nov 17 22:35:09 2002
@@ -123,8 +123,8 @@
int lung;
char dati[0]; // puntatore ai dati
- friend editor; // solo pero' all'interno di ZED.H
- friend list;
+ friend class editor; // solo pero' all'interno di ZED.H
+ friend class list;
};
protected: