Update to 0.2.0
Approved by: maintainer
This commit is contained in:
parent
db5b2ce0c6
commit
3b4c1d8a37
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133761
7 changed files with 99 additions and 15 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= nzbget
|
||||
PORTVERSION= 0.1.1
|
||||
PORTVERSION= 0.2.0
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= nzbget
|
||||
|
@ -23,11 +23,12 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
|
|||
LOCALBASE="${LOCALBASE}"
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
|
||||
PLIST_FILES= bin/nzbget etc/nzbget.cfg.example
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/bin/nzbget|${PREFIX}/bin/nzbget|' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/nzbget.cfg.example ${PREFIX}/etc
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (nzbget-0.1.1.tar.gz) = a653120fac3dde326e0305fb4a1fb27d
|
||||
SIZE (nzbget-0.1.1.tar.gz) = 82928
|
||||
MD5 (nzbget-0.2.0.tar.gz) = 4e51fb8461b651bf14b1b3f52003a43e
|
||||
SIZE (nzbget-0.2.0.tar.gz) = 377173
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ArticleDownloader.cpp.orig Fri Apr 2 18:55:19 2004
|
||||
+++ ArticleDownloader.cpp Sat Apr 17 22:57:09 2004
|
||||
@@ -27,6 +27,8 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
+#include <unistd.h>
|
||||
+
|
||||
#include "ArticleDownloader.h"
|
||||
#include "Decoder.h"
|
||||
#include "global.h"
|
10
news/nzbget/files/patch-Coordinator.cpp
Normal file
10
news/nzbget/files/patch-Coordinator.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Coordinator.cpp~ Wed Feb 23 09:05:23 2005
|
||||
+++ Coordinator.cpp Fri Apr 15 15:41:42 2005
|
||||
@@ -28,6 +28,7 @@
|
||||
#endif
|
||||
|
||||
#include <unistd.h>
|
||||
+#include <libgen.h>
|
||||
|
||||
#include "global.h"
|
||||
#include "Coordinator.h"
|
55
news/nzbget/files/patch-Makefile.in
Normal file
55
news/nzbget/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,55 @@
|
|||
--- Makefile.in.orig Sun Feb 27 12:59:05 2005
|
||||
+++ Makefile.in Fri Apr 15 16:31:02 2005
|
||||
@@ -19,8 +19,8 @@
|
||||
CP = @CP@
|
||||
CFLAGS = @CFLAGS@
|
||||
DEFS = @DEFS@ -DVERSION=\"$(VERSION)\"
|
||||
-CPPFLAGS = -I./uulib @CPPFLAGS@
|
||||
-LDFLAGS = -L./uulib @LDFLAGS@
|
||||
+CPPFLAGS = @CPPFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@
|
||||
LIBS = -luu -lncurses @LIBS@
|
||||
INSTALL = @INSTALL@
|
||||
|
||||
@@ -94,19 +94,14 @@
|
||||
|
||||
# Executable programmes
|
||||
#
|
||||
-nzbget: $(OBJECTS) nzbget.o ./uulib/libuu.a
|
||||
+nzbget: $(OBJECTS) nzbget.o
|
||||
$(CXX) $(CFLAGS) -o $@ $(OBJECTS) nzbget.o $(LDFLAGS) $(LIBS)
|
||||
@echo "Build succeeded."
|
||||
|
||||
-./uulib/libuu.a:
|
||||
- make -C uulib
|
||||
-
|
||||
clean:
|
||||
- -cd ./uulib && make clean && cd ..
|
||||
-$(RM) -f *.o $(PROGRAMS) .depend libuu.a
|
||||
|
||||
distclean: clean
|
||||
- -cd ./uulib && make distclean && cd ..
|
||||
-$(RM) -f Makefile config.status config.log config.h .depend
|
||||
|
||||
|
||||
@@ -123,17 +118,15 @@
|
||||
|
||||
distrib:
|
||||
$(MKDIR) nzbget-$(VERSION)
|
||||
- $(MKDIR) nzbget-$(VERSION)/uulib
|
||||
$(CP) -av $(DISTFILES) nzbget-$(VERSION)
|
||||
- $(CP) -av $(UUDISTFILES) nzbget-$(VERSION)/uulib
|
||||
cd nzbget-$(VERSION) && ./configure
|
||||
- cd nzbget-$(VERSION) && make
|
||||
- cd nzbget-$(VERSION) && make distclean
|
||||
+ cd nzbget-$(VERSION) && ${MAKE}
|
||||
+ cd nzbget-$(VERSION) && ${MAKE} distclean
|
||||
tar -czf nzbget-$(VERSION).tar.gz nzbget-$(VERSION)
|
||||
$(RM) -r nzbget-$(VERSION)
|
||||
|
||||
install: nzbget
|
||||
- $(INSTALL) nzbget /usr/bin/nzbget
|
||||
+ $(INSTALL) nzbget ${PREFIX}/bin/nzbget
|
||||
|
||||
|
||||
-include .depend
|
19
news/nzbget/files/patch-NCursesFrontend.cpp
Normal file
19
news/nzbget/files/patch-NCursesFrontend.cpp
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- NCursesFrontend.cpp~ Wed Feb 23 09:05:23 2005
|
||||
+++ NCursesFrontend.cpp Fri Apr 15 15:43:27 2005
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <unistd.h>
|
||||
#include <stdarg.h>
|
||||
#include <signal.h>
|
||||
+#include <libgen.h>
|
||||
|
||||
#include "NCursesFrontend.h"
|
||||
|
||||
@@ -342,7 +343,7 @@
|
||||
NCURSES_COLORPAIR_DEBUG};
|
||||
|
||||
NCOLORON( iMessageTypeColor[Msg.m_eType] );
|
||||
- mvprintw( iRow, 0, szMessageType[ Msg.m_eType ] );
|
||||
+ mvprintw( iRow, 0, (char *)szMessageType[ Msg.m_eType ] );
|
||||
NCOLOROFF( iMessageTypeColor[Msg.m_eType] );
|
||||
|
||||
char szBuffer[512];
|
10
news/nzbget/files/patch-NZBQueue.cpp
Normal file
10
news/nzbget/files/patch-NZBQueue.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- NZBQueue.cpp~ Wed Feb 23 09:05:23 2005
|
||||
+++ NZBQueue.cpp Fri Apr 15 15:40:41 2005
|
||||
@@ -26,6 +26,7 @@
|
||||
#ifdef HAVE_CONFIG_H
|
||||
#include <config.h>
|
||||
#endif
|
||||
+#include <libgen.h>
|
||||
|
||||
#include "NZBQueue.h"
|
||||
#include "global.h"
|
Loading…
Reference in a new issue