- Upgrade to version 1.0.0.
- Replace PKGNAMESUFFIX with PKGNAMEPREFIX.
This commit is contained in:
parent
5e0ae7774e
commit
3b57b1103f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325353
4 changed files with 1519 additions and 473 deletions
|
@ -2,10 +2,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ipython
|
||||
PORTVERSION= 0.13.2
|
||||
PORTVERSION= 1.0.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= olgeni@FreeBSD.org
|
||||
COMMENT= An enhanced Interactive Python shell
|
||||
|
@ -35,16 +35,17 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-
|
|||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MHTML_NOTEBOOK}
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.0:${PORTSDIR}/www/py-tornado
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.0:${PORTSDIR}/www/py-tornado \
|
||||
${PYTHON_PKGNAMEPREFIX}Jinja2>=0:${PORTSDIR}/devel/py-Jinja2
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MZMQ}
|
||||
.if ${PORT_OPTIONS:MZMQ} || ${PORT_OPTIONS:MHTML_NOTEBOOK}
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.4:${PORTSDIR}/devel/py-pyzmq
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if ! ${PORT_OPTIONS:MEXAMPLES}
|
||||
${REINPLACE_CMD} -e "s# + example_files##g" ${WRKSRC}/setupbase.py
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (ipython-0.13.2.tar.gz) = 17fbeea1dff2318d617d90fdf7af4eb35dc48c61389a2dffaab8ff100fb100ea
|
||||
SIZE (ipython-0.13.2.tar.gz) = 5982733
|
||||
SHA256 (ipython-1.0.0.tar.gz) = 0d07521b4784e1b1f676b4b32c1f708a026cf398a0e6c3f095fce41f1402911c
|
||||
SIZE (ipython-1.0.0.tar.gz) = 8658118
|
||||
|
|
|
@ -3,26 +3,16 @@ $FreeBSD$
|
|||
|
||||
--- setupbase.py.orig
|
||||
+++ setupbase.py
|
||||
@@ -201,7 +201,8 @@
|
||||
@@ -208,7 +208,7 @@
|
||||
"""
|
||||
|
||||
docdirbase = pjoin('share', 'doc', 'ipython')
|
||||
- manpagebase = pjoin('share', 'man', 'man1')
|
||||
+ manpagebase = pjoin('man', 'man1')
|
||||
+ examplebase = pjoin('share', 'examples', 'ipython')
|
||||
|
||||
# Simple file lists can be made by hand
|
||||
manpages = [f for f in glob(pjoin('docs','man','*.1.gz')) if isfile(f)]
|
||||
@@ -215,7 +216,7 @@
|
||||
example_files = make_dir_struct(
|
||||
'data',
|
||||
pjoin('docs','examples'),
|
||||
- pjoin(docdirbase,'examples')
|
||||
+ pjoin(examplebase)
|
||||
)
|
||||
manual_files = make_dir_struct(
|
||||
'data',
|
||||
@@ -225,7 +226,6 @@
|
||||
@@ -232,7 +232,6 @@
|
||||
|
||||
# And assemble the entire output list
|
||||
data_files = [ (manpagebase, manpages),
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue