Add an llvm snapshot port including clang. The current snapshot is as of
2008-08-05.
This commit is contained in:
parent
c317d29df2
commit
3b5949bbb7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218773
6 changed files with 601 additions and 0 deletions
|
@ -738,6 +738,7 @@
|
|||
SUBDIR += linxt
|
||||
SUBDIR += lion
|
||||
SUBDIR += llvm
|
||||
SUBDIR += llvm-devel
|
||||
SUBDIR += lndir
|
||||
SUBDIR += log4c
|
||||
SUBDIR += log4cplus
|
||||
|
|
87
devel/llvm-devel/Makefile
Normal file
87
devel/llvm-devel/Makefile
Normal file
|
@ -0,0 +1,87 @@
|
|||
# New ports collection makefile for: llvm
|
||||
# Date created: 20 Nov 2005
|
||||
# Whom: Hye-Shik Chang
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= llvm
|
||||
DISTVERSION= 2.4.snap${SNAPDATE}
|
||||
CATEGORIES= devel lang
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= brooks
|
||||
PKGNAMESUFFIX= -devel
|
||||
|
||||
MAINTAINER= brooks@FreeBSD.org
|
||||
COMMENT= Low Level Virtual Machine
|
||||
|
||||
.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
|
||||
BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
|
||||
.endif
|
||||
.if defined(MAINTAINER_MODE)
|
||||
BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
|
||||
.endif
|
||||
|
||||
.if defined(BOOTSTRAP)
|
||||
SVN_SNAPDATE!= date -v-1d +%Y-%m-%d
|
||||
.else
|
||||
SVN_SNAPDATE= 2008-08-05
|
||||
.endif
|
||||
|
||||
SNAPDATE= ${SVN_SNAPDATE:S/-//g}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
USE_PERL5_BUILD=yes
|
||||
|
||||
.if defined(MAINTAINER_MODE)
|
||||
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --enable-optimized
|
||||
.endif
|
||||
|
||||
MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
|
||||
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
|
||||
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
|
||||
llvm-prof.1 llvm-ranlib.1 llvmgcc.1 \
|
||||
llvmgxx.1 opt.1 tblgen.1
|
||||
|
||||
.if defined(BOOTSTRAP)
|
||||
FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
|
||||
|
||||
do-fetch:
|
||||
${MKDIR} ${WRKDIR}
|
||||
svn export http://llvm.org/svn/llvm-project/llvm/trunk ${WRKSRC}
|
||||
svn export http://llvm.org/svn/llvm-project/cfe/trunk ${WRKSRC}/tools/clang
|
||||
cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
|
||||
${WRKSRC}/Makefile.config.in
|
||||
${REINPLACE_CMD} -e 's,\(PROJ_mandir.*:=\).*$$,\1${MANPREFIX}/man,g' \
|
||||
${WRKSRC}/Makefile.config.in
|
||||
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
|
||||
${WRKSRC}/tools/clang/utils/scan-build
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/tools/clang; ${GMAKE}
|
||||
|
||||
post-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/Release/bin/clang ${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/ccc \
|
||||
${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/ccc-analyzer \
|
||||
${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/scan-build \
|
||||
${PREFIX}/bin
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/tools/clang/utils/sorttable.js ${DATADIR}
|
||||
@${RM} ${PREFIX}/bin/.dir \
|
||||
${PREFIX}/lib/.dir
|
||||
|
||||
regression-test: ${BUILD_COOKIE}
|
||||
(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/llvm-devel/distinfo
Normal file
3
devel/llvm-devel/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (llvm-2.4.snap20080805.tar.bz2) = 55961fd6c07054445eb7be08a6326b73
|
||||
SHA256 (llvm-2.4.snap20080805.tar.bz2) = 4451deae1ca92098e5806adcec5103e4301b07e4295d6a29b91fe04bd748e258
|
||||
SIZE (llvm-2.4.snap20080805.tar.bz2) = 6018013
|
17
devel/llvm-devel/files/patch-tools_clang_utils_scan-build
Normal file
17
devel/llvm-devel/files/patch-tools_clang_utils_scan-build
Normal file
|
@ -0,0 +1,17 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- tools/clang/utils/scan-build.orig
|
||||
+++ tools/clang/utils/scan-build
|
||||
@@ -360,9 +360,9 @@
|
||||
my $Dir = shift;
|
||||
|
||||
DieDiag("Cannot find 'sorttable.js'.\n")
|
||||
- if (! -r "$RealBin/sorttable.js");
|
||||
+ if (! -r "%%DATADIR%%/sorttable.js");
|
||||
|
||||
- system ("cp", "$RealBin/sorttable.js", "$Dir");
|
||||
+ system ("cp", "%%DATADIR%%/sorttable.js", "$Dir");
|
||||
|
||||
DieDiag("Could not copy 'sorttable.js' to '$Dir'.\n")
|
||||
if (! -r "$Dir/sorttable.js");
|
10
devel/llvm-devel/pkg-descr
Normal file
10
devel/llvm-devel/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
Low Level Virtual Machine (LLVM) is:
|
||||
- A compilation strategy designed to enable effective program
|
||||
optimization across the entire lifetime of a program.
|
||||
- A virtual instruction set.
|
||||
- A compiler infrastructure.
|
||||
- LLVM does not imply things that you would expect from a high-level
|
||||
virtual machine. It does not require garbage collection or run-time
|
||||
code generation.
|
||||
|
||||
WWW: http://llvm.cs.uiuc.edu/
|
483
devel/llvm-devel/pkg-plist
Normal file
483
devel/llvm-devel/pkg-plist
Normal file
|
@ -0,0 +1,483 @@
|
|||
bin/bugpoint
|
||||
bin/ccc
|
||||
bin/ccc-analyzer
|
||||
bin/clang
|
||||
bin/gccas
|
||||
bin/gccld
|
||||
bin/llc
|
||||
bin/lli
|
||||
bin/llvmc2
|
||||
bin/llvm-ar
|
||||
bin/llvm-as
|
||||
bin/llvm-bcanalyzer
|
||||
bin/llvm-config
|
||||
bin/llvm-db
|
||||
bin/llvm-dis
|
||||
bin/llvm-extract
|
||||
bin/llvm-ld
|
||||
bin/llvm-link
|
||||
bin/llvm-nm
|
||||
bin/llvm-prof
|
||||
bin/llvm-ranlib
|
||||
bin/llvm-stub
|
||||
bin/opt
|
||||
bin/scan-build
|
||||
include/llvm-c/Analysis.h
|
||||
include/llvm-c/BitReader.h
|
||||
include/llvm-c/BitWriter.h
|
||||
include/llvm-c/Core.h
|
||||
include/llvm-c/ExecutionEngine.h
|
||||
include/llvm-c/LinkTimeOptimizer.h
|
||||
include/llvm-c/Transforms/Scalar.h
|
||||
include/llvm-c/Target.h
|
||||
include/llvm-c/lto.h
|
||||
include/llvm/ADT/APFloat.h
|
||||
include/llvm/ADT/APInt.h
|
||||
include/llvm/ADT/APSInt.h
|
||||
include/llvm/ADT/BitVector.h
|
||||
include/llvm/ADT/DenseMap.h
|
||||
include/llvm/ADT/DenseSet.h
|
||||
include/llvm/ADT/DepthFirstIterator.h
|
||||
include/llvm/ADT/EquivalenceClasses.h
|
||||
include/llvm/ADT/FoldingSet.h
|
||||
include/llvm/ADT/GraphTraits.h
|
||||
include/llvm/ADT/HashExtras.h
|
||||
include/llvm/ADT/ImmutableList.h
|
||||
include/llvm/ADT/ImmutableMap.h
|
||||
include/llvm/ADT/ImmutableSet.h
|
||||
include/llvm/ADT/IndexedMap.h
|
||||
include/llvm/ADT/IntrusiveRefCntPtr.h
|
||||
include/llvm/ADT/OwningPtr.h
|
||||
include/llvm/ADT/PostOrderIterator.h
|
||||
include/llvm/ADT/PriorityQueue.h
|
||||
include/llvm/ADT/ScopedHashTable.h
|
||||
include/llvm/ADT/SCCIterator.h
|
||||
include/llvm/ADT/STLExtras.h
|
||||
include/llvm/ADT/SetOperations.h
|
||||
include/llvm/ADT/SetVector.h
|
||||
include/llvm/ADT/SmallPtrSet.h
|
||||
include/llvm/ADT/SmallSet.h
|
||||
include/llvm/ADT/SmallString.h
|
||||
include/llvm/ADT/SmallVector.h
|
||||
include/llvm/ADT/SparseBitVector.h
|
||||
include/llvm/ADT/Statistic.h
|
||||
include/llvm/ADT/StringExtras.h
|
||||
include/llvm/ADT/StringMap.h
|
||||
include/llvm/ADT/StringSet.h
|
||||
include/llvm/ADT/Tree.h
|
||||
include/llvm/ADT/Trie.h
|
||||
include/llvm/ADT/UniqueVector.h
|
||||
include/llvm/ADT/VectorExtras.h
|
||||
include/llvm/ADT/hash_map.h
|
||||
include/llvm/ADT/hash_set.h
|
||||
include/llvm/ADT/ilist.h
|
||||
include/llvm/ADT/ilist_node.h
|
||||
include/llvm/ADT/iterator.h
|
||||
include/llvm/ADT/iterator
|
||||
include/llvm/AbstractTypeUser.h
|
||||
include/llvm/Analysis/AliasAnalysis.h
|
||||
include/llvm/Analysis/AliasSetTracker.h
|
||||
include/llvm/Analysis/CFGPrinter.h
|
||||
include/llvm/Analysis/CallGraph.h
|
||||
include/llvm/Analysis/ConstantFolding.h
|
||||
include/llvm/Analysis/ConstantsScanner.h
|
||||
include/llvm/Analysis/DominatorInternals.h
|
||||
include/llvm/Analysis/Dominators.h
|
||||
include/llvm/Analysis/FindUsedTypes.h
|
||||
include/llvm/Analysis/Interval.h
|
||||
include/llvm/Analysis/IntervalIterator.h
|
||||
include/llvm/Analysis/IntervalPartition.h
|
||||
include/llvm/Analysis/LibCallAliasAnalysis.h
|
||||
include/llvm/Analysis/LibCallSemantics.h
|
||||
include/llvm/Analysis/LoadValueNumbering.h
|
||||
include/llvm/Analysis/LoopInfo.h
|
||||
include/llvm/Analysis/LoopPass.h
|
||||
include/llvm/Analysis/LoopVR.h
|
||||
include/llvm/Analysis/MemoryDependenceAnalysis.h
|
||||
include/llvm/Analysis/Passes.h
|
||||
include/llvm/Analysis/PostDominators.h
|
||||
include/llvm/Analysis/ProfileInfo.h
|
||||
include/llvm/Analysis/ProfileInfoLoader.h
|
||||
include/llvm/Analysis/ProfileInfoTypes.h
|
||||
include/llvm/Analysis/ScalarEvolution.h
|
||||
include/llvm/Analysis/ScalarEvolutionExpander.h
|
||||
include/llvm/Analysis/ScalarEvolutionExpressions.h
|
||||
include/llvm/Analysis/SparsePropagation.h
|
||||
include/llvm/Analysis/Trace.h
|
||||
include/llvm/Analysis/ValueNumbering.h
|
||||
include/llvm/Analysis/ValueTracking.h
|
||||
include/llvm/Analysis/Verifier.h
|
||||
include/llvm/Argument.h
|
||||
include/llvm/Assembly/AsmAnnotationWriter.h
|
||||
include/llvm/Assembly/Parser.h
|
||||
include/llvm/Assembly/PrintModulePass.h
|
||||
include/llvm/Assembly/Writer.h
|
||||
include/llvm/AutoUpgrade.h
|
||||
include/llvm/BasicBlock.h
|
||||
include/llvm/Bitcode/Archive.h
|
||||
include/llvm/Bitcode/BitCodes.h
|
||||
include/llvm/Bitcode/BitstreamReader.h
|
||||
include/llvm/Bitcode/BitstreamWriter.h
|
||||
include/llvm/Bitcode/Deserialize.h
|
||||
include/llvm/Bitcode/LLVMBitCodes.h
|
||||
include/llvm/Bitcode/ReaderWriter.h
|
||||
include/llvm/Bitcode/Serialization.h
|
||||
include/llvm/Bitcode/SerializationFwd.h
|
||||
include/llvm/Bitcode/Serialize.h
|
||||
include/llvm/CallGraphSCCPass.h
|
||||
include/llvm/CallingConv.h
|
||||
include/llvm/CodeGen/AsmPrinter.h
|
||||
include/llvm/CodeGen/BreakCriticalMachineEdge.h
|
||||
include/llvm/CodeGen/CallingConvLower.h
|
||||
include/llvm/CodeGen/Collector.h
|
||||
include/llvm/CodeGen/CollectorMetadata.h
|
||||
include/llvm/CodeGen/Collectors.h
|
||||
include/llvm/CodeGen/DAGISelHeader.h
|
||||
include/llvm/CodeGen/DwarfWriter.h
|
||||
include/llvm/CodeGen/ELFRelocation.h
|
||||
include/llvm/CodeGen/FileWriters.h
|
||||
include/llvm/CodeGen/IntrinsicLowering.h
|
||||
include/llvm/CodeGen/LinkAllCodegenComponents.h
|
||||
include/llvm/CodeGen/LiveInterval.h
|
||||
include/llvm/CodeGen/LiveIntervalAnalysis.h
|
||||
include/llvm/CodeGen/LiveStackAnalysis.h
|
||||
include/llvm/CodeGen/LiveVariables.h
|
||||
include/llvm/CodeGen/MachORelocation.h
|
||||
include/llvm/CodeGen/MachineBasicBlock.h
|
||||
include/llvm/CodeGen/MachineCodeEmitter.h
|
||||
include/llvm/CodeGen/MachineConstantPool.h
|
||||
include/llvm/CodeGen/MachineDominators.h
|
||||
include/llvm/CodeGen/MachineFrameInfo.h
|
||||
include/llvm/CodeGen/MachineFunction.h
|
||||
include/llvm/CodeGen/MachineFunctionPass.h
|
||||
include/llvm/CodeGen/MachineInstr.h
|
||||
include/llvm/CodeGen/MachineInstrBuilder.h
|
||||
include/llvm/CodeGen/MachineJumpTableInfo.h
|
||||
include/llvm/CodeGen/MachineLocation.h
|
||||
include/llvm/CodeGen/MachineLoopInfo.h
|
||||
include/llvm/CodeGen/MachineMemOperand.h
|
||||
include/llvm/CodeGen/MachineModuleInfo.h
|
||||
include/llvm/CodeGen/MachineOperand.h
|
||||
include/llvm/CodeGen/MachinePassRegistry.h
|
||||
include/llvm/CodeGen/MachineRegisterInfo.h
|
||||
include/llvm/CodeGen/MachineRelocation.h
|
||||
include/llvm/CodeGen/Passes.h
|
||||
include/llvm/CodeGen/PseudoSourceValue.h
|
||||
include/llvm/CodeGen/RegAllocRegistry.h
|
||||
include/llvm/CodeGen/RegisterCoalescer.h
|
||||
include/llvm/CodeGen/RegisterScavenging.h
|
||||
include/llvm/CodeGen/RuntimeLibcalls.h
|
||||
include/llvm/CodeGen/ScheduleDAG.h
|
||||
include/llvm/CodeGen/SchedulerRegistry.h
|
||||
include/llvm/CodeGen/SelectionDAG.h
|
||||
include/llvm/CodeGen/SelectionDAGISel.h
|
||||
include/llvm/CodeGen/SelectionDAGNodes.h
|
||||
include/llvm/CodeGen/ValueTypes.h
|
||||
include/llvm/CodeGen/ValueTypes.td
|
||||
include/llvm/Config/alloca.h
|
||||
include/llvm/Config/config.h
|
||||
include/llvm/Constant.h
|
||||
include/llvm/Constants.h
|
||||
include/llvm/Debugger/Debugger.h
|
||||
include/llvm/Debugger/InferiorProcess.h
|
||||
include/llvm/Debugger/ProgramInfo.h
|
||||
include/llvm/Debugger/RuntimeInfo.h
|
||||
include/llvm/Debugger/SourceFile.h
|
||||
include/llvm/Debugger/SourceLanguage.h
|
||||
include/llvm/DerivedTypes.h
|
||||
include/llvm/ExecutionEngine/ExecutionEngine.h
|
||||
include/llvm/ExecutionEngine/GenericValue.h
|
||||
include/llvm/ExecutionEngine/Interpreter.h
|
||||
include/llvm/ExecutionEngine/JIT.h
|
||||
include/llvm/ExecutionEngine/JITMemoryManager.h
|
||||
include/llvm/Function.h
|
||||
include/llvm/GlobalAlias.h
|
||||
include/llvm/GlobalValue.h
|
||||
include/llvm/GlobalVariable.h
|
||||
include/llvm/InlineAsm.h
|
||||
include/llvm/InstrTypes.h
|
||||
include/llvm/Instruction.def
|
||||
include/llvm/Instruction.h
|
||||
include/llvm/Instructions.h
|
||||
include/llvm/IntrinsicInst.h
|
||||
include/llvm/Intrinsics.gen
|
||||
include/llvm/Intrinsics.h
|
||||
include/llvm/Intrinsics.td
|
||||
include/llvm/IntrinsicsARM.td
|
||||
include/llvm/IntrinsicsCellSPU.td
|
||||
include/llvm/IntrinsicsPowerPC.td
|
||||
include/llvm/IntrinsicsX86.td
|
||||
include/llvm/LinkAllPasses.h
|
||||
include/llvm/LinkAllVMCore.h
|
||||
include/llvm/Linker.h
|
||||
include/llvm/Module.h
|
||||
include/llvm/ModuleProvider.h
|
||||
include/llvm/OperandTraits.h
|
||||
include/llvm/ParameterAttributes.h
|
||||
include/llvm/Pass.h
|
||||
include/llvm/PassAnalysisSupport.h
|
||||
include/llvm/PassManager.h
|
||||
include/llvm/PassManagers.h
|
||||
include/llvm/PassSupport.h
|
||||
include/llvm/Support/AIXDataTypesFix.h
|
||||
include/llvm/Support/AlignOf.h
|
||||
include/llvm/Support/Allocator.h
|
||||
include/llvm/Support/Annotation.h
|
||||
include/llvm/Support/CFG.h
|
||||
include/llvm/Support/CallSite.h
|
||||
include/llvm/Support/Casting.h
|
||||
include/llvm/Support/CommandLine.h
|
||||
include/llvm/Support/Compiler.h
|
||||
include/llvm/Support/ConstantRange.h
|
||||
include/llvm/Support/DOTGraphTraits.h
|
||||
include/llvm/Support/DataFlow.h
|
||||
include/llvm/Support/DataTypes.h
|
||||
include/llvm/Support/Debug.h
|
||||
include/llvm/Support/Dwarf.h
|
||||
include/llvm/Support/DynamicLinker.h
|
||||
include/llvm/Support/ELF.h
|
||||
include/llvm/Support/FileUtilities.h
|
||||
include/llvm/Support/GetElementPtrTypeIterator.h
|
||||
include/llvm/Support/GraphWriter.h
|
||||
include/llvm/Support/IRBuilder.h
|
||||
include/llvm/Support/InstIterator.h
|
||||
include/llvm/Support/InstVisitor.h
|
||||
include/llvm/Support/LeakDetector.h
|
||||
include/llvm/Support/ManagedStatic.h
|
||||
include/llvm/Support/Mangler.h
|
||||
include/llvm/Support/MathExtras.h
|
||||
include/llvm/Support/MemoryBuffer.h
|
||||
include/llvm/Support/MutexGuard.h
|
||||
include/llvm/Support/OutputBuffer.h
|
||||
include/llvm/Support/PassNameParser.h
|
||||
include/llvm/Support/PatternMatch.h
|
||||
include/llvm/Support/PluginLoader.h
|
||||
include/llvm/Support/Recycler.h
|
||||
include/llvm/Support/Registry.h
|
||||
include/llvm/Support/RecyclingAllocator.h
|
||||
include/llvm/Support/SlowOperationInformer.h
|
||||
include/llvm/System/Solaris.h
|
||||
include/llvm/Support/StableBasicBlockNumbering.h
|
||||
include/llvm/Support/Streams.h
|
||||
include/llvm/Support/StringPool.h
|
||||
include/llvm/Support/SystemUtils.h
|
||||
include/llvm/Support/Timer.h
|
||||
include/llvm/Support/type_traits.h
|
||||
include/llvm/SymbolTableListTraits.h
|
||||
include/llvm/System/Alarm.h
|
||||
include/llvm/System/Disassembler.h
|
||||
include/llvm/System/DynamicLibrary.h
|
||||
include/llvm/System/Host.h
|
||||
include/llvm/System/IncludeFile.h
|
||||
include/llvm/System/LICENSE.TXT
|
||||
include/llvm/System/Memory.h
|
||||
include/llvm/System/Mutex.h
|
||||
include/llvm/System/Path.h
|
||||
include/llvm/System/Process.h
|
||||
include/llvm/System/Program.h
|
||||
include/llvm/System/Signals.h
|
||||
include/llvm/System/TimeValue.h
|
||||
include/llvm/Target/SubtargetFeature.h
|
||||
include/llvm/Target/TargetAsmInfo.h
|
||||
include/llvm/Target/TargetData.h
|
||||
include/llvm/Target/TargetELFWriterInfo.h
|
||||
include/llvm/Target/TargetFrameInfo.h
|
||||
include/llvm/Target/TargetInstrDesc.h
|
||||
include/llvm/Target/TargetInstrInfo.h
|
||||
include/llvm/Target/TargetInstrItineraries.h
|
||||
include/llvm/Target/TargetJITInfo.h
|
||||
include/llvm/Target/TargetLowering.h
|
||||
include/llvm/Target/TargetMachOWriterInfo.h
|
||||
include/llvm/Target/TargetMachine.h
|
||||
include/llvm/Target/TargetMachineRegistry.h
|
||||
include/llvm/Target/TargetOptions.h
|
||||
include/llvm/Target/TargetRegisterInfo.h
|
||||
include/llvm/Target/TargetSubtarget.h
|
||||
include/llvm/Target/ELFTargetAsmInfo.h
|
||||
include/llvm/Target/DarwinTargetAsmInfo.h
|
||||
include/llvm/Transforms/IPO.h
|
||||
include/llvm/Transforms/IPO/InlinerPass.h
|
||||
include/llvm/Transforms/Instrumentation.h
|
||||
include/llvm/Transforms/RSProfiling.h
|
||||
include/llvm/Transforms/Scalar.h
|
||||
include/llvm/Transforms/Utils/BasicBlockUtils.h
|
||||
include/llvm/Transforms/Utils/BasicInliner.h
|
||||
include/llvm/Transforms/Utils/Cloning.h
|
||||
include/llvm/Transforms/Utils/FunctionUtils.h
|
||||
include/llvm/Transforms/Utils/InlineCost.h
|
||||
include/llvm/Transforms/Utils/Local.h
|
||||
include/llvm/Transforms/Utils/PromoteMemToReg.h
|
||||
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
|
||||
include/llvm/Transforms/Utils/UnrollLoop.h
|
||||
include/llvm/Transforms/Utils/ValueMapper.h
|
||||
include/llvm/Type.h
|
||||
include/llvm/TypeSymbolTable.h
|
||||
include/llvm/Use.h
|
||||
include/llvm/User.h
|
||||
include/llvm/Value.h
|
||||
include/llvm/ValueSymbolTable.h
|
||||
lib/LLVMARM.o
|
||||
lib/LLVMAlpha.o
|
||||
lib/LLVMCBackend.o
|
||||
lib/LLVMCellSPU.o
|
||||
lib/LLVMCppBackend.o
|
||||
lib/LLVMExecutionEngine.o
|
||||
lib/LLVMHello.a
|
||||
lib/LLVMHello.la
|
||||
lib/LLVMHello.so
|
||||
lib/LLVMHello.so.0
|
||||
lib/LLVMIA64.o
|
||||
lib/LLVMInterpreter.o
|
||||
lib/LLVMJIT.o
|
||||
lib/LLVMMSIL.o
|
||||
lib/LLVMMips.o
|
||||
lib/LLVMPowerPC.o
|
||||
lib/LLVMPIC16.o
|
||||
lib/LLVMSparc.o
|
||||
lib/LLVMX86.o
|
||||
lib/libLLVMAnalysis.a
|
||||
lib/libLLVMArchive.a
|
||||
lib/libLLVMAsmParser.a
|
||||
lib/libLLVMBitReader.a
|
||||
lib/libLLVMBitWriter.a
|
||||
lib/libLLVMCodeGen.a
|
||||
lib/libLLVMCore.a
|
||||
lib/libLLVMDebugger.a
|
||||
lib/libLLVMInstrumentation.a
|
||||
lib/libLLVMLinker.a
|
||||
lib/libLLVMScalarOpts.a
|
||||
lib/libLLVMSelectionDAG.a
|
||||
lib/libLLVMSupport.a
|
||||
lib/libLLVMSystem.a
|
||||
lib/libLLVMTarget.a
|
||||
lib/libLLVMTransformUtils.a
|
||||
lib/libLLVMipa.a
|
||||
lib/libLLVMipo.a
|
||||
%%DOCSDIR%%/html.tar.gz
|
||||
%%DOCSDIR%%/html/AliasAnalysis.html
|
||||
%%DOCSDIR%%/html/BitCodeFormat.html
|
||||
%%DOCSDIR%%/html/Bugpoint.html
|
||||
%%DOCSDIR%%/html/CFEBuildInstrs.html
|
||||
%%DOCSDIR%%/html/CodeGenerator.html
|
||||
%%DOCSDIR%%/html/CodingStandards.html
|
||||
%%DOCSDIR%%/html/CommandGuide/bugpoint.html
|
||||
%%DOCSDIR%%/html/CommandGuide/index.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llc.html
|
||||
%%DOCSDIR%%/html/CommandGuide/lli.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-as.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-config.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-db.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-ld.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-link.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
|
||||
%%DOCSDIR%%/html/CommandGuide/llvmgxx.html
|
||||
%%DOCSDIR%%/html/CommandGuide/manpage.css
|
||||
%%DOCSDIR%%/html/CommandGuide/opt.html
|
||||
%%DOCSDIR%%/html/CommandGuide/tblgen.html
|
||||
%%DOCSDIR%%/html/CommandLine.html
|
||||
%%DOCSDIR%%/html/CompilerDriver.html
|
||||
%%DOCSDIR%%/html/CompilerWriterInfo.html
|
||||
%%DOCSDIR%%/html/DeveloperPolicy.html
|
||||
%%DOCSDIR%%/html/ExceptionHandling.html
|
||||
%%DOCSDIR%%/html/ExtendingLLVM.html
|
||||
%%DOCSDIR%%/html/FAQ.html
|
||||
%%DOCSDIR%%/html/GCCFEBuildInstrs.html
|
||||
%%DOCSDIR%%/html/GarbageCollection.html
|
||||
%%DOCSDIR%%/html/GetElementPtr.html
|
||||
%%DOCSDIR%%/html/GettingStarted.html
|
||||
%%DOCSDIR%%/html/GettingStartedVS.html
|
||||
%%DOCSDIR%%/html/HowToReleaseLLVM.html
|
||||
%%DOCSDIR%%/html/HowToSubmitABug.html
|
||||
%%DOCSDIR%%/html/LangRef.html
|
||||
%%DOCSDIR%%/html/Lexicon.html
|
||||
%%DOCSDIR%%/html/LinkTimeOptimization.html
|
||||
%%DOCSDIR%%/html/MakefileGuide.html
|
||||
%%DOCSDIR%%/html/Passes.html
|
||||
%%DOCSDIR%%/html/ProgrammersManual.html
|
||||
%%DOCSDIR%%/html/Projects.html
|
||||
%%DOCSDIR%%/html/ReleaseNotes.html
|
||||
%%DOCSDIR%%/html/SourceLevelDebugging.html
|
||||
%%DOCSDIR%%/html/Stacker.html
|
||||
%%DOCSDIR%%/html/SystemLibrary.html
|
||||
%%DOCSDIR%%/html/TableGenFundamentals.html
|
||||
%%DOCSDIR%%/html/TestingGuide.html
|
||||
%%DOCSDIR%%/html/UsingLibraries.html
|
||||
%%DOCSDIR%%/html/WritingAnLLVMBackend.html
|
||||
%%DOCSDIR%%/html/WritingAnLLVMPass.html
|
||||
%%DOCSDIR%%/html/doxygen.css
|
||||
%%DOCSDIR%%/html/img/Debugging.gif
|
||||
%%DOCSDIR%%/html/img/libdeps.gif
|
||||
%%DOCSDIR%%/html/img/lines.gif
|
||||
%%DOCSDIR%%/html/img/objdeps.gif
|
||||
%%DOCSDIR%%/html/img/venusflytrap.jpg
|
||||
%%DOCSDIR%%/html/index.html
|
||||
%%DOCSDIR%%/html/llvm.css
|
||||
%%DOCSDIR%%/html/tutorial/JITTutorial1.html
|
||||
%%DOCSDIR%%/html/tutorial/JITTutorial2.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl1.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl2.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl3.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl4.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl5.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl6.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl7.html
|
||||
%%DOCSDIR%%/html/tutorial/LangImpl8.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl1.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl2.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl3.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl4.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
|
||||
%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
|
||||
%%DOCSDIR%%/html/tutorial/index.html
|
||||
%%DOCSDIR%%/ps/bugpoint.ps
|
||||
%%DOCSDIR%%/ps/llc.ps
|
||||
%%DOCSDIR%%/ps/lli.ps
|
||||
%%DOCSDIR%%/ps/llvm-ar.ps
|
||||
%%DOCSDIR%%/ps/llvm-as.ps
|
||||
%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
|
||||
%%DOCSDIR%%/ps/llvm-config.ps
|
||||
%%DOCSDIR%%/ps/llvm-db.ps
|
||||
%%DOCSDIR%%/ps/llvm-dis.ps
|
||||
%%DOCSDIR%%/ps/llvm-extract.ps
|
||||
%%DOCSDIR%%/ps/llvm-ld.ps
|
||||
%%DOCSDIR%%/ps/llvm-link.ps
|
||||
%%DOCSDIR%%/ps/llvm-nm.ps
|
||||
%%DOCSDIR%%/ps/llvm-prof.ps
|
||||
%%DOCSDIR%%/ps/llvm-ranlib.ps
|
||||
%%DOCSDIR%%/ps/llvmgcc.ps
|
||||
%%DOCSDIR%%/ps/llvmgxx.ps
|
||||
%%DOCSDIR%%/ps/opt.ps
|
||||
%%DOCSDIR%%/ps/tblgen.ps
|
||||
%%DATADIR%%/sorttable.js
|
||||
@dirrm include/llvm/Transforms/Utils
|
||||
@dirrm include/llvm/Transforms/IPO
|
||||
@dirrm include/llvm/Transforms
|
||||
@dirrm include/llvm/Target
|
||||
@dirrm include/llvm/System
|
||||
@dirrm include/llvm/Support
|
||||
@dirrm include/llvm/ExecutionEngine
|
||||
@dirrm include/llvm/Debugger
|
||||
@dirrm include/llvm/Config
|
||||
@dirrm include/llvm/CodeGen
|
||||
@dirrm include/llvm/Bitcode
|
||||
@dirrm include/llvm/Assembly
|
||||
@dirrm include/llvm/Analysis
|
||||
@dirrm include/llvm/ADT
|
||||
@dirrm include/llvm-c/Transforms
|
||||
@dirrm include/llvm-c
|
||||
@dirrm include/llvm
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm %%DOCSDIR%%/ps
|
||||
@dirrm %%DOCSDIR%%/html/img
|
||||
@dirrm %%DOCSDIR%%/html/tutorial
|
||||
@dirrm %%DOCSDIR%%/html/CommandGuide
|
||||
@dirrm %%DOCSDIR%%/html
|
||||
@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue