. Add a port of moria. For those too young to have played moria:

The game of moria is a single player dungeon simulation.  A player
may choose from a number of races and classes when creating a
character, and then `run' that character over a period of days,
weeks, even months, attempting to win the game by defeating the
Balrog which lurks in the deeper levels.

The player will begin his adventure on the town level where he may
acquire supplies, weapons, armor, and magical devices by bartering
with various shop owners. After preparing for his adventure, the
player can descend into the dungeons of moria where fantastic
adventures await his coming!

WWW: http://www-math.bgsu.edu/~grabine/moria.html
This commit is contained in:
Greg Lewis 2003-08-07 04:26:34 +00:00
parent 3024fe12f5
commit 3b5afbbdfb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86419
9 changed files with 197 additions and 0 deletions

View file

@ -233,6 +233,7 @@
SUBDIR += miscom
SUBDIR += moon-buggy
SUBDIR += moonlander
SUBDIR += moria
SUBDIR += mvdsv
SUBDIR += myth2_demo
SUBDIR += mythserver

36
games/moria/Makefile Normal file
View file

@ -0,0 +1,36 @@
# New ports collection makefile for: moria
# Date created: 6 August 2003
# Whom: glewis@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= moria
PORTVERSION= 5.5.2
CATEGORIES= games
MASTER_SITES= ftp://ftp.funet.fi/pub/unix/games/moria/source/ \
ftp://ftp.greyhelm.com/pub/Games/Moria/source/
DISTNAME= um${PORTVERSION}
EXTRACT_SUFX= .tar.Z
MAINTAINER= glewis@FreeBSD.org
COMMENT= A dungeon exploration game
USE_REINPLACE= yes
MAN6= moria.6
WRKSRC= ${WRKDIR}/umoria
ALL_TARGET= moria
do-configure:
for i in ${WRKSRC}/source/config.h ${WRKSRC}/unix/Makefile; do \
${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" $$i; \
done
cd ${WRKSRC} && ${LN} -sf source/* unix/* .
post-install:
for i in ${MAN6}; do \
${INSTALL_MAN} ${WRKSRC}/doc/$$i ${PREFIX}/man/man6; \
done
.include <bsd.port.mk>

1
games/moria/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (um5.5.2.tar.Z) = 04a2852864302c702e82992023d97184

View file

@ -0,0 +1,40 @@
$FreeBSD$
--- source/config.h Thu Jul 21 19:47:13 1994
+++ source/config.h Tue Aug 5 10:04:39 2003
@@ -14,7 +14,7 @@
/* Person to bother if something goes wrong. */
/* Recompile files.c and misc2.c if this changes. */
-#define WIZARD "David Grabiner"
+#define WIZARD "root"
/* The wizard password and wizard uid are no longer used. */
@@ -200,16 +200,16 @@
/* This must be unix; change MORIA_LIB as appropriate. */
#define MORIA_SAV "moria.save"
-#define MORIA_LIB(xxx) "/home/math/grabiner/moria/files/xxx"
-#define MORIA_HOU MORIA_LIB(hours)
-#define MORIA_MOR MORIA_LIB(news)
-#define MORIA_TOP MORIA_LIB(scores)
-#define MORIA_HELP MORIA_LIB(roglcmds.hlp)
-#define MORIA_ORIG_HELP MORIA_LIB(origcmds.hlp)
-#define MORIA_WIZ_HELP MORIA_LIB(rwizcmds.hlp)
-#define MORIA_OWIZ_HELP MORIA_LIB(owizcmds.hlp)
-#define MORIA_WELCOME MORIA_LIB(welcome.hlp)
-#define MORIA_VER MORIA_LIB(version.hlp)
+#define MORIA_LIB(xxx) "%%PREFIX%%/share/moria/" xxx
+#define MORIA_HOU MORIA_LIB("hours")
+#define MORIA_MOR MORIA_LIB("news")
+#define MORIA_TOP MORIA_LIB("scores")
+#define MORIA_HELP MORIA_LIB("roglcmds.hlp")
+#define MORIA_ORIG_HELP MORIA_LIB("origcmds.hlp")
+#define MORIA_WIZ_HELP MORIA_LIB("rwizcmds.hlp")
+#define MORIA_OWIZ_HELP MORIA_LIB("owizcmds.hlp")
+#define MORIA_WELCOME MORIA_LIB("welcome.hlp")
+#define MORIA_VER MORIA_LIB("version.hlp")
#endif
#endif

View file

@ -0,0 +1,42 @@
$FreeBSD$
--- source/io.c Thu Jul 21 19:47:26 1994
+++ source/io.c Tue Aug 5 09:59:14 2003
@@ -13,6 +13,10 @@
#include "config.h"
+#ifdef __FreeBSD__
+#include <sys/ioctl_compat.h>
+#endif
+
#ifdef HPUX
#include <sys/bsdtty.h>
#endif
@@ -313,7 +317,7 @@
#endif
/* PC curses returns ERR */
-#if defined(USG) && !defined(PC_CURSES) && !defined(AMIGA)
+#if (defined(USG) && !defined(PC_CURSES) && !defined(AMIGA)) || defined(__FreeBSD__)
if (initscr() == NULL)
#else
if (initscr() == ERR)
@@ -331,7 +335,7 @@
#if defined(atarist) && defined(__GNUC__)
(void) signal (SIGTSTP, (__Sigfunc)suspend);
#else
-#ifdef __386BSD__
+#if defined(__386BSD__) || defined(__FreeBSD__)
(void) signal (SIGTSTP, (sig_t)suspend);
#else
(void) signal (SIGTSTP, suspend);
@@ -757,7 +761,7 @@
msg_print("Fork failed. Try again.");
return;
}
-#if defined(USG) || defined(__386BSD__)
+#if defined(USG) || defined(__386BSD__) || defined(__FreeBSD__)
(void) wait((int *) 0);
#else
(void) wait((union wait *) 0);

View file

@ -0,0 +1,22 @@
$FreeBSD$
--- source/signals.c Thu Jul 21 19:47:42 1994
+++ source/signals.c Tue Aug 5 10:00:36 2003
@@ -89,7 +89,7 @@
/*ARGSUSED*/
#ifndef USG
-#ifdef __386BSD__
+#if defined(__386BSD__) || defined(__FreeBSD__)
static void signal_handler(sig, code, scp)
#else
static int signal_handler(sig, code, scp)
@@ -217,7 +217,7 @@
#if defined(atarist) && defined(__GNUC__)
(void) signal(SIGTSTP, (__Sigfunc)suspend);
#else
-#ifdef __386BSD__
+#if defined(__386BSD__) || defined(__FreeBSD__)
(void) signal(SIGTSTP, (sig_t)suspend);
#else
(void) signal(SIGTSTP, suspend);

View file

@ -0,0 +1,31 @@
$FreeBSD$
--- unix/Makefile.orig Thu Jul 21 16:37:08 1994
+++ unix/Makefile Wed Aug 6 16:17:52 2003
@@ -3,10 +3,10 @@
# LIBDIR must be the same directory defined in config.h
# OWNER is who you want the game to be chown to.
# GROUP is who you wnat the game to be chgrp to.
-BINDIR = /home/zariski/grabiner/moria
-LIBDIR = /home/zariski/grabiner/moria/files
-OWNER = grabiner
-GROUP = grad
+BINDIR = %%PREFIX%%/bin
+LIBDIR = %%PREFIX%%/share/moria/
+OWNER = games
+GROUP = games
# For testing and debugging the program, it is best to use this line.
# CFLAGS = -g
@@ -60,9 +60,11 @@
# you must define BINDIR and LIBDIR before installing
# assumes that BINDIR and LIBDIR exist
install:
+ -mkdir -p $(BINDIR)
chmod 755 $(BINDIR)
cp moria $(BINDIR)
chmod 4711 $(BINDIR)/moria
+ -mkdir -p $(LIBDIR)
chmod 711 $(LIBDIR)
(cd files; cp $(LIBFILES) $(LIBDIR))
(cd $(LIBDIR); chmod 444 $(LIBFILES))

13
games/moria/pkg-descr Normal file
View file

@ -0,0 +1,13 @@
The game of moria is a single player dungeon simulation. A player
may choose from a number of races and classes when creating a
character, and then `run' that character over a period of days,
weeks, even months, attempting to win the game by defeating the
Balrog which lurks in the deeper levels.
The player will begin his adventure on the town level where he may
acquire supplies, weapons, armor, and magical devices by bartering
with various shop owners. After preparing for his adventure, the
player can descend into the dungeons of moria where fantastic
adventures await his coming!
WWW: http://www-math.bgsu.edu/~grabine/moria.html

11
games/moria/pkg-plist Normal file
View file

@ -0,0 +1,11 @@
bin/moria
share/moria/hours
share/moria/news
share/moria/origcmds.hlp
share/moria/owizcmds.hlp
share/moria/roglcmds.hlp
share/moria/rwizcmds.hlp
share/moria/scores
share/moria/version.hlp
share/moria/welcome.hlp
@dirrm share/moria