- Update to 2.0.1
- Take maintainership - Added patch file to fix core dumps (will be submitted upstream) - Pass maintainership to submitter PR: ports/123564 Submitted by: Greg Larkin <glarkin@sourcehosting.net>
This commit is contained in:
parent
3098ddb17d
commit
3b776d898d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=213247
4 changed files with 81 additions and 27 deletions
|
@ -5,26 +5,27 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cvstrac
|
||||
PORTVERSION= 2.0.0
|
||||
PORTNAME?= cvstrac
|
||||
PORTVERSION= 2.0.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.cvstrac.org/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
DISTNAME= cvstrac-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Web-Based Bug And Patch-Set Tracking System For CVS
|
||||
MAINTAINER= glarkin@sourcehosting.net
|
||||
COMMENT?= Web-Based Bug And Patch-Set Tracking System For CVS
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
WRKSRC= ${WRKDIR}/cvstrac-${PORTVERSION}
|
||||
USE_SQLITE= yes
|
||||
USE_GNOME= pkgconfig
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAKE_ARGS= SRCDIR=${WRKSRC} PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
|
||||
MAKE_ARGS+= SRCDIR=${WRKSRC} PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
|
||||
|
||||
NOMAN=
|
||||
PLIST_FILES= bin/cvstrac
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/cvstrac ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (cvstrac-2.0.0.tar.gz) = 434b7c19a2990e8a3d6b17e3e97f1668
|
||||
SHA256 (cvstrac-2.0.0.tar.gz) = 7e1d4125a7624ff192016a88aa4bb1f92202f81d8bbccb4af70ec3b49207f575
|
||||
SIZE (cvstrac-2.0.0.tar.gz) = 283011
|
||||
MD5 (cvstrac-2.0.1.tar.gz) = 684bcb739eb5a6e1932fb8797ffe6a91
|
||||
SHA256 (cvstrac-2.0.1.tar.gz) = fcb703c8c4e426a0d071d0fa1f406ec3c18b0867af27c85aa3d2806bc0aca806
|
||||
SIZE (cvstrac-2.0.1.tar.gz) = 261467
|
||||
|
|
|
@ -1,11 +1,64 @@
|
|||
--- db.c.org Wed Dec 27 11:14:31 2006
|
||||
+++ db.c Wed Dec 27 11:15:09 2006
|
||||
@@ -107,6 +107,8 @@
|
||||
extern int sqlite3StrICmp(const char*, const char*);
|
||||
if( type==SQLITE_SELECT ){
|
||||
return SQLITE_OK;
|
||||
+ }else if( type==SQLITE_FUNCTION ){
|
||||
+ return SQLITE_OK;
|
||||
}else if( type==SQLITE_READ ){
|
||||
if( sqlite3StrICmp(zArg1,"user")==0 ){
|
||||
if( sqlite3StrICmp(zArg2,"passwd")==0 || sqlite3StrICmp(zArg2,"email")==0 ){
|
||||
--- db.c.orig 2008-05-09 19:34:45.288709828 -0400
|
||||
+++ db.c 2008-05-09 19:35:37.495027112 -0400
|
||||
@@ -326,7 +326,7 @@
|
||||
db_err( zErrMsg ? zErrMsg : sqlite3_errmsg(pDb), zSql,
|
||||
"db_query: Database query failed" );
|
||||
}
|
||||
- free(zSql);
|
||||
+ sqlite3_free(zSql);
|
||||
if( sResult.azElem==0 ){
|
||||
db_query_callback(&sResult, 0, 0, 0);
|
||||
}
|
||||
@@ -385,7 +385,7 @@
|
||||
db_err( zErrMsg ? zErrMsg : sqlite3_errmsg(pDb), zSql,
|
||||
"db_short_query: Database query failed" );
|
||||
}
|
||||
- free(zSql);
|
||||
+ sqlite3_free(zSql);
|
||||
return zResult;
|
||||
}
|
||||
|
||||
@@ -409,7 +409,7 @@
|
||||
if( rc!=SQLITE_OK ){
|
||||
db_err(zErrMsg, zSql, "db_execute: Database execute failed");
|
||||
}
|
||||
- free(zSql);
|
||||
+ sqlite3_free(zSql);
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -448,7 +448,7 @@
|
||||
if( rc!=SQLITE_OK ){
|
||||
db_err(zErrMsg, zSql, "db_exists: Database exists query failed");
|
||||
}
|
||||
- free(zSql);
|
||||
+ sqlite3_free(zSql);
|
||||
return iResult;
|
||||
}
|
||||
|
||||
@@ -470,6 +470,7 @@
|
||||
db_restrict_query(1);
|
||||
rc = sqlite3_exec(pDb, zSql, 0, 0, &zErrMsg);
|
||||
db_restrict_query(0);
|
||||
+ sqlite3_free(zSql);
|
||||
return (rc!=SQLITE_OK) ? zErrMsg : 0;
|
||||
}
|
||||
|
||||
@@ -538,7 +539,7 @@
|
||||
db_err(zErrMsg ? zErrMsg : sqlite3_errmsg(pDb), zSql,
|
||||
"db_callback_query: Database query failed");
|
||||
}
|
||||
- free(zSql);
|
||||
+ sqlite3_free(zSql);
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -565,7 +566,7 @@
|
||||
db_err(zErrMsg ? zErrMsg : sqlite3_errmsg(pDb), zSql,
|
||||
"db_callback_execute: Database query failed");
|
||||
}
|
||||
- free(zSql);
|
||||
+ sqlite3_free(zSql);
|
||||
}
|
||||
|
||||
/*
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
This port will install the cvstrac binary in ${PREFIX}/bin. Please follow
|
||||
the detailed installation instructions in the CVSTrac Wiki at
|
||||
http://www.cvstrac.org/cvstrac/wiki?p=CvstracInstallation for
|
||||
information on how to get CVSTrac up and running in your preferred
|
||||
|
||||
Please follow the detailed installation instructions in the CVSTrac
|
||||
Wiki at http://www.cvstrac.org/cvstrac/wiki?p=CvstracInstallation
|
||||
for information on how to get CVSTrac up and running in your preferred
|
||||
configuration.
|
||||
|
|
Loading…
Reference in a new issue