- Update to 6.05
- Regenerate patches to silence portlint warnings PR: 200290 Submitted by: tkato432 at yahoo.com
This commit is contained in:
parent
8a122b98ba
commit
3b8bf8296b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=388907
11 changed files with 142 additions and 38 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= csound
|
||||
PORTVERSION= 6.04
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 6.05
|
||||
CATEGORIES= audio lang
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION}
|
||||
PKGNAMESUFFIX= 6
|
||||
|
@ -24,10 +23,12 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
|
|||
USES= bison cmake python:2
|
||||
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
|
||||
-DBUILD_JAVA_INTERFACE:BOOL=OFF \
|
||||
-DBUILD_P5GLOVE_OPCODES:BOOL=OFF \
|
||||
-DBUILD_PD_CLASS:BOOL=OFF \
|
||||
-DBUILD_STK_OPCODES:BOOL=OFF \
|
||||
-DBUILD_TESTS:BOOL=OFF \
|
||||
-DPYTHON_MODULE_INSTALL_DIR:STRING="${PYTHONPREFIX_SITELIBDIR}"
|
||||
-DBUILD_WIIMOTE_OPCODES:BOOL=OFF \
|
||||
-DPYTHON_MODULE_INSTALL_DIR:PATH="${PYTHONPREFIX_SITELIBDIR}"
|
||||
USE_LDCONFIG= yes
|
||||
SSP_UNSAFE= yes
|
||||
|
||||
|
@ -39,7 +40,7 @@ SUB_FILES= pkg-message
|
|||
CONFLICTS= csound-5.*
|
||||
CONFLICTS_INSTALL= outguess-*
|
||||
|
||||
OPTIONS_DEFINE= ALSA CURL DSSI FLTK FLUIDSYNTH JACK LUA NLS \
|
||||
OPTIONS_DEFINE= ALSA CURL DSSI FLTK FLUIDSYNTH HDF5 JACK LUA NLS \
|
||||
OPENMP OSC PNG PORTAUDIO PULSEAUDIO
|
||||
OPTIONS_DEFAULT= FLTK OPENMP
|
||||
OPTIONS_SUB= yes
|
||||
|
@ -64,6 +65,9 @@ FLTK_CMAKE_OFF= -DBUILD_CSOUND_AC:BOOL=OFF \
|
|||
FLUIDSYNTH_DESC= Building FluidSynth opcodes
|
||||
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
|
||||
FLUIDSYNTH_CMAKE_OFF= -DBUILD_FLUID_OPCODES:BOOL=OFF
|
||||
HDF5_DESC= Build HDF5 read/write opcodes
|
||||
HDF5_LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
|
||||
HDF5_CMAKE_OFF= -DBUILD_HDF5_OPCODES:BOOL=OFF
|
||||
JACK_DESC= Build Jack I/O module and opcodes
|
||||
JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
|
||||
JACK_CMAKE_OFF= -DBUILD_JACK_OPCODES:BOOL=OFF \
|
||||
|
@ -74,21 +78,21 @@ LUA_CMAKE_OFF= -DBUILD_CSOUND_AC_LUA_INTERFACE:BOOL=OFF \
|
|||
-DBUILD_LUA_INTERFACE:BOOL=OFF \
|
||||
-DBUILD_LUA_OPCODES:BOOL=OFF
|
||||
NLS_USES= gettext
|
||||
NLS_CMAKE_OFF= -DGETTEXT_MSGFMT_EXECUTABLE="" \
|
||||
-DLIBINTL_HEADER:STRING="" \
|
||||
-DLIBINTL_LIBRARY:STRING="" \
|
||||
NLS_CMAKE_OFF= -DGETTEXT_MSGFMT_EXECUTABLE:FILEPATH="" \
|
||||
-DGETTEXT_MSGMERGE_EXECUTABLE:FILEPATH="" \
|
||||
-DLIBINTL_LIBRARY:FILEPATH="" \
|
||||
-DUSE_GETTEXT:BOOL=OFF
|
||||
OPENMP_USES= compiler:openmp
|
||||
OPENMP_USES= compiler:gcc-c++11-lib
|
||||
OPENMP_USES_OFF= compiler:c++11-lib
|
||||
OPENMP_CMAKE_OFF= -DUSE_OPEN_MP:BOOL=OFF
|
||||
OSC_DESC= Build OSC opcodes
|
||||
OSC_LIB_DEPENDS= liblo.so:${PORTSDIR}/audio/liblo
|
||||
OSC_CMAKE_OFF= -DBUILD_OSC_OPCODES:BOOL=OFF
|
||||
PNG_DESC= Build Image opcodes
|
||||
PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
|
||||
PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
|
||||
PNG_CMAKE_OFF= -DBUILD_IMAGE_OPCODES:BOOL=OFF
|
||||
PORTAUDIO_DESC= Build PortAudio I/O module
|
||||
PORTAUDIO_LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio
|
||||
PORTAUDIO_CMAKE_ON= -DUSE_PORTAUDIO:BOOL=ON
|
||||
PORTAUDIO_CMAKE_OFF= -DUSE_PORTAUDIO:BOOL=OFF
|
||||
PULSEAUDIO_DESC= Build PulseAudio I/O module
|
||||
PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:${PORTSDIR}/audio/pulseaudio
|
||||
|
@ -125,15 +129,11 @@ post-patch:
|
|||
s| dl)|)|' \
|
||||
${WRKSRC}/Opcodes/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/CMAKE_SYSTEM_NAME/s|"Linux"|"${OPSYS}"| ; \
|
||||
s|--{WINSOUND_H}|$${WINSOUND_H}|' \
|
||||
'/CMAKE_SYSTEM_NAME/s|"Linux"|"${OPSYS}"|' \
|
||||
${WRKSRC}/frontends/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e \
|
||||
's| mixer)| csmixer)|' \
|
||||
${WRKSRC}/util/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|_IS_GNUCC)|_IS_GNUCC OR __COMPILER_CLANG)|' \
|
||||
${WRKSRC}/util1/CMakeLists.txt
|
||||
|
||||
post-install:
|
||||
@${LN} -sf libcsnd6.so.6.0 ${STAGEDIR}${PREFIX}/lib/libcsnd6.so.6
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (csound/Csound6.04.tar.gz) = 0ff0203b87d10779dca962292a407e15ab0b284b558c9c63f892b74ed1e06080
|
||||
SIZE (csound/Csound6.04.tar.gz) = 23959744
|
||||
SHA256 (csound/Csound6.05.tar.gz) = 0d0ab4c1804265f4947e07c5e41ee72bc1a122b873bd77b9e7179f4c4db43a28
|
||||
SIZE (csound/Csound6.05.tar.gz) = 26208635
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- H/remote.h.orig
|
||||
--- H/remote.h.orig 2015-04-25 19:06:22 UTC
|
||||
+++ H/remote.h
|
||||
@@ -37,7 +37,10 @@
|
||||
@@ -42,7 +42,10 @@
|
||||
#ifdef MACOSX
|
||||
#include <net/if.h>
|
||||
#endif
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- InOut/rtalsa.c.orig 2011-12-22 19:41:53.000000000 +0900
|
||||
+++ InOut/rtalsa.c 2011-12-27 23:53:00.000000000 +0900
|
||||
--- InOut/rtalsa.c.orig 2015-04-25 19:06:22 UTC
|
||||
+++ InOut/rtalsa.c
|
||||
@@ -23,6 +23,7 @@
|
||||
02111-1307 USA
|
||||
*/
|
||||
|
@ -8,15 +8,15 @@
|
|||
#ifndef _ISOC99_SOURCE
|
||||
#define _ISOC99_SOURCE 1
|
||||
#endif
|
||||
@@ -39,6 +40,7 @@
|
||||
#ifndef _POSIX_C_SOURCE
|
||||
#define _POSIX_C_SOURCE 1
|
||||
@@ -32,6 +33,7 @@
|
||||
#ifndef _BSD_SOURCE
|
||||
#define _BSD_SOURCE 1
|
||||
#endif
|
||||
+*/
|
||||
|
||||
#include "csdl.h"
|
||||
|
||||
@@ -57,6 +59,8 @@
|
||||
@@ -50,6 +52,8 @@
|
||||
#include <signal.h>
|
||||
#include <sys/mman.h>
|
||||
#include <sys/resource.h>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- Opcodes/urandom.c.old 2011-01-30 02:14:59.000000000 -0600
|
||||
+++ Opcodes/urandom.c 2011-01-30 02:15:08.000000000 -0600
|
||||
--- Opcodes/urandom.c.orig 2015-04-25 19:06:23 UTC
|
||||
+++ Opcodes/urandom.c
|
||||
@@ -22,7 +22,6 @@
|
||||
*/
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Top/csound.c.orig
|
||||
--- Top/csound.c.orig 2015-04-25 19:06:23 UTC
|
||||
+++ Top/csound.c
|
||||
@@ -60,10 +60,13 @@
|
||||
#include "cs_par_dispatch.h"
|
||||
|
@ -15,8 +15,8 @@
|
|||
#if defined(USE_OPENMP)
|
||||
#include <omp.h>
|
||||
#endif /* USE_OPENMP */
|
||||
@@ -3469,7 +3473,7 @@
|
||||
/* ------------------------------------ */
|
||||
@@ -3495,7 +3498,7 @@ void csoundNotifyFileOpened(CSOUND* csou
|
||||
/* ------------------------------------ */
|
||||
|
||||
#if defined(HAVE_RDTSC)
|
||||
-#if !(defined(LINUX) && defined(__GNUC__) && defined(__i386__))
|
||||
|
@ -24,7 +24,7 @@
|
|||
#undef HAVE_RDTSC
|
||||
#endif
|
||||
#endif
|
||||
@@ -3482,6 +3486,13 @@
|
||||
@@ -3508,6 +3511,13 @@ static double timeResolutionSeconds = -1
|
||||
static int getTimeResolution(void)
|
||||
{
|
||||
#if defined(HAVE_RDTSC)
|
||||
|
@ -38,7 +38,7 @@
|
|||
FILE *f;
|
||||
char buf[256];
|
||||
|
||||
@@ -3517,9 +3528,14 @@
|
||||
@@ -3543,9 +3553,14 @@ static int getTimeResolution(void)
|
||||
}
|
||||
}
|
||||
fclose(f);
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- frontends/CsoundAC/ChordSpace.hpp.orig
|
||||
--- frontends/CsoundAC/ChordSpace.hpp.orig 2015-04-25 19:06:23 UTC
|
||||
+++ frontends/CsoundAC/ChordSpace.hpp
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <climits>
|
||||
|
@ -8,7 +8,7 @@
|
|||
#include <eigen3/Eigen/Dense>
|
||||
#include "Event.hpp"
|
||||
#include <iostream>
|
||||
@@ -545,7 +546,7 @@
|
||||
@@ -554,7 +555,7 @@ public:
|
||||
char buffer[0x1000];
|
||||
std::stringstream stream;
|
||||
for (size_t voice = 0; voice < voices(); ++voice) {
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- frontends/CsoundAC/Composition.cpp.orig
|
||||
--- frontends/CsoundAC/Composition.cpp.orig 2015-04-25 19:06:23 UTC
|
||||
+++ frontends/CsoundAC/Composition.cpp
|
||||
@@ -22,6 +22,7 @@
|
||||
#endif
|
||||
|
@ -8,7 +8,7 @@
|
|||
#include <cstdlib>
|
||||
#include <map>
|
||||
|
||||
@@ -289,7 +290,7 @@
|
||||
@@ -289,7 +290,7 @@ namespace csound
|
||||
int Composition::normalizeOutputSoundfile(double levelDb)
|
||||
{
|
||||
char buffer[0x100];
|
||||
|
@ -17,7 +17,7 @@
|
|||
0x100,
|
||||
"sox %s -V3 -b 32 -e floating-point %s gain -n %f\n",
|
||||
getOutputSoundfileName().c_str(),
|
||||
@@ -307,7 +308,7 @@
|
||||
@@ -307,7 +308,7 @@ namespace csound
|
||||
int Composition::translateToCdAudio(double levelDb)
|
||||
{
|
||||
char buffer[0x100];
|
||||
|
@ -26,7 +26,7 @@
|
|||
getOutputSoundfileName().c_str(),
|
||||
getCdSoundfileName().c_str(),
|
||||
levelDb);
|
||||
@@ -323,7 +324,7 @@
|
||||
@@ -323,7 +324,7 @@ namespace csound
|
||||
int Composition::translateToMp3(double bitrate, double levelDb)
|
||||
{
|
||||
char buffer[0x100];
|
||||
|
|
|
@ -0,0 +1,89 @@
|
|||
--- frontends/CsoundAC/Counterpoint.cpp.orig 2015-04-25 19:06:23 UTC
|
||||
+++ frontends/CsoundAC/Counterpoint.cpp
|
||||
@@ -217,8 +217,8 @@ void Counterpoint::toCsoundScore(std::st
|
||||
delete uniform_real_generator;
|
||||
}
|
||||
int Counterpoint::ABS(int i) {if (i < 0) return(-i); else return(i);}
|
||||
- int Counterpoint::MIN(int a, int b) {if (a < b) return(a); else return(b);}
|
||||
- int Counterpoint::MAX(int a, int b) {if (a > b) return(a); else return(b);}
|
||||
+ int Counterpoint::IMIN(int a, int b) {if (a < b) return(a); else return(b);}
|
||||
+ int Counterpoint::IMAX(int a, int b) {if (a > b) return(a); else return(b);}
|
||||
void Counterpoint::ARRBLT(int *dest, int *source, int num) {int i; for (i=0;i<num;i++) dest[i]=source[i];} /* SAIL p51 */
|
||||
|
||||
int Counterpoint::InMode(int Pitch, int Mode)
|
||||
@@ -294,8 +294,8 @@ void Counterpoint::toCsoundScore(std::st
|
||||
for (i=1;i<Cn;i++)
|
||||
{
|
||||
pit=Us(i,v);
|
||||
- Minp=MIN(Minp,pit);
|
||||
- Maxp=MAX(Maxp,pit);
|
||||
+ Minp=IMIN(Minp,pit);
|
||||
+ Maxp=IMAX(Maxp,pit);
|
||||
}
|
||||
return(Maxp-Minp);
|
||||
}
|
||||
@@ -316,7 +316,7 @@ void Counterpoint::toCsoundScore(std::st
|
||||
{
|
||||
int j,LowestPitch;
|
||||
LowestPitch=Cantus(Cn,v);
|
||||
- for (j=1;j<v;j++) LowestPitch=MIN(LowestPitch,Other(Cn,v,j));
|
||||
+ for (j=1;j<v;j++) LowestPitch=IMIN(LowestPitch,Other(Cn,v,j));
|
||||
return(LowestPitch);
|
||||
}
|
||||
|
||||
@@ -993,7 +993,7 @@ void Counterpoint::toCsoundScore(std::st
|
||||
/* slightly frown upon leap back in the opposite direction */
|
||||
if ((Cn>2) && ((ASkip(MelInt)) && ((ASkip(LastMelInt)) && (!(SameDir)))))
|
||||
{
|
||||
- Val += (MAX(0,((ABS(MelInt)+ABS(LastMelInt))-8)));
|
||||
+ Val += (IMAX(0,((ABS(MelInt)+ABS(LastMelInt))-8)));
|
||||
if ((Cn>3) && (ASkip(LastCp2-LastCp3))) Val += ThreeSkipsPenalty;
|
||||
}
|
||||
|
||||
@@ -1009,7 +1009,7 @@ void Counterpoint::toCsoundScore(std::st
|
||||
if ((Us(k,v)-Cantus(k,v))*(Us(k-1,v)-Cantus(k-1,v)) < 0) Cross++;
|
||||
}
|
||||
}
|
||||
- if (Cross > 0) Val += (MAX(0,((Cross-2)*3)));
|
||||
+ if (Cross > 0) Val += (IMAX(0,((Cross-2)*3)));
|
||||
|
||||
/* don't repeat note on upbeat */
|
||||
if (UpBeat(Cn,v) && (MelInt == Unison)) Val += RepetitionOnUpbeatPenalty;
|
||||
@@ -1107,7 +1107,7 @@ void Counterpoint::toCsoundScore(std::st
|
||||
}
|
||||
}
|
||||
BestFitPenalty=CurrentPenalty+Penalty;
|
||||
- MaxPenalty=MIN(int(BestFitPenalty*PenaltyRatio),MaxPenalty);
|
||||
+ MaxPenalty=IMIN(int(BestFitPenalty*PenaltyRatio),MaxPenalty);
|
||||
/* AllDone=1; */
|
||||
Fits[2]=Fits[1]; Fits[1]=Fits[0]; Fits[0]=BestFitPenalty;
|
||||
for (v=1;v<=v1;v++)
|
||||
@@ -1164,7 +1164,7 @@ void Counterpoint::toCsoundScore(std::st
|
||||
{
|
||||
for (i=1;i<=NumParts;i++) Pens[x-i]=Is[i];
|
||||
}
|
||||
- else NewLim=MIN(NewLim,penalty);
|
||||
+ else NewLim=IMIN(NewLim,penalty);
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -1196,7 +1196,7 @@ void Counterpoint::toCsoundScore(std::st
|
||||
for (i=0;i<=NumParts;i++)
|
||||
{
|
||||
OurTime=Onset(VIndex(CurTime,i)+1,i);
|
||||
- if (OurTime != 0) NextTime=MIN(NextTime,OurTime);
|
||||
+ if (OurTime != 0) NextTime=IMIN(NextTime,OurTime);
|
||||
}
|
||||
for (i=1;i<=NumParts;i++)
|
||||
{
|
||||
@@ -1289,8 +1289,8 @@ void Counterpoint::toCsoundScore(std::st
|
||||
{
|
||||
int i;
|
||||
i=(int)(RANDOM(10.0));
|
||||
- if (CurRhy(i) > CurRhy(MAX(1,(i-1)))) return(MAX(1,(i-1)));
|
||||
- if (CurRhy(i) <= CurRhy(MIN(9,(i+1)))) return(MIN(9,(i+1)));
|
||||
+ if (CurRhy(i) > CurRhy(IMAX(1,(i-1)))) return(IMAX(1,(i-1)));
|
||||
+ if (CurRhy(i) <= CurRhy(IMIN(9,(i+1)))) return(IMIN(9,(i+1)));
|
||||
return(i);
|
||||
}
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
--- frontends/CsoundAC/Counterpoint.hpp.orig 2015-04-25 19:06:23 UTC
|
||||
+++ frontends/CsoundAC/Counterpoint.hpp
|
||||
@@ -102,8 +102,8 @@ public:
|
||||
Counterpoint();
|
||||
virtual ~Counterpoint();
|
||||
int ABS(int i);
|
||||
- int MIN(int a, int b);
|
||||
- int MAX(int a, int b);
|
||||
+ int IMIN(int a, int b);
|
||||
+ int IMAX(int a, int b);
|
||||
void ARRBLT(int *dest, int *source, int num);
|
||||
enum
|
||||
{
|
|
@ -70,6 +70,7 @@ lib/csound/plugins-6.0/libexciter.so
|
|||
lib/csound/plugins-6.0/libfareygen.so
|
||||
%%FLUIDSYNTH%%lib/csound/plugins-6.0/libfluidOpcodes.so
|
||||
lib/csound/plugins-6.0/libfractalnoise.so
|
||||
%%HDF5%%lib/csound/plugins-6.0/libhdf5.so
|
||||
%%PNG%%lib/csound/plugins-6.0/libimage.so
|
||||
lib/csound/plugins-6.0/libipmidi.so
|
||||
%%JACK%%lib/csound/plugins-6.0/libjackTransport.so
|
||||
|
@ -77,6 +78,7 @@ lib/csound/plugins-6.0/libipmidi.so
|
|||
lib/csound/plugins-6.0/liblinear_algebra.so
|
||||
lib/csound/plugins-6.0/libmixer.so
|
||||
%%OSC%%lib/csound/plugins-6.0/libosc.so
|
||||
lib/csound/plugins-6.0/libpadsynth.so
|
||||
lib/csound/plugins-6.0/libplaterev.so
|
||||
lib/csound/plugins-6.0/libpy.so
|
||||
%%ALSA%%lib/csound/plugins-6.0/librtalsa.so
|
||||
|
|
Loading…
Reference in a new issue